locked
504 error time-out- Inbound calls to Skype for Business 2015 RRS feed

  • Question

  • Hello Wizards,

    I am working on an integration between SFB 2015 installed in lab with a 3rd party contact centre solution.

    We have a 3 server FE Pool and a 2 server Mediation pool. The set up is as follows:

    FE Server<---->Mediation Server<----->SBC<----->Contact Centre Platform

    Inbound calls are being load balanced by the Mediation servers and forwarded to the FE servers in the pool. I am receiving issues on the inbound calls where the calls are successful if the call is processed by FE03, however calls fail and return 504 time-out error if the INVITE is sent to the other two FE servers in the pool. The bad call has the following error message returned fro FE01 server in the pool:

    TL_INFO(TF_PROTOCOL) [med-pool01\med01]096C.3314::12/05/2017-14:16:41.687.000123A0

    (S4,SipMessage.DataLoggingHelper:sipmessage.cs(801)) [1007823223]
    <<<<<<<<<<<<Incoming SipMessage c=[<SipTlsConnection_609E6D>], XX.XX.XX.52:57448<-XX.XX.XX.36:5061
    SIP/2.0 504 Server time-out
    FROM: "XXX334693"<sip:XXX334693;phone-

    http://www.microsoft.com/LCS/UserServices";source="fe01.XX.XX.XX"
    ms-application-via: ms-udc.cdr%3D79d277983017952a2ee2f102004843bf%3A5;ms-pool=fe-pool01.XX.XX.XX;ms-

    application=http%3A%2F%2Fwww.microsoft.com%2FLCS%2FUdcAgent;ms-server=fe01.XX.XX.XX

    From the above error I am assuming there is an issue with Userservices module on FE server and it probably requires a service restart or maybe reinstall FE server if that doesn't work?

    Is there anything else anyone can point me to on what could be done to fix this issue?

    Thanks,

    Imran

    Wednesday, December 6, 2017 9:16 AM

All replies

  • Full error log here, realized I missed something.

    TL_INFO(TF_PROTOCOL) [med-pool01\med01]096C.3314::12/05/2017-14:16:41.687.000123A0

    (S4,SipMessage.DataLoggingHelper:sipmessage.cs(801)) [1007823223]
    <<<<<<<<<<<< Incoming SipMessage c=[<SipTlsConnection_609E6D>], XX.XX.XX.52:57448<-XX.XX.XX.36:5061
    SIP/2.0 504 Server time-out
    FROM: "XXX334693"<sip:XXX334693;phone-

    http://www.microsoft.com/LCS/UserServices";source="fe01.xx.xx.xx"
    ms-application-via: ms-udc.cdr%3D79d277983017952a2ee2f102004843bf%3A5;ms-pool=fe-pool01.XX.XX.XXl;ms-application=http%3A%2F%2Fwww.microsoft.com%2FLCS%2FUdcAgent;ms-server=fe01.XX.XX.XX

    Wednesday, December 6, 2017 9:22 AM
  • First of all, you would need to check if there is any firewall/network filtering that you didn't aware between Med and 2 other FE servers?

    To me it looks like a firewall issue, Server time-out surfaced once it's connecting to .36 via port 5061.

    Incoming SipMessage c=[<SipTlsConnection_609E6D>], XX.XX.XX.52:57448<-XX.XX.XX.36:5061

    SIP/2.0 504 Server time-out


    • Edited by ThettNaing Wednesday, December 6, 2017 3:32 PM
    Wednesday, December 6, 2017 3:30 PM
  • Hi Skype-imran,

    Agree with Matrix.

    You could close the fireware on the FE server and SFB client ,to make a test.

    Close the load balance ,route the call to the FE01 server directly.

    Compare the certificates between FE01 server and FE03 server.


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, December 7, 2017 5:55 AM
  • Thanks Leon & Matrix,

    There is no firewall between Mediation Server and FE as this is a lab environment.

    Do you want me to disable the Windows firewall on both FE and SFB client and try out?

    Certificates seem fine though.

    There is DNS load balancing configured. So I removed the DNS entries of FE01 and FE02 from fe-pool so the mediation server routes the call only to FE03 server configured in the pool. I am still getting the same result. Out of 10 calls, 6 are failing and 4 successful.

    Thanks,
    Imran


    • Edited by Skype-imran Thursday, December 7, 2017 5:12 PM adding further
    Thursday, December 7, 2017 4:46 PM
  • Hi,

    Yes ,you could close your firewall on FE server and client ,make a test in your lab environment.


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, December 8, 2017 9:16 AM
  • Thanks Leon,

    I removed the DNS entries pointing to the 2 FE servers so the pool only points to the "working" FE. Also disabled Windows firewall from the 2 FE servers. Calls are 100% successful now as they are only landing on the "working" FE and not the other 2. It is just a good workaround so we could proceed with the testing, however I am not sure what else we could do to the other 2 servers to be able to get them to process calls successfully.

    Thanks,
    Qader

    Monday, December 11, 2017 7:18 PM
  • Hi Skype-imran ,

     

    Now ,you could try to following scenarios.

     

    Scenarios 1: You could add the DNS entries pointing to the 2 FE servers(not working),remove the “working “ FE . Also disabled Windows firewall from the 2 FE servers. If it doesn’t work ,please check the DNS record like the following table.

    Description

    Record type

    Name

    Resolves to

    Load balancing type

    Pool FQDN

    A

    pool.contoso.local

    IP address of server SFB01

    DNS

    SFB01 FQDN

    A

    SFB01.contoso.local

    IP address of server SFB01

    DNS

    Pool FQDN

    A

    pool.contoso.local

    IP address of server SFB02

    DNS

    SFB02 FQDN

    A

    SFB02.contoso.local

    IP address of server SFB02

    DNS

    Pool FQDN

    A

    pool.contoso.local

    IP address of server SFB03

    DNS

    SFB03 FQDN

    A

    SFB03.contoso.local

    IP address of server SFB03

    DNS

     

    If Scenarios 1 could work, you could try to Scenarios 2.

    Scenarios 2:the problem is relate to the port ,please enable windows firewall from the 2 FE servers and check the ports between FE servers,you could check ports like the following link and use “telnet” check the port.

    https://technet.microsoft.com/en-us/library/gg398833.aspx


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, December 12, 2017 1:52 AM
  • Are there any update for this issue, if the reply is helpful to you, please try to mark it as an answer, it will help others who has similar issue.

    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, December 13, 2017 9:07 AM
  • Hi Leon,

    Post that successful testing, I enabled the Windows firewall and continued testing. It did work(although I did not reinstate the DNS entries pointing to "non-working" FE servers yet). As Christmas is approaching and we have an impending change freeze, we quickly want to test few scenarios and prove the call flows work therefore I wouldn't be testing further with the changes you mentioned above.

    Following is a screenshot of how the DNS entries were setup before. fe-pool01 now points to only .38 IP address.

    Also I did not understand your statement here: "check the ports between FE servers,you could check ports like the following link and use “telnet” check the port"

    Could you elaborate on this please?

    Appreciate your help!

    Thanks,
    Imran

    Thursday, December 14, 2017 10:04 AM
  • Hi,

    if you want to use telnet to test the FE port ,if it is open ,for example i use telnet to test port 5061 of FE server  if it is open like  the following picture.

    if the port 5061 is open,you will receive the result like the following picture.

    if the port not open ,you will receive the result like the following picture.

    if you want to use the cmd(must enable this feature) ,you could refer to the following link.

    https://www.labnol.org/software/windows-telnet-command/18222/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, December 19, 2017 10:50 AM
  • Are there any update for this issue, if the reply is helpful to you, please try to mark it as an answer, it will help others who has similar issue.


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, December 21, 2017 12:24 PM