none
Win7 Pro OEM Upgrade to Win10 Ent 1703 RRS feed

  • Question

  • Attempting to do a MDT Upgrade install on several Lenovo desktops. MDT Upgrade sequence fails everytime.  I tried to do a manual upgrade using the ISO and I get the error "Setup has failed to validate the Product key"

    On the machine I ran slmgr.vbs /dlv and its a licensed activated oem_coa_slp .

    The exact same computer, I did a P2V into ESX / vSphere and it upgrades just fine.  I actually used a snapshot and have rolled back and upgradeded it several times.  

    So what am I missing here?  

    My next step is to try different media.  

    Since I have several machines with this error, on one machine I ran slmgr.vbs /upk.  Now I have an unlicensed, unattractive Win7 that I can not upgrade.  But I don't care.  

    What I do want is to fix whatever block where it can not validate my license key, and I can proceed to upgrade.  Secondly I'd like to know why the P2V instance works.  

    Any help here ?

    Jeremy

    Wednesday, September 20, 2017 3:40 PM

All replies

  • Have you taken a look at the Windows upgrade log files located in C:\$Windows.~BT? While I myself did not encounter this error message I remember reading some posts a while ago in which log analysis pointed to totally different cause, like a file being already present on the system. In those cases setup.exe was unable to create a file and error out displaying the error message you ran into.

    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Wednesday, September 20, 2017 4:21 PM
  • Here is my SetupErr.log

    2017-09-20 09:25:23, Error                 MOUPG  CSystemHelper::CheckConnectedStandby(642): Result = 0x80070057
    2017-09-20 09:25:32, Error                        SPGetWIMImageInfo: Failed to extract software hive from WIM image. Error: 0x80070522[gle=0x00000522]
    2017-09-20 09:25:32, Error                        Failed to get image information for C:\WIN_ENT_10_1703.1_64BIT\Sources\Install.wim, image 1. Error: 0x80070522[gle=0x00000012]
    2017-09-20 09:25:32, Error                 MOUPG  CDlpActionProductKeyValidate::PopulateImageInfoSet(2841): Result = 0x80070522
    2017-09-20 09:25:32, Error                 MOUPG  CDlpActionProductKeyValidate::ReportDownlevelInstallChannel(2947): Result = 0x80070522
    2017-09-20 09:25:32, Error                 MOUPG  ProductKey: Failed to report Host OS channel to telemetry.
    2017-09-20 09:25:33, Error                        SPGetWIMImageInfo: Failed to extract software hive from WIM image. Error: 0x80070522[gle=0x00000522]
    2017-09-20 09:25:33, Error                        Failed to get image information for C:\WIN_ENT_10_1703.1_64BIT\Sources\Install.wim, image 1. Error: 0x80070522[gle=0x00000012]
    2017-09-20 09:25:33, Error                 MOUPG  CDlpActionProductKeyValidate::PopulateImageInfoSet(2841): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CDlpActionProductKeyValidate::ValidateProductKeyFromWim(1744): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CDlpActionProductKeyValidate::SearchForValidProductKey(1119): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CDlpActionProductKeyValidate::ExecuteRoutinePkeyValidate(429): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CDlpActionProductKeyValidate::ExecuteRoutine(376): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CDlpActionImpl<class CDlpErrorImpl<class CDlpObjectInternalImpl<class CUnknownImpl<class IProductKeyAction> > > >::Execute(441): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CDlpTask::ExecuteAction(3243): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CDlpTask::ExecuteActions(3397): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CDlpTask::Execute(1631): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CSetupManager::ExecuteTask(2083): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CSetupManager::ExecuteTask(2046): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CSetupManager::ExecuteInstallMode(745): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CSetupManager::ExecuteDownlevelMode(396): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CSetupManager::Execute(232): Result = 0x80070522
    2017-09-20 09:25:33, Error                 MOUPG  CSetupHost::Execute(368): Result = 0x80070522


    Jeremy

    Wednesday, September 20, 2017 5:06 PM
  • After much testing and troubleshooting, I have determined that I can disjoin the domain, rename the computer, rejoin the domain and the upgrade will work.  This indicates that there is something on the AD Computer object preventing the upgrade from working. 

    Its a nasty workaround, but it does work. 


    Jeremy

    Thursday, September 21, 2017 3:20 PM
  • Any chance someone has found an alternate solution?  We are now experiencing this in a large enterprise environment with all laptops and desktops failing the IPU to Windows 10 1703.  VMs have no issues upgrading.  Our Panther logs are identical.
    Wednesday, February 21, 2018 9:26 PM