none
OWA not displaying login page in IE RRS feed

  • Question

  • OWA gives you the option to continue when it says there is a certificate error, which it's always done.  However, now when you click continue; the OWA webpage does not display properly.  In IE it just shows a blank page, in Google Chrome it only shows text but no graphics.  Allows you to login in with Chrome, but again just shows text.  The only thing I've done recentlly is added a DC.  Email comes in just fine in Outlook.  We are using Exchange Server 2007 running on Windows 2008 Server Standard.  I've rebooted a couple of times and that does not fix the issue.

    Saturday, October 13, 2012 12:31 PM

Answers

All replies

  • Hello,

    Look at this post. It states that the issue could be cause by updates in Windows, SP1 or SP2 rollups.

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrclients/thread/4655b89e-9897-4205-a23a-45cbccde616f/

    I also read another post where it was fixed by resetting the OWA virtual directory using remove-owavirtualdirectory and new-owavirtualdirectory cmdlets.

    Are there any errors on your application logs?


    Miguel Fra | Falcon IT Services, Miami, FL
    www.falconitservices.com | www.falconits.com | Blog

    Saturday, October 13, 2012 3:12 PM
  • Hello,

    The issue happen on a user or many users. If a user have the issue, please login in owa with another computer.

    If many users have the issue, please follow the falcon‘s suggestion to recreate owa virtual directory.


    Cara Chen

    TechNet Community Support


    Monday, October 15, 2012 6:36 AM
    Moderator
  • I have not tried the resetting the OWA virtual directory yet.  Wanted to let you see the error first.

    I see this error under windows logs-application:

    Source: ESE

    Event ID: 467

    MSExchangeIS (2600) First Storage Group: Database C:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox Database.edb: Index FidDeleteTimeIndex of table IndexAge is corrupted (0).

    Monday, October 15, 2012 3:14 PM
  • I tried the remove- owavirtual directory and this is what I get:

    [PS] C:\Windows\System32>remove-owavirtualdirectory -identity "exchange\owa (def

    ualt web site)"

    Remove-OwaVirtualDirectory : The operation could not be performed because objec

    t 'exchange\owa (defualt web site)' could not be found on domain controller 'DC

    -108K-01.bossiercityarena.local'.

    At line:1 char:27

    + remove-owavirtualdirectory  <<<< -identity "exchange\owa (defualt web site)"

    I tried the new-owavirtualdirectory and this is what I get:

    [PS] C:\Windows\System32>new-owavirtualdirectory -name "exchange\owa (default we

    b site)"

    New-OwaVirtualDirectory : The virtual directory 'owa' already exists under 'EXC

    HANGE.bossiercityarena.local/Default Web Site'.

    Parameter name: VirtualDirectoryName

    At line:1 char:24

    + new-owavirtualdirectory  <<<< -name "exchange\owa (default web site)"

    what am I doing wrong in removing the owa virtual directory?

    Sunday, October 21, 2012 2:48 AM
  • The operation could not be performed because object 'exchange\owa (defualt web site)' could not be found on domain controller 'DC-108K-01.bossiercityarena.local'.

    The virtual directory 'owa' already exists under 'EXC

    HANGE.bossiercityarena.local/Default Web Site'.

    Hello again.

    Did you use use the -identity command and specify the server Exchange?  Looks like you may have spelled default wrong as well.

    Remove-OwaVirtualDirectory -Identity "Exchange\owa (default Web site)"


    Miguel Fra | Falcon IT Services, Miami, FL
    www.falconitservices.com | www.falconits.com | Blog

    Sunday, October 21, 2012 3:24 AM
  • Thank you for catching the misspelling.... after recreating the OWA Virtual Directory, you can see the login page now and see the email page after you log in.... however where there should be graphics there are small squares with a red x.... also you cannot select any emails.... thoughts?
    Monday, October 22, 2012 1:32 PM
  • Hello,

    Are you connecting using https? Is the virtual directory security tab for restrictive permissions and also on the documents tab check that Default.htm is set instead of logon.asp?

    Open the EMS

    Navigate to C:\Program Files\Microsoft\Exchange Server\Bin

    Run the UpdateOWA.ps1 script (done by entering .\UpdateOWA.ps1)


    Miguel Fra | Falcon IT Services, Miami, FL
    www.falconitservices.com | www.falconits.com | Blog

    Monday, October 22, 2012 1:47 PM
  • running the updateowa.ps1 script fixed it... thank you for all your help.
    Monday, October 22, 2012 1:57 PM
  • You are welcome. Glad it worked.

    Miguel Fra | Falcon IT Services, Miami, FL
    www.falconitservices.com | www.falconits.com | Blog

    Monday, October 22, 2012 2:21 PM