none
Error installing KB 978864 (Error 1603) RRS feed

  • Question

  • I am receiving error 1603 when attempting to install FIM Update 1 (KB 978864).  I am trying to upgrade from FIM 4.0.2592.0 to 4.0.3531.2, and am getting this error.  I was successfully able to update the sync service, but not the portal.  I have made sure that the SQL Native Client is installed, and I am running as the same user that performed the original install.
    Managing Partner
    Wednesday, January 26, 2011 3:57 PM

Answers

  • Hey Larry,

    Did you try the repair installation option in the existing version of the service that is deployed? I did that in one environment and then was able to apply the hotfix without a problem.

    Thanks

    B

    • Marked as answer by Larry Aucoin Thursday, January 27, 2011 8:33 PM
    Thursday, January 27, 2011 8:19 PM

All replies

  • Hi Larry,

    I have to admit, I had received a similar error before when I was doing an installation and no matter what I did, it seemed to continue to fail. I did a "repair" install of the FIM Service/Portal and the installation worked again on the next attempt. Hopefully this will help you out.

    Thanks

    B

    Thursday, January 27, 2011 2:27 PM
  • When that happened to me, it turned out that my login info that runs the services wasn't in the correct format.  The default install had it like:  servicename@domain.net, but it needed to be domain\servicename.

    It didn't make a lot of sense to me, but after changing it, it worked.

     

    • Proposed as answer by MDordoy Monday, December 12, 2011 3:49 PM
    Thursday, January 27, 2011 3:53 PM
  • That's a good fix. My service had the format you noted but the repair worked which is interesting as well... Hmmm... another item for the toolbox!

    Thanks!

    B

    Thursday, January 27, 2011 4:08 PM
  • My "Manager Service" was in the correct format (DOMAIN\User), but my "Manager Password Reset Client Service" was not.  I changed the wrong one and tried the update again, but getting the same error.
    Thursday, January 27, 2011 7:02 PM
  • Are you installing the update commandline or just by clicking it and doing next next...

    I had an update which I just couldn't get installed commandline (definately had the right syntax + elevated) but which installed just fine if I went to the graphical setup.


    http://setspn.blogspot.com
    Thursday, January 27, 2011 7:57 PM
  • Using GUI.  Same user as initial install + running as Administrator.  I see a few pop-ups, then the roll-back process.
    Thursday, January 27, 2011 8:14 PM
  • I'm not sure whether there's a logfile to some default location. Don't you see anything extra usefull in the event log? Or in the setup log (event log too)?

    Besides that. As an other option: try starting a command prompt as an adminstrator and then just type "name_of_installer" and enter. This will start the setup graphically but in the elevated context.


    http://setspn.blogspot.com
    Thursday, January 27, 2011 8:16 PM
  • Hey Larry,

    Did you try the repair installation option in the existing version of the service that is deployed? I did that in one environment and then was able to apply the hotfix without a problem.

    Thanks

    B

    • Marked as answer by Larry Aucoin Thursday, January 27, 2011 8:33 PM
    Thursday, January 27, 2011 8:19 PM
  • Blain,

    That did it.  I just needed to repair the base install, then I was able to apply update 1.  Thanks for your suggestion!

    -Larry

    Thursday, January 27, 2011 8:35 PM
  • You might use advanced MSI logging to get more specific information but what this sounds like is certificate problem. If you run FIM install and don't use the option for self-signed certificate, the subject name needs to be ForefrontIdentityManager. Anything else results in error. The fix is to run through change mode install, most users choose self signed cert here, then they are able to update to new version. This sounds like what is going on here. You can verify this by running command such as

     

    MSIEXEC /update <updatepackage.msp> /l*v <logfile>

     

    Look for string such as 'return value 3' and see if there is function name there that has to do with certificate thumbprint.

     

    • Proposed as answer by KotFrBursa Sunday, April 17, 2011 7:22 PM
    Thursday, January 27, 2011 9:43 PM
  • I was also receiving error 1603 with Update 1 on a FIM Portal 2008 R2 server even though I was logged in with the same local administrator account that did the initial RC1 install (FIM 4.0.2592.0 to 4.0.3531.2). I initially tried the repair option suggested above. Update 1 would still not install.

    The MS download is a self installing exe, it may seem obvious, however, make sure you right click on the .exe and select 'Run as Administrator' instead of double clicking on the executable. Once I did this, the update ran successfully. I also assume this applies to Update 2.

     



    Sunday, April 17, 2011 12:48 AM
  • You might use advanced MSI logging to get more specific information but what this sounds like is certificate problem. If you run FIM install and don't use the option for self-signed certificate, the subject name needs to be ForefrontIdentityManager. Anything else results in error. The fix is to run through change mode install, most users choose self signed cert here, then they are able to update to new version. This sounds like what is going on here. You can verify this by running command such as

     

    MSIEXEC /update <updatepackage.msp> /l*v <logfile>

     

    Look for string such as 'return value 3' and see if there is function name there that has to do with certificate thumbprint.

     

    Thank you.

    Your answer very helpful. We had this problem, and when issued certificate for FIM with cn=ForefrontIdentityManager update finished sucsessfuly.

    Sunday, April 17, 2011 7:20 PM
  • You rock! This solved the problem for me! It troubled me for at least 5 hours! Thank you!
    Thursday, September 15, 2016 9:01 AM