locked
Windows Store won't load on Windows 8.1 Enterprise RRS feed

  • Question

  • Cross post from http://answers.microsoft.com/en-us/windows/forum/windows8_1-windows_store/windows-store-wont-load-on-windows-81-enterprise/f7df5e80-ff03-493f-bbd6-b7ce7646923b

    In the past week I have been unable to launch the Windows Store app. It just opens and spins endlessly on the loading screen.

    I'm not sure if its related, but in the last week my company had DNS issues that they fixed, although I'm not sure what was involved in the fix.

    I have searched and tried numerous fixes at this point and no result and am close to doing a Windows Refresh and starting over but I'm worried about losing saved app data specific to games or apps that will be lost that I believe is saved locally.

    I have tried:

    Running the App troubleshoot for Windows app - Which it tells me Service Registration is missing or corrupt. Digging in it says the BITS is already started which is why it couldn't be restarted.

    Running the Windows Update Troubleshooter if found and fixed issues with BITS (service is already started) one with a RootCause of RC_DataStore and error code 0x80070057

    Running the Microsoft Account Troubleshooter - Gave me a "Can’t connect to Sync service" and "Rootcauses found and created logs" Although I suspect its because my work blocks MS sync which is why I am unable to sign into xbox live services at work. Store still doesn't work on home network.

    I have verified that I am not using a proxy server for LAN

    I have tried Wsreset.exe - Just spins still

    I have sfc /scannow - Told me it found corrupt files but was unable too fix all of them. Looking at the log file it says I had 1 CSI Payload Corruption which was not fixed.

    "amd64_prncacla.inf_31bf3856ad364e35_6.3.9600.16384_none_9590ba64d5b91f79\Amd64\CNBJ2530.DPB
    Repair failed: Missing replacement payload."

    Tried a different user, both microsoft and local as well as un-linking and linking the MS account to my domain account.

    Tried running powershell command: "powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml"

    Verified I have no Windows updates to install and tried to use the command line to install updates behind the scenes.

    Checked my date and time was correct.

    Anything in this list that looks suspicious or anything else I can try?

    Monday, September 12, 2016 10:00 PM

All replies

  • Hello,

    Suggest you to try additional suggestions mentioned here, see if they helps you:

    http://www.kapilarya.com/service-registration-is-missing-or-corrupt-in-windows-10

    Hope this helps, Good luck :)

    Windows Insider MVP | Windows troubleshooting and how-to guides - http://www.kapilarya.com

    Tuesday, September 13, 2016 2:15 AM
  • Hi MoneyShot360,

    We could run chkdsk /r from an elevated command prompt and restart Windows. When the disk check has finished, run again the sfc /scannow command.

    Please refer to the link below to get more information.

    https://blogs.technet.microsoft.com/askperf/2013/10/11/what-to-do-if-your-windows-8-modern-app-fails-to-start/

    Hope it will be helpful to you


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 13, 2016 9:24 AM
  • Unfortunately the chkdsk /r, then restart then sfc /scannow resulted in the same "found corrupt files but was unable to fix some of them.

    In the log file, among other things I found this, is this related, or should I look for something else in the log file?

    2016-09-15 19:28:05, Info                  CBS    Client specifies store corruption detect and repair.
    2016-09-15 19:28:05, Info                  CBS    Exec: Session processing started.  Client: DISM Package Manager Provider, Session(Store Corruption Detect/Repair): 30543793_822664421
    2016-09-15 19:28:05, Info                  CBS    Reboot mark set
    2016-09-15 19:28:05, Info                  CBS    Winlogon: Registering for CreateSession notifications
    2016-09-15 19:28:29, Info                  CBS    Repr: CBS Store check completes
    2016-09-15 19:28:29, Info                  CSI    0000000f StoreCorruptionRepair transaction begun. WcpVersion: [l:82{41}]"6.3.9600.18384 (winblue_ltsb.160621-0600)".
    2016-09-15 19:28:29, Info                  CSI    00000010@2016/9/16:00:28:29.586 Starting corruption detection (InnerFlags=5)
    2016-09-15 19:35:37, Info                  CSI    00000011 Hashes for file member \SystemRoot\WinSxS\amd64_prncacla.inf_31bf3856ad364e35_6.3.9600.16384_none_9590ba64d5b91f79\Amd64\CNBJ2530.DPB do not match actual file [l:36{18}]"Amd64\CNBJ2530.DPB" :
      Found: {l:32 b:zsnCbV7FSllkjDEr1tMgQu+DL9sO5dQiERwgQzncj4k=} Expected: {l:32 b:n520k714Uu3utHa5JGQ6HQYbZphKhlMWq5pEmfnCDuw=}
    2016-09-15 19:35:46, Info                  CSI    00000012@2016/9/16:00:35:46.466 Corruption detection complete. numCorruptions = 1, Disp = 1.
    2016-09-15 19:35:46, Info                  CBS    Repr: CSI meta data corruption found, will commit repair transaction if repair is asked.
    2016-09-15 19:35:46, Info                  CBS    Repr: CSI Store check completes
    2016-09-15 19:35:46, Info                  CBS    Exec: Manual Repair feasibility evaluation, continue on download evaluation.

    Friday, September 16, 2016 1:38 AM
  • Since sfc scannow didn't fix the problem, I moved onto the DISM commands and upon trying to run a -RestoreHealth I get error code 0x800f0906.

    Friday, September 16, 2016 2:37 AM