locked
Server Manager error 0x80070422 - Roles and features are not accesible RRS feed

  • Question

  • Hi

    I cannot view Roles and Features in Server Manager on my Server 2008 R2 box. The error is:

    Unexpected error refreshing Server Manager: The service cannot be started, either because it is disbaled or because it has no enabled devices assicaited with it (Exception from HResult: 0x80070422)

    I have looked at my services - but don't know what service to look for, everything seems to be in order.

    After some investigation on the net, I understood that I need to setup the win readiness tool, I did and the output in CheckSur file is as follows


    =================================
    Checking System Update Readiness.
    Binary Version 6.1.7601.21645
    Package Version 12.0
    2011-05-31 19:02

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs
    (f) CBS MUM Corrupt 0x00000000 servicing\Packages\Package_for_KB2296199_RTM~31bf3856ad364e35~amd64~~6.1.1.1.mum  Expected file name Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~6.1.7600.16385.mum does not match the actual file name
    (fix) CBS MUM Corrupt CBS File Replaced Package_for_KB2296199_RTM~31bf3856ad364e35~amd64~~6.1.1.1.mum from Cabinet: C:\Windows\CheckSur\v1.0\windows6.1-servicing-x64-apr29.cab.
    (fix) CBS Paired File CBS File also Replaced Package_for_KB2296199_RTM~31bf3856ad364e35~amd64~~6.1.1.1.cat from Cabinet: C:\Windows\CheckSur\v1.0\windows6.1-servicing-x64-apr29.cab.

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store

    Summary:
    Seconds executed: 4058
     Found 1 errors
     Fixed 1 errors
      CBS MUM Corrupt Total count: 1
      Fixed: CBS MUM Corrupt.  Total count: 1
      Fixed: CBS Paired File.  Total count: 1

    Here again, it seems that everything is fine.

    Thanks in advance for your help

     

    Wednesday, June 1, 2011 10:02 AM

Answers

All replies

  • Hi,

     

    Please try to install Windows Server 2008 R2 Service Pack 1 directly and check the result. Service Pack 1 for Windows Server 2008 R2 includes all the previous released Windows Updates and hotfixes.

     

    If it does not work, you will need to copy these files from another working Windows Server 2008 R2 system to replace the corrupt ones.

     

    Otherwise, you will need to perform an In-Place upgrade to repair the system.

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 2, 2011 6:21 AM
  • I downloaded SP1, run it got "SP1s setup failure.

     

    I try to copy the mentioned files from another win 2k8 box, I get "You need permissions to perform this action". In spite of the fact that I am logged as domain admin

    Thursday, June 2, 2011 3:22 PM
  • Well I had no other option, I wnr with the In-Place upgrade which is really a very ugly option.

    Once installation is finished, I got "Setup has detected that .Net Framework version 4 needs to be repaired. Do not restart until setup is complete.

    Anyway, it finished and I was able to access server features.

    Regards,

    Regards,

    Thursday, June 2, 2011 9:12 PM
  • You can download and extract new packages.

    http://blogs.technet.com/b/roplatforms/archive/2010/05/12/how-to-fix-server-manager-errors-after-installing-updates-hresult-0x800f0818-hresult-0x800b0100.aspx

     

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]
    Friday, June 3, 2011 2:04 AM
  • Thanks for the info, it came a little it late. I will keep it fo any new similar incident. I still beleive that there should be a more clear and direct repair options
    Saturday, June 4, 2011 9:50 AM
  • I had a same problem on one of my server. The reason is one service: Windows Module Installer was disabled for some reason. Started it and set it start automatically. The problem was solved.
    CliffZ
    • Proposed as answer by FlyDino Friday, January 4, 2013 2:34 PM
    Thursday, December 15, 2011 12:22 AM
  • Thank you so much! it's so right. the MVPs were in name only.
    • Proposed as answer by Guesfrnd Wednesday, February 10, 2016 3:04 PM
    Tuesday, October 15, 2013 9:58 AM
  • You are right. I had the same problem, but in my case i had one exception. For fixing my problem I have also ran Windows Installer service. Marked your answer as well.

    Regards, Ivan Starunkin

    Friday, March 20, 2015 9:58 AM
  • Thanks a lot ,Works like a Charm !
    Wednesday, February 10, 2016 3:11 PM
  • Enabling and then starting the Windows Module Installer service worked for me, as well.  Thanks, CliffZ!
    Monday, October 10, 2016 3:56 PM