none
Win2012r2 DC problems with DNS RRS feed

  • Question

  • I have DC with AD and DHCP roles and DNS. Few days ago my DNS stopped working.

    This is a weird situation because DNS sometimes working perfectly (1-2 hours) sometime does not work with the first query and response to the second or third, sometimes not working. DNS is configured in forwarder mode.

    Below is my NIC configuration:

    Windows IP Configuration
    
       Host Name . . . . . . . . . . . . : WIN2012R2-DC
       Primary Dns Suffix  . . . . . . . : knyszyn.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : knyszyn.local
    
    Ethernet adapter Ethernet0:
    
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : vmxnet3 Ethernet Adapter
       Physical Address. . . . . . . . . : 00-0C-29-60-EF-88
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::5812:99ce:3201:284c%12(Preferred) 
       IPv4 Address. . . . . . . . . . . : 192.168.34.105(Preferred) 
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.34.1
       DHCPv6 IAID . . . . . . . . . . . : 301993001
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-16-01-9E-00-0C-29-60-EF-88
       DNS Servers . . . . . . . . . . . : 127.0.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    
    Tunnel adapter isatap.{D70A3D2E-109D-4026-9138-7D48F030ABE9}:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    

    And nslookup querie ( site wp.pl ):

    C:\Users\Administrator>nslookup
    Default Server:  localhost
    Address:  127.0.0.1
    
    > set debug
    > wp.pl
    Server:  localhost
    Address:  127.0.0.1
    
    ------------
    Got answer:
        HEADER:
            opcode = QUERY, id = 2, rcode = NXDOMAIN
            header flags:  response, auth. answer, want recursion, recursion avail.
            questions = 1,  answers = 0,  authority records = 1,  additional = 0
    
        QUESTIONS:
            wp.pl.knyszyn.local, type = A, class = IN
        AUTHORITY RECORDS:
        ->  knyszyn.local
            ttl = 3600 (1 hour)
            primary name server = win2012r2-dc.knyszyn.local
            responsible mail addr = hostmaster.knyszyn.local
            serial  = 911
            refresh = 900 (15 mins)
            retry   = 600 (10 mins)
            expire  = 86400 (1 day)
            default TTL = 3600 (1 hour)
    
    ------------
    ------------
    Got answer:
        HEADER:
            opcode = QUERY, id = 3, rcode = NXDOMAIN
            header flags:  response, auth. answer, want recursion, recursion avail.
            questions = 1,  answers = 0,  authority records = 1,  additional = 0
    
        QUESTIONS:
            wp.pl.knyszyn.local, type = AAAA, class = IN
        AUTHORITY RECORDS:
        ->  knyszyn.local
            ttl = 3600 (1 hour)
            primary name server = win2012r2-dc.knyszyn.local
            responsible mail addr = hostmaster.knyszyn.local
            serial  = 911
            refresh = 900 (15 mins)
            retry   = 600 (10 mins)
            expire  = 86400 (1 day)
            default TTL = 3600 (1 hour)
    
    ------------
    DNS request timed out.
        timeout was 2 seconds.
    timeout (2 secs)
    ------------
    Got answer:
        HEADER:
            opcode = QUERY, id = 5, rcode = NOERROR
            header flags:  response, want recursion, recursion avail.
            questions = 1,  answers = 0,  authority records = 1,  additional = 0
    
        QUESTIONS:
            wp.pl, type = AAAA, class = IN
        AUTHORITY RECORDS:
        ->  wp.pl
            ttl = 735 (12 mins 15 secs)
            primary name server = ns2.wp.pl
            responsible mail addr = dnsmaster.wp-sa.pl
            serial  = 2017051202
            refresh = 900 (15 mins)
            retry   = 600 (10 mins)
            expire  = 86400 (1 day)
            default TTL = 3600 (1 hour)
    
    ------------
    *** Request to localhost timed-out
    > exit

    I don't have idea what is wrong. Please help !

    Tuesday, May 16, 2017 12:39 PM

All replies

  • Hi mUpi,

    >>DNS request timed out.
        timeout was
    2seconds.
        timeout
    (2secs)

    It seems no problem with your NIC configuration.

    From your nslookup log, “DNS request timed out” seems happened in the process of forwarding.

    I suggest that you could use network monitor to analyze the process.

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 17, 2017 3:22 AM
  • Thanks for response. Yes it is definitly problem with forwarding. Forwarding not working !

    Actually I reconfigured my network and on the local PCs I sat first DNS on my not working DNS serwer 192.168.34.105 and second DNS on the google serwer 8.8.8.8  People can work normally. But problem still exist.

    Could you tell my witch network analyzer I should use. WireShark or something else ?

    Wednesday, May 17, 2017 7:41 AM
  • Hi mUpi,

    >>Could you tell my witch network analyzer I should use. WireShark or something else ?

    You could use Microsoft Network Monitor to analyze.

    This is the download link:

    https://www.microsoft.com/en-sg/download/details.aspx?id=4865

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 17, 2017 8:00 AM
  • Hi mUpi

    Just checking in to see if the information provided was helpful.

    Please let us know if you would like further assistance.

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 23, 2017 8:40 AM