locked
SCCM 2012 R2 Secondery sites Database replication link was failed RRS feed

  • Question

  • Hello

    we upgraded 2012 r2 to sp1 it was failed and courpted primary server provious we had taken server clone .

    now we use clone server but secoundry servers database replication failed i run the Replication Link Analizer bou it was failed.

    Kinldy help.


    Kiran

    Wednesday, April 20, 2016 4:46 AM

Answers

  • Cloning or taking snapshots is not a valid backup/restore Scenario - especially when there is more than one site.
    Isn't replication link analyzer able to fix it? I guess that it's not possible to solve that here in the forums. Replication is way too complex.

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, April 20, 2016 5:41 AM
  • No. The whole point is that taking snap-shots takes a point in time "picture" of the DB and restoring the snap-hot restores this picture but this confuses any other DBs replicating with it because to them it all of a sudden and magically changed and is missing data they though should be there. Snapshots are very bad for n-tier applications that store state at different levels.

    As Torsten noted, you need to contact Microsoft support.


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Wednesday, April 20, 2016 12:11 PM

All replies

  • Cloning or taking snapshots is not a valid backup/restore Scenario - especially when there is more than one site.
    Isn't replication link analyzer able to fix it? I guess that it's not possible to solve that here in the forums. Replication is way too complex.

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, April 20, 2016 5:41 AM
  •  

    hi,

    Can i recover Secoundery sites it work?..


    Kiran

    Wednesday, April 20, 2016 6:48 AM
  • No. The whole point is that taking snap-shots takes a point in time "picture" of the DB and restoring the snap-hot restores this picture but this confuses any other DBs replicating with it because to them it all of a sudden and magically changed and is missing data they though should be there. Snapshots are very bad for n-tier applications that store state at different levels.

    As Torsten noted, you need to contact Microsoft support.


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Wednesday, April 20, 2016 12:11 PM