none
WSSE in Oracle EBS MA RRS feed

  • Question

  • Hi,

    I've been working on implementing the Oracle EBS management agent. I have the Oracle web services published and I can access the wsdls from the FIM server just fine.

    I've updated the wsconfig project with these WSDLs in the Discovery section. (I also had to change some of the soaHeader reference attribute names from things like "Responsibility" to "ResponsibilityName" to get around some errors.)

    When I try to test the connection via the management agent, I receive the error: "Test Connection failed witht he following error: Missing <wsse:Security> in SOAP Header".

    Using Wireshark, I found the SOAP envelope and it didn't have these headers, but I've got no idea how to add them to the request.

    If anyone has any suggestions I'd appreciate it.

    Thanks,

    Sami

    Sunday, January 27, 2013 5:48 PM

Answers

  • Embarassingly enough, this was in the Connector for Web Services document. The Interoperable check box and "PasswordText" options being set enabled us to get around the wsse header issue.
    • Proposed as answer by Furqan Asghar Sunday, May 19, 2013 9:00 AM
    • Marked as answer by SamiVV Monday, May 20, 2013 11:33 AM
    Thursday, February 14, 2013 4:46 PM

All replies

  • Has anyone gotten this connector to work?

    I've been trying to get the Oracle EBS Connector to work for over a week now and have run into issue after issue.

    The documentation is very loosely written--especially as regards how EBS needs to be configured for the management agent to work.

    If anyone could share their experiences in getting this implemented, I would appreciate it.

    The Oracle web services seem to require wsse, but I can't figure out how to do that within the Web Service Configuration Tool. I also tried the technique of changing the wsconfig file to a zip and unzipping it, making changes and re-zipping it, but that just results in an empty project file. I was able to call the web service via a Windows Forms app that I stuffed the wsse headers into.

    Thanks for any help at all.

    Sami

    Wednesday, February 6, 2013 5:13 PM
  • Embarassingly enough, this was in the Connector for Web Services document. The Interoperable check box and "PasswordText" options being set enabled us to get around the wsse header issue.
    • Proposed as answer by Furqan Asghar Sunday, May 19, 2013 9:00 AM
    • Marked as answer by SamiVV Monday, May 20, 2013 11:33 AM
    Thursday, February 14, 2013 4:46 PM
  • Please mark it as an answer.

    Regards Furqan Asghar

    Sunday, May 19, 2013 9:00 AM