locked
Unable to open xls in desired instance of excel from File explorer RRS feed

  • Question

  • We've gotten reports that the functionality in interaction between MS Excel and Windows 7 has changed.  Previously, one was able to open two instances of Excel.exe and then double the desired *.xls from Windows explorer and the file would open in the last excel instance that was in focus.  This no longer occurs.  In Windows 7, the first excel instance opened always grabs the file.  I've confirmed this occurs in Excel 2007 and Excel 2010.

    While using the File open dialog from within Excel does offer a workaround, this solution does not offer the simple need my end user has, to open the desired xls which has been received as an email attachment.  Any ideas on how to address? 

    I'm aware of the /e "%1" fix on the xls and xlsx extensions.  That fix does not address this specfic issue.  For the record I've already imported the following reg entries as the file type association no longer permits the DDE change directly.  TIA for suggestion, comments, workaround or simple moral support.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8\shell\Open\command]
    @="\"C:\\Program Files\\Microsoft Office\\OFFICE11\\EXCEL.EXE\" /e \"%1\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12\shell\Open\command]
    @="\"C:\\Program Files\\Microsoft Office\\OFFICE11\\EXCEL.EXE\" /e \"%1\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.14\shell\Open\command]
    @="\"C:\\Program Files\\Microsoft Office\\OFFICE11\\EXCEL.EXE\" /e \"%1\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8\shell\Open\ddeexec]
    @="[open(\"%1\")]"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12\shell\Open\ddeexec]
    @="[open(\"%1\")]"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.14\shell\Open\ddeexec]
    @="[open(\"%1\")]"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8\shell\Open\ddeexec\application]
    @="Excel"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12\shell\Open\ddeexec\application]
    @="Excel"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.14\shell\Open\ddeexec\application]
    @="Excel"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8\shell\Open\ddeexec\topic]
    @="system"


    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12\shell\Open\ddeexec\topic]
    @="system"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.14\shell\Open\ddeexec\topic]
    @="system"

     

    Tuesday, August 3, 2010 2:01 PM

Answers

  • Hi,

    Thanks for posting in Technet.

    Since it is a Microsoft Office Excel issue, please discuss in the following forum.

    Excel IT Pro Discussions


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Tuesday, August 10, 2010 3:29 AM
    • Unmarked as answer by JRWilliams308 Wednesday, August 11, 2010 3:05 PM
    • Marked as answer by Arthur Xie Wednesday, September 1, 2010 9:50 AM
    Wednesday, August 4, 2010 9:50 AM
  • Thanks, I'm aware of this.  That should be evident by the fact that I posted the registry keys in question and the DDE setting that require modification.  

     

    I'm going to post this same question in the excel forum as you've suggested.  However, Please understand, A change in the file type assocation dialog page has be introduced in Windows 7 (actually Vista, I believe) which no longer provides the required options to modify DDE settings.  This is an OS level function, not application.  The workaround, should be to modify the registry keys I indicated, however the OS is NOT recognizing these changes.

     

    So respectfully, and I do truly say this with all due respect for your volunteer-ism, and your time. Can you research the topic at hand or perhaps is there another MSP\Moderator who might assist?  I hate to cross link topics, but I'm afraid the next person who runs into this issue will also look to this OS forum and hope the link provided helps future searchers.

    The post has been created in the Excel forum as you suggested at http://social.technet.microsoft.com/Forums/en/excel/thread/d74463a8-95b9-4c1a-9a8e-c9934bd9e06e

    • Edited by JRWilliams308 Wednesday, August 11, 2010 3:10 PM updated to provide new forum location link
    • Marked as answer by JRWilliams308 Wednesday, August 11, 2010 3:20 PM
    • Marked as answer by JRWilliams308 Wednesday, August 11, 2010 3:23 PM
    Wednesday, August 11, 2010 3:06 PM

All replies

  • Hi,

    Thanks for posting in Technet.

    Since it is a Microsoft Office Excel issue, please discuss in the following forum.

    Excel IT Pro Discussions


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Arthur Xie Tuesday, August 10, 2010 3:29 AM
    • Unmarked as answer by JRWilliams308 Wednesday, August 11, 2010 3:05 PM
    • Marked as answer by Arthur Xie Wednesday, September 1, 2010 9:50 AM
    Wednesday, August 4, 2010 9:50 AM
  • No.  This is a Windows 7 issue.  I specifically chose this forum.  This issue does not occur on Windows XP.
    Wednesday, August 4, 2010 7:34 PM
  • Please understand that how Microsoft Office Excel opens a *.xls file completely depends on the configurations or the Registry settings of Microsoft Office Excel. You may need to work with these configurations or Registry keys. Therefore please create a new thread in our Excel forum for this topic.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, August 5, 2010 9:10 AM
  • Thanks, I'm aware of this.  That should be evident by the fact that I posted the registry keys in question and the DDE setting that require modification.  

     

    I'm going to post this same question in the excel forum as you've suggested.  However, Please understand, A change in the file type assocation dialog page has be introduced in Windows 7 (actually Vista, I believe) which no longer provides the required options to modify DDE settings.  This is an OS level function, not application.  The workaround, should be to modify the registry keys I indicated, however the OS is NOT recognizing these changes.

     

    So respectfully, and I do truly say this with all due respect for your volunteer-ism, and your time. Can you research the topic at hand or perhaps is there another MSP\Moderator who might assist?  I hate to cross link topics, but I'm afraid the next person who runs into this issue will also look to this OS forum and hope the link provided helps future searchers.

    The post has been created in the Excel forum as you suggested at http://social.technet.microsoft.com/Forums/en/excel/thread/d74463a8-95b9-4c1a-9a8e-c9934bd9e06e

    • Edited by JRWilliams308 Wednesday, August 11, 2010 3:10 PM updated to provide new forum location link
    • Marked as answer by JRWilliams308 Wednesday, August 11, 2010 3:20 PM
    • Marked as answer by JRWilliams308 Wednesday, August 11, 2010 3:23 PM
    Wednesday, August 11, 2010 3:06 PM