locked
Exchange 2010 server - Outlook 2007 cannot open a room calender but Outlook 2010 can using same login user RRS feed

  • Question

  • We have an Exchange 2010 server and have set up two Room resources. I want my Outlook users to be able to add a these room calendars. If the user is using Outlook 2010 it works fine, if that same user is using Outlook 2007 they get this message: You do not have sufficient permissions to open the calendar folder. You don't have appropriate permission to perform this operation.

    It has to be something with outlook 2007 client, but I am stumped on what to try. Any suggestions?

     

    Friday, March 25, 2011 9:31 PM

All replies

  • That behavior is different for Outlook 2010 and 2007. Outlook 2010 will allow you to open a calendar to view the freebusy but 2007 will not unless you explicity have at least reviewer rights; so with 2007 you typically use the scheduling assistant to view free busy. 
    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Proposed as answer by Maddas69 Thursday, August 30, 2012 10:07 AM
    Friday, March 25, 2011 9:35 PM
  • I have given a user even OWNER explicit rights and it still does not work in 2007.
    Monday, March 28, 2011 3:06 PM
  • Someone had this issue last week but can't find the thread. It worked for 2010 but not 2007 even after adding the perms. The solution was open the resource mailbox using pfdavadmin right click the freebusy data folder and see if the permissions you granted the user exists. It seems that if the user does not have FB access, granting him any rights doesn't work.
    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Monday, March 28, 2011 7:38 PM
  • Hi,

     

    If the permission is enough, but the issue still exits, Could you please try running outlook 2007 with /cleanfreebusy parameter.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, March 29, 2011 9:18 AM
  • Tried that without success.
    Wednesday, March 30, 2011 8:24 PM
  • I am having a similar issue.  I would love to see what the resolution is.
    Monday, April 18, 2011 5:51 PM
  • I am also seeing the same issue.  Permissions are set properly I think.  With the same user ID, opening the room calendar from OWA works, but not from Outlook 2007.

    We're using Exchange 2010 SP1.

    I can't open the resource mailbox using pfdavadmin, as it's not supported on Exchange 2010.  I've used ExFolders, and again, the permissions look fine.  User has Editor permission on the calendar.  Default is set to AvailabilityOnly.  Anonymous is set to None.



    To fix it, I had to give the user FULLACCESS rights to the Room's Mailbox.  This isn't what I wanted, but it works.
    Tuesday, April 19, 2011 10:46 PM
  • I am currently having the same issue for one of our users.  I haven't tried giving full access yet but that is not ideal.
    Monday, May 16, 2011 12:50 PM
  • James Chongs answer is the correct one in this thread.

    To ellaborate to his post; make sure that DEFAULT is set to at least REVIEWER permission level in the Free/Busy section of the room mailbox.

    To do this open the mailbox in Outlook 2007, go to the Tools menu, chose Options, Calendar Options, Free/Busy Options and change DEFAULT to REVIEWER permission level and users will be able to open the meeting room calendar in Outlook 2007.


    • Edited by Maddas69 Thursday, August 30, 2012 10:15 AM
    Thursday, August 30, 2012 10:15 AM