none
RAM and Processors RRS feed

  • Question

  • Hello,

    I'm running Win 2019 SRV with HyperV and two (2) VMs.

    My main server has 8 cores and 64GB RAM and it running on RAID6 10k SATA drives.

    I setup the VMs as one processor and dynamic RAM from 1GB to 10GB.

    One VM is running the Kaspersky Management Console only.

    The other is running as a RDP Server.

    These are the only functionalities these two VMs run.

    When I login into the host, the login is really fast. When I login into the VMs, the login takes more time.

    Should I change something here to make the VMs faster to login and perform faster?


    Thank you. Karel Grulich, MCSE, SBS


    • Edited by karelg719 Thursday, January 10, 2019 5:40 PM
    Thursday, January 10, 2019 5:39 PM

Answers

  • "I setup the VMs as one processor and dynamic RAM from 1GB to 10GB."

    I have found that just about every instance of Windows runs better for interactive users with at least two processors.  With what you have reported for your configuration, there is no reason why you could not assign more virtual processors to the VMs.  I haven't tried adjusting the memory size in a case like this, but you might give a try to setting the startup memory to 2GB.  You can leave the dynamic at 1-10, but having the startup value higher than the low size of the dynamic might (again, I haven't tried this) leave more of the necessary routines in memory for the initial interactive login.


    tim

    • Marked as answer by karelg719 Wednesday, January 16, 2019 3:48 PM
    Friday, January 11, 2019 1:57 PM

All replies

  • Hello Karel!

    Are you logging in by using RDP to your host and virtual machines (VMs)?

    Could you elaborate a bit on the following for us?

    • Host login = "really fast"
    • VM login "takes more time"

    Have you also applied any group policies to your virtual machines that could delay the login slightly?

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, January 10, 2019 8:41 PM
  • "I setup the VMs as one processor and dynamic RAM from 1GB to 10GB."

    I have found that just about every instance of Windows runs better for interactive users with at least two processors.  With what you have reported for your configuration, there is no reason why you could not assign more virtual processors to the VMs.  I haven't tried adjusting the memory size in a case like this, but you might give a try to setting the startup memory to 2GB.  You can leave the dynamic at 1-10, but having the startup value higher than the low size of the dynamic might (again, I haven't tried this) leave more of the necessary routines in memory for the initial interactive login.


    tim

    • Marked as answer by karelg719 Wednesday, January 16, 2019 3:48 PM
    Friday, January 11, 2019 1:57 PM
  • Thank you for your input. That's what I was going to try. It seems like it improved the performance. I'll leave it at that for now and see how it goes.

    I changed it to two processors for each VM and to 3GB start up memory and 3-10GB dynamic.


    Thank you. Karel Grulich, MCSE, SBS

    Friday, January 11, 2019 5:33 PM
  • "I changed it to two processors for each VM and to 3GB start up memory and 3-10GB dynamic."

    Though it looks like your host has enough resources to have your VMs configured this way, it is not necessary to have the startup memory be the same value as the minimum dynamic setting.  For some systems, more memory is needed to get it up and running quickly, but once it is running, it does not need as much memory.  But if you think that your system may eventually need up to 10 GB of memory, it seems likely that a larger minimum may be appropriate.  Best process would be to watch the memory usage of the VMs to see what setting is most effective.

    https://www.altaro.com/hyper-v/hyper-v-dynamic-memory-explanation-and-recommendations-2/ provides a good explanation of how dynamic memory works on Hyper-V.


    tim

    Saturday, January 12, 2019 2:30 PM

  • Hi,

    Just check the situation about your issue.

    Best Regards,
    Frank

    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, January 14, 2019 9:11 PM
    Moderator
  • I checked and the RAM usage was around 2.5GB so setting it to min of 3GB sounds good to me. I can always adjust later but everything works fine now. Thanks again.

    Thank you. Karel Grulich, MCSE, SBS

    Wednesday, January 16, 2019 3:47 PM