none
896358: Cannot open CHM files RRS feed

  • Question

  • I hope this isn't indicative of MS's patch quality continuing to take a nosedive.

    I need for certain users to be able to open CHM files from a network share.  Easy cheesy.  Sadly the 'workarounds' seem to function (or not) wildly differently across OS versions and architecture. 

    I have Win7 64 and 32 bit machines.  64 bit work fine when the 'allowed' URLs are specified in the registry (HKLM\Software\Microsoft\HTMLhelp\1.x\ItssRestrictions - value UrlAllowList).  No zone modification needed.

    However;

    32 bit Win 7 machines do not work with this method.  Unless the user is a local administrator (not happening).  I cannot get them to work at all.  Can anyone please help me understand what needs to be done differently for these clients?

    Thanks!

    Tuesday, April 28, 2015 9:17 PM

Answers

  • The drives are mapped by simple \\hostname\share and navigable by UNC.  I put both paths in the AllowList value.  Also note that the fix works - if you're local admin. 

    We are going to move the CHM files.  Much less hassle. Thanks for your responses.

    • Proposed as answer by Michael_LSModerator Monday, May 4, 2015 1:31 AM
    • Marked as answer by n4 Monday, May 4, 2015 9:01 PM
    Thursday, April 30, 2015 1:07 PM

All replies

  • Hi n4,

    Have you tried to add a MaxAllowedZone value under the registry key?

    HKLM\Software\Microsoft\HTMLhelp\1.x\ItssRestrictions

    If not, you may take a try:

    1. Right-click the ItssRestrictions subkey, point to New, and then click DWORD Value.
    2. Type MaxAllowedZone, and then press Enter.
    3. Right-click the MaxAllowedZone value, and then click Modify.
    4. In the Value data box, type 1, and then click OK.
    5. Quit Registry Editor.

    If the above steps do not work for you, please see http://support.microsoft.com/kb/896358 for alternatives.

    More threads for reference:

    https://social.technet.microsoft.com/Forums/ie/en-US/3cd184ca-6a16-4039-a8a0-a2538613d604/cannot-open-chm-files?forum=w7itprogeneral

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, April 29, 2015 9:51 AM
    Moderator
  • Thanks for the response.

    I have tried the MaxAllowedZone settings and it doesn't do the trick either.  I've read a ton of links and even downloaded a tool made specifically to deal with this mess.  Frustrating.

    I came across a reg key HHRestrictions that supports the same settings, I'm wondering if that will do the trick.  Will report back.

    Wednesday, April 29, 2015 1:36 PM
  • Nope.  None of this works. 

    I should note that I am attempting to open these files with the MS Help Executable.

    Wednesday, April 29, 2015 2:19 PM
  • n4,

    How do we mapped the drive on the 32 bit machines?

    If the network drive is configured with IP address, it may be recongnized as Internet Zone, which may not work, see this KB:

    Intranet site is identified as an Internet site when you use an FQDN or an IP address

    Try to use GPO to map the drive using UNC path, then check if issue insists.

    I will keep searching on this topic.

    Regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, April 30, 2015 7:34 AM
    Moderator
  • The drives are mapped by simple \\hostname\share and navigable by UNC.  I put both paths in the AllowList value.  Also note that the fix works - if you're local admin. 

    We are going to move the CHM files.  Much less hassle. Thanks for your responses.

    • Proposed as answer by Michael_LSModerator Monday, May 4, 2015 1:31 AM
    • Marked as answer by n4 Monday, May 4, 2015 9:01 PM
    Thursday, April 30, 2015 1:07 PM