locked
SharePoint 2010 does not search within PDFs after installing and configuring iFilter RRS feed

  • Question

  • After following the steps in this article, searching within a PDF still does not work: http://www.codeproject.com/KB/sharepoint/PDFiFIlterSharePoint2010.aspx.  Indexing and Search work fine for Office documents.
    Wednesday, May 26, 2010 5:42 PM

Answers

  • the key to that is

    1. Make sure you loaded the right GUID for the iFilter.

    2. Make sure PDF is registered as an crawl file type.

    3. Make sure you restart the osearch14 service after the changes.

    Saturday, June 26, 2010 2:24 AM
  • I have included below an excerpt from Adnan Ahmed post on installing and configuring PDF iFilter for SharePoint Server 2010 or Search Server 2010 Express edition. apart from updating the registry settings required to update GUID for .pdf, remaining steps are similar.  http://www.mossgurus.com/adnan/Lists/Posts/Post.aspx?ID=40

     

    1. Install PDF iFilter 9.0 (64 bit) from http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025
    2. Download PDF icon file from pdf16.gif and copy at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\IMAGES\
    3. Add the following entry in docIcon.xml file, which can be found at: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\XML

      <Mapping Key="pdf" Value="pdf16.gif" />

    4. Add pdf file type on the Manage File Type page under Search Service Application.
    5. Open registry by executing regedit on the Start --> Run.
    6. Navigate to the following location:

      \\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\14.0\Search\Setup\ContentIndexCommon\Filters\Extension

    7. Right-click Extension, a menu will appear.
    8. Click New--> Key to create a new key for .pdf. See screen shot below.

    For therest of the post go to http://www.mossgurus.com/adnan/Lists/Posts/Post.aspx?ID=40 

     

     Cheers,

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Friday, June 25, 2010 5:37 PM

All replies

  • I think the problem is in their step 13:  "Perform incremental to include PDF files".

    I'm pretty sure you will need to run a Full Scan to force the rescan of the existing (previously scanned) PDFs.  For a quick test, upload a new PDF file and run an incremental to see if the iFilter is working.

     


    Mike Smith TechTrainingNotes.blogspot.com
    Wednesday, May 26, 2010 6:27 PM
  • Are you sure your PDFs are searchable?  To check open up your PDF and hit Control-F and search on a term in the document and see if it works.  If it does, then there's something not right with the iFilter.  If nothing comes up, then the issue is with the PDF itself.


    John
    SharePoint911: SharePoint Consulting
    Blog: http://www.rossonmoss.com
    Twitter: JohnRossJr

    MOSS Explained: An Information Workers Deep Dive into Microsoft Office SharePoint Server 2007
    Wednesday, May 26, 2010 6:47 PM
  • I added a new PDF and waited for the incremental.  I can find that new document by a word in the title but not a word unique to the text.
    Monday, June 7, 2010 11:50 PM
  • That's an interesting thought.  I used a new document that I can search on both Mac (Preview) and Windows 7 (Foxit Reader), and it's not being indexed.
    Monday, June 7, 2010 11:52 PM
  • you may want to check if the ifilter is correctly registered.
    Thursday, June 10, 2010 8:05 PM
  • What would be the main indicator that it has registered correctly?

    Thanks!

    Thursday, June 10, 2010 10:35 PM
  • Double check the registery keys to make sure that you didn't mistype any of the characters.  It is easy for that to happen.  Also if you have more than one SharePoint server in the farm, ensure that you are doing these steps on the server running the search cralwer.   If possible try resetting the index and doing a full crawl.

     


    If you get your question answered, please come back and mark the reply as an answer.  
    If you are helped by an answer to someone else's question, please mark it as helpful.
    Mike Hacker | Blog: http://mphacker.spaces.live.com 

    Thursday, June 10, 2010 11:56 PM
  • Here's the reg settings for 2007 -- I'd assume they are pretty similar for 2010 except instead of 12.0 you'd use 14.0:

    http://msmvps.com/blogs/sundar_narasiman/archive/2008/02/06/configuring-moss-2007-to-search-pdf-documents-install-and-configure-pdf-ifilters.aspx

     


    John Ross
    SharePoint Server MVP | Sr. Consultant SharePoint911: SharePoint Consulting
    Blog: http://www.sharepoint911.com/blogs/john
    Twitter: @JohnRossJr

    <http://www.amazon.com/Professional-SharePoint-Branding-Interface-Design/dp/0470584645">Professional SharePoint 2010 Branding and User Interface Design
    Friday, June 11, 2010 1:05 PM
  • Does anyone have a definitive set of PDF iFilter and search configuration instructions for 2010?
    Wednesday, June 16, 2010 11:20 PM
  • I also had the same problem on 2010.

    I worked out this problem by following the install manual provided by Adobe, but chaged the registry type to <REG_SZ> on step 4. ( Manual says to set it to REG_MUTI_SZ>)

    http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025

    Manual name : Configuring PDF iFilter for MS Sharepoint 2007.pdf

    Wishing this help you.

     

    Thursday, June 17, 2010 7:48 AM
  • The paths specified in the 2007 document do not exist on my server, i.e., HKLM\software\microsoft\exchange path does not exist.  A search of the registry for .pdf shows up all keys set to REG_SZ

     

    I'm still looking for a document that is specific to 2010 for the configuration of the pdf ifilter from adobe.

    Friday, June 25, 2010 4:49 PM
  • I have included below an excerpt from Adnan Ahmed post on installing and configuring PDF iFilter for SharePoint Server 2010 or Search Server 2010 Express edition. apart from updating the registry settings required to update GUID for .pdf, remaining steps are similar.  http://www.mossgurus.com/adnan/Lists/Posts/Post.aspx?ID=40

     

    1. Install PDF iFilter 9.0 (64 bit) from http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025
    2. Download PDF icon file from pdf16.gif and copy at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\IMAGES\
    3. Add the following entry in docIcon.xml file, which can be found at: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\XML

      <Mapping Key="pdf" Value="pdf16.gif" />

    4. Add pdf file type on the Manage File Type page under Search Service Application.
    5. Open registry by executing regedit on the Start --> Run.
    6. Navigate to the following location:

      \\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\14.0\Search\Setup\ContentIndexCommon\Filters\Extension

    7. Right-click Extension, a menu will appear.
    8. Click New--> Key to create a new key for .pdf. See screen shot below.

    For therest of the post go to http://www.mossgurus.com/adnan/Lists/Posts/Post.aspx?ID=40 

     

     Cheers,

    -Ivan


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders.
    Friday, June 25, 2010 5:37 PM
  • Thanks, I will give it another go on Monday.
    Saturday, June 26, 2010 1:28 AM
  • the key to that is

    1. Make sure you loaded the right GUID for the iFilter.

    2. Make sure PDF is registered as an crawl file type.

    3. Make sure you restart the osearch14 service after the changes.

    Saturday, June 26, 2010 2:24 AM
  • I verified each step is correct and restarted the service.  From the comments to the article above, did you have to do this part?

    - making sure the ".pdf" key with "Extension=pdf", "FileTypeBucket=1", and MimeTypes="application/pdf" values exist under:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\14.0\Search\Setup\Filters

    There isn't anything similar to that for any file extension in my registry, so I'm hesitant to add it.

    Monday, June 28, 2010 6:59 PM
  • I re-pasted the guid into the reg key and restarted the osearch service, and now it works.
    Monday, June 28, 2010 8:07 PM
  • Thanks Brandon. I faced similar issue as you had and performed exact same steps - pasted the GUID again in registry, restarted search service but I also had to execute a full crawl on content source then it worked for me. :)
    Tuesday, January 5, 2016 7:59 AM