none
ID 998 Details: The semaphore timeout period has expired (0x80070079) RRS feed

  • Question

  • Hello

    I am getting this error intermittently when backing up directly to tape.

     

    I have dpm 2016 (5.0.342.0 UR4) on windows 2016 STD (Version 0.0.14393 Build 14393)

     

    I have done the following on the dpmserver and client servers;

     

    Disabled windows defender using gpedit

     

    enabledTCP Chimney Offload;  netsh int tcp set global chimney=enabled

     

    Created the TCP/IP maximum retransmission timeout parameter and set to 10 (have tried changing this to different values)

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

     

    Created this;

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent] "BufferQueueSize"= 30 decimal (have tried changing this to different values)

     

    The exact error is ;

    The operation failed because of a protection agent failure. (ID 998 Details: The semaphore timeout period has expired (0x80070079))

     

    It would be great if you could shine any light on this please as I am on the verge of rebuilding the server using dpm2012R2

     

    I also posted this as a reply to the post by Mohit Sharma on Tuesday, July 11, 2017 3:47 AM

    Tuesday, November 14, 2017 8:23 PM

All replies


  • The status for all agents is 'OK'

    Its important to note that the tape backup job starts and runs for a period of time before failing. Some backups have been successful. So its an intermittent type problem (with it failing 90% of the time)

    I also made the following changes to the properties of the NIC ;

    Large Send Offload V2(IPV4)- Disabled

    Large Send Offload V2(IPV6)- Disabled

    Receive Side Scaling-Disabled

    Transmit Buffers-512

    NIC drivers are up to date

    In DPM mgmt console - Optimize performance and use "Enable on-the-wire compression"

    Turned off Chimney and RSS on the client and dpm 2016 servers
        To disable chimney:   netsh int tcp set global chimney=disabled 
        To disable RSS: netsh int tcp set global rss=disabled 

    The library and library drive firmware is up to date. The library drives have the latest drivers installed. The 4 library drives are connected to the Windows 2016 server by fibre and the drivers for the fibre cards are up to date




    • Edited by dpmoperator Thursday, November 16, 2017 4:32 PM
    Wednesday, November 15, 2017 12:19 PM
  • Bump, I am having the same semaphore issues with DPM 2016 UR4. It seems to only happen with protected computers running Server 2016. Also, I'm not running tape backups. I can get it to temporarily create a replica by manually going to a server and running the setdpmserver -dpmservername <dpmserver> command. But by the next day, the semaphore errors pop up again


    Tuesday, November 28, 2017 8:22 PM
  • Same problem here; did you ever find any solution?

    We have tinkered with these parameters and other things, too.

    It only affects Server 2016 BMR Workloads for us.

    Wednesday, November 7, 2018 9:37 PM
  • Hi,

    Have you tried with the latest Update Rollup 6 for DPM 2016 to see whether  the issue still persists or not?


    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, November 7, 2018 10:17 PM
  • Hi Leon,

    this is not applicable as our version is 1807, to UR doesn't apply unfortunately.

    Wednesday, November 7, 2018 10:18 PM
  • What is the exact error message you're getting?

    Did you try modifying the TCP/IP maximum retransmission time-out in the registry?


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, November 7, 2018 10:34 PM
  • I adjusted this value on the DPM server now.

    Should this be adjusted there or on all client-servers, too?


    • Edited by namezero111111 Thursday, November 8, 2018 7:30 AM spelling
    Thursday, November 8, 2018 6:50 AM
  • It should be modified on the DPM server, a reboot is most likely required after the change.

    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, November 8, 2018 9:28 AM
  • Yes, that's what I assumed. I did this last night and am monitoring now; will report back (latest in a week or so if it works).Just fyi I set the retransmission timeout to 16

    Thursday, November 8, 2018 11:48 AM
  • Hi, unfortunately, there are still BMR recovery point errors, even with the following settings:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\TcpMaxDataRetransmissions set to 0x12

    ARP offload- Disabled
    Large Send Offload V2(IPV4)- Disabled
    Large Send Offload V2(IPV6)- Disabled
    NS Offload-Disabled
    Receive Side Scaling-Disabled
    TCP/UDP Checksum Offload(IPV4)-Disabled
    TCP/UDP Checksum Offload(IPV6)-Disabled
    Transmit Buffers-600

    Tuesday, November 13, 2018 7:05 AM