none
MDT not passing ScanStateArgs to USMT RRS feed

  • Question

  • Looking for some MDT guru's with USMT experience here. My MDT environment doesn't seem to be passing my ScanStateArgs to USMT during OS deployment.

    Environment: 
    ADK 1903
    MDT 8450

    CustomSettings.ini:

    Text
    [Settings]
    Priority=DefaultGateway, Default
    Properties=MyCustomProperty
    
    [DefaultGateway]
    10.1.111.254=City1
    10.2.112.254=City2
    
    [City1]
    Deployroot=\\City1\DepShare$
    SLShare=\\City1\DepShare$\DepLogs
    SLShareDynamicLogging = \\City1\DepShare$\DepLogs\%OSDComputerName%
    EventService=http://City1:9800
    UserDataLocation=NETWORK
    UDShare=\\City1\USMT$
    UDDir=%ComputerName%
    
    [City2]
    Deployroot=\\City2\DepShare$
    SLShare=\\City2\DepShare$\DepLogs
    SLShareDynamicLogging = \\City2\DepShare$\DepLogs\%OSDComputerName%
    EventService=http://City2:9800
    UserDataLocation=NETWORK
    UDShare=\\City2\USMT$
    UDDir=%ComputerName%
    
    [Default]
    
    ScanStateAgrs=/v:5 /o /c /vsc /ui:domain.local\* /uel:30 /efs:skip
    USMTMigFiles001=MigApp.xml
    USMTMigFiles002=MigUser.xml
    
    LoadStateArgs=/v:5 /c /lac
    
    Initially, I noticed that profiles older than 30 days were being captured and restored, which based on the flags above, should not be the case.  But then one of the computers was failing to capture the profile due to encrypted files and the deployment failed as a result.  This is when I started digging in the logs and found that none of my custom arguments were being passed to USMT.
    I quickly noticed the 3rd line which verified the issue:
    USMTcapture.log:
    Command line: C:\MININT\USMT\X64\scanstate.exe \\City1\USMT$\ComputerName /v:5 /c /o /i:C:\MININT\USMT\X64\MigApp.xml...
    As you can see, only the default arguments are being used.
    Any ideas?

    Moderators & Contingent Staff: I humbly request that you do not mark any reply, whether yours or someone else, as an answer unless the original poster confirms it resolved their issue. Thank you for your understanding.

    Wednesday, October 16, 2019 7:15 PM

All replies

  • Bump.

    Moderators & Contingent Staff: I humbly request that you do not mark any reply, whether yours or someone else, as an answer unless the original poster confirms it resolved their issue. Thank you for your understanding.

    Monday, October 21, 2019 1:43 PM