none
Project Web App Taking at least 5mins to load RRS feed

  • Question

  • Hello, Each page in PWA takes at least five minutes to load. It was working fine until Thursday last week. Accessing the site collection is fine and another test web application response time is quick also. It is just the Project Web App that is causing the issue. I tried creating a new instance and same issue. I am not sure where to start looking to troubleshoot the issue, but have this feeling it is something to do with Project Service Application. I have restarted the service and still no change. I cannot see any errors in the event viewer or the logs. Any help will be highly appreciated. SJ
    Monday, February 21, 2011 1:00 AM

Answers

  • Thanks Gary.

    I have been away so haven't had a chance to update this thread. I was running out of time so commissioned another QA environment and it is fine. So I do think the IIS settings must be the cause of the problem, which I will confirm later when I get a chance.

    As mentioned before SQL Server and SP Server have the same locale settings, but IIS is different. 

    Thank you all for your assistance!

    Regards,

    SJ

    • Marked as answer by SJ_PPM Monday, February 28, 2011 9:41 PM
    Monday, February 28, 2011 9:41 PM

All replies

  • A few point: - Does this happen for all users? - Have you tried to re-start the SharePoint Timer service? - What does the Project Queue look like? - Did you restart the Project Queue Service? - What is the connection like from Project Pro? - Were any updates provided last week the cause this issue? Please provide further information to be able to effectively help troubleshoot this issue. Regards,
    Best Regards, Dharmesh Patel Microsoft Technology Specialist Project Server / SharePoint / BI Reporting http://www.DharmeshPatel.co.uk
    Monday, February 21, 2011 8:22 AM
  • Hi Sj_EPM,

    are you using Project Server 2007? If yes, when you say that each page, you say all pages or only pages with ActiveX?

    So, in this case, can be possible that this is a client issue? Can you clean the browser cache?

    Maybe it's not related, maybe yes.

    I hope this can help you,

    Best Regards

    Paolo O.

    Monday, February 21, 2011 11:14 AM
  • Sorry. I should have been more specifc. It is PS2010. Cleared Cache. Restarted all services. Nothing pending in the queue. Queue restarted. No updates at all were applied to the environment. I have been searching for extra info myself. Log files, event viewer, SQL Logs etc...anything to at least give me starting point. I think I am just not looking hard enough as there has to be some info somewhere getting logged.

     

    Tuesday, February 22, 2011 2:19 AM
  • Hi,

    Have you determined if the problem is occuring when you remote desktop into the server itself and open PWA? If it is, then there is something happening within PS and / or the content.

    Have any new features or configuration changes been enabled or made to the environment?

    As a last resort, I would suggest turning on the developer dashboard on the PWA site and seeing if that can throw any light on which components of the page are taking a long time to run?  More info here :http://blogs.msdn.com/b/chrisfie/archive/2010/01/29/why-sharepoint-2010-developer-dashboard-is-for-all-it-professionals.aspx

    Let us know how you go,


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Tuesday, February 22, 2011 4:29 AM
    Moderator
  • Thank you Alex! I will use this tool. Hopefully it will tell me something.
    Tuesday, February 22, 2011 4:47 AM
  • I would troubleshoot as below:

    -Ensure "Project application server" Time and "SQL server Time" are same

    -Stop the project application service in central admin, then start the service.

    -Have you updated any patch on Thursday? Did you check the ULS logs on Thursday? Anychange in SQL server ?

    -Did you check the CPU / memory util when you try to browse the PWA sites?

    (Last option) Create new web application and new service application (Make it as default) and create new PWA on the new web application, later check the behaviour


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Tuesday, February 22, 2011 5:16 AM
    Moderator
  • Sorry about the delay. I have tried using Developer's Dashboard, but without any success. I created 'Failed Request Tracing Rule' in IIS against the Web App and tried logging onto PWA again and it generated this error after 10 seconds:

    ModuleName: WindowsAuthenticationModule

    Notification:2

    HttpStatus:401

    HttpReason:Unauthorized

    HttpSubStatus:1

    ErrorCode:2148074252

    ConfigExceptionInfo:

    Notification: AUTHENTICATE_REQUEST

    ErrorCode: The logon attempt failed (0x8009030c)

    After 5mins I see a success, but I think it doesn't seem to recognize authentication initially and then suddenly its okay with authentication.

    I also noticed that the Failed Request Logs time is different...it is actually one hour behind and time zone format is different. It may well be IIS settings and nothing to do with server hosting PWA and SQL Server which have the local settings...so I shouldn't worry about it?

    Wednesday, February 23, 2011 7:01 AM
  • No updates applied. It is not CPU resource hungry either. I have stopped and restarted all project server related services several times.
    Wednesday, February 23, 2011 7:18 AM
  • SJ:

    Could it be that your SQL Server and your SharePoint front end servers have different locale and time settings? Everything SharePoint does is based on timer jobs, that expect the servers to be in snynch.


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Sunday, February 27, 2011 2:12 PM
    Moderator
  • Thanks Gary.

    I have been away so haven't had a chance to update this thread. I was running out of time so commissioned another QA environment and it is fine. So I do think the IIS settings must be the cause of the problem, which I will confirm later when I get a chance.

    As mentioned before SQL Server and SP Server have the same locale settings, but IIS is different. 

    Thank you all for your assistance!

    Regards,

    SJ

    • Marked as answer by SJ_PPM Monday, February 28, 2011 9:41 PM
    Monday, February 28, 2011 9:41 PM