none
Folder Redirection with Group Policy not working

    Question

  • I have followed the following guide to try and setup folder redirection with GPO but no matter what I do whenever the user logs in the folders always point to the local machine:

    https://technet.microsoft.com/en-us/library/jj649078(v=ws.11).aspx

    I have verified that the users can access the share i created I can manaully move the folders to that location. But no matter what I try I cannot get GPO to automatically apply the redirection.

    I am running Server 2012 R2 with a Windows 10 Client.

    Friday, August 19, 2016 5:04 AM

Answers

  • Hi Lewis,

    Follow those actions below:

    1. For \\hit-toor-dc01\RedirectedFolders, try to delegate everyone read/write permission
    2. Create a user OU and add those user, which want to apply the folder redirection policy
    3. Create a GPO and link to the user OU
    4. Configure the folder redirection setting under the path below:

    User Configuration\Policies\Windows Settings\Folder Redirection

    1. Logon client with those users, which is part of user OU above, and run gpupdate /force
    2. If the policy still not apply, try to logon again

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Lewis Hackfath Wednesday, August 24, 2016 5:04 AM
    Wednesday, August 24, 2016 1:55 AM
    Moderator

All replies

  • Hi Lewis,

    Thanks for your post.

    First, I suggest you check the path folder for folder redirection is a UNC path(\\fileserver\folderredirection) and user could access it on client.

    If the path is ok, I suggest you run gpresult /h C:\gpresult.html and post it to us for further research.

    Here is an article below about how to configure folder redirection for your reference.

    Simple Step : Configure Folder Redirection in Window Server 2012 R2

    https://mizitechinfo.wordpress.com/2014/11/18/simple-step-configure-folder-redirection-in-window-server-2012-r2/

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 19, 2016 8:28 AM
    Moderator
  • Thanks for replying.

    The path i am using is:

    \\hit-toor-dc01\redirectedfolders

    all users have permission for this folder and i have verified this by creating a folder and file in it under a domain user.

    from the results of the gpresult i can see that the group policy is not being applied and i have no idea why.

    http://hitmediasolutions.com.au/gpresult.html

    Friday, August 19, 2016 11:53 PM
  • I am still having trouble with this.
    Tuesday, August 23, 2016 4:50 AM
  • Hi,

    From gpresult, there is no any folder redirections setting are configured.

    I suggest you try to configure it again. And make sure the settings are configured.

    all users have permission for this folder and i have verified this by creating a folder and file in it under a domain user.

    >>>I suggest you logon with the domain user and run gpresult.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 23, 2016 9:29 AM
    Moderator
  • I have followed the guide you posted and created the group policy.

    I deleted the local copies of the domain users profile from the windows 10 machine.

    Logged back in as the domain user on the windows 10 machine and reran GPResult and still nothing.

    If i type in to the Explorer address bar:

    \\hit-toor-dc01\RedirectedFolders

    I can access the share and create folders and files as a regular domain user.

    no matter what i do I cannot seem to get this GP to work.

    what could i be doing wrong?

    Tuesday, August 23, 2016 9:17 PM
  • Hi Lewis,

    Follow those actions below:

    1. For \\hit-toor-dc01\RedirectedFolders, try to delegate everyone read/write permission
    2. Create a user OU and add those user, which want to apply the folder redirection policy
    3. Create a GPO and link to the user OU
    4. Configure the folder redirection setting under the path below:

    User Configuration\Policies\Windows Settings\Folder Redirection

    1. Logon client with those users, which is part of user OU above, and run gpupdate /force
    2. If the policy still not apply, try to logon again

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Lewis Hackfath Wednesday, August 24, 2016 5:04 AM
    Wednesday, August 24, 2016 1:55 AM
    Moderator
  • I feel really stupid now.

    I had the GP in an OU but all the users weren't in that OU

    thanks for the assistance.

    Wednesday, August 24, 2016 5:05 AM
  • Hi Lewis,

    I am glad to hear that your problem has been resolved.

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 24, 2016 5:07 AM
    Moderator