none
Hotfix (4.1.3559) installation on the second portal node fails RRS feed

  • Question

  • Hi,

    I'm installing FIM hotfix (4.1.3559). It installed without issues on sync server and first node of the portal/service. On second node it is failing. Here is place from the log (most probably failing somewhere here):


    StartServices: Service: Forefront Identity Manager Service
    MSI (s) (70:D4) [16:57:19:635]: Executing op: ActionStart(Name=PatchRemoveFIMPortal,,)
    Action 16:57:19: PatchRemoveFIMPortal.
    MSI (s) (70:D4) [16:57:19:635]: Executing op: CustomActionSchedule(Action=PatchRemoveFIMPortal,ActionType=1025,Source=BinaryData,Target=CAQuietExec,CustomActionData="C:\Program Files\Microsoft Forefront Identity Manager\2010\Portal\Microsoft.IdentityManagement.SolutionPackUtility.exe" action=uninstall mode=ServiceAndPortal log=event SHAREPOINTTIMEOUT=180 SolutionPack=MicrosoftIdentityManagement.wsp deleteweb=no continueonerror=no UILevel=5)
    MSI (s) (70:2C) [16:57:19:790]: Invoking remote custom action. DLL: C:\Windows\Installer\MSICD1E.tmp, Entrypoint: CAQuietExec
    CAQuietExec:  Microsoft.IdentityManagement.SolutionPackUtility.exe will deploy and/or retract the FIM solution packs. This operation may take long time in a SharePoint farm environment.
    CAQuietExec:  Executing all administrative timer jobs in preparation for FIM solution pack retraction.
    CAQuietExec:  An exception occurred while deploying/retracting FIM Portal solution packs. Exception : Exception has been thrown by the target of an invocation.
    CAQuietExec:  Error 0xfffffff9: Command line returned an error.
    CAQuietExec:  Error 0xfffffff9: CAQuietExec Failed
    CustomAction PatchRemoveFIMPortal returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    09/27/2014 16:57:28.791 [7024]: Assembly Install: Failing with hr=80070005 at RemoveDirectoryAndChildren, line 398

    09/27/2014 16:57:28.791 [7024]: Detailed info about C:\Windows\assembly\tmp\S9M6DS80\Microsoft.ResourceManagement.dll

    09/27/2014 16:57:28.791 [7024]:  File attributes: 00000080

    09/27/2014 16:57:28.948 [7024]:  Restart Manager Info: 1 entries

    09/27/2014 16:57:28.948 [7024]:   App[0]: (7024) Windows Installer (msiserver), type = 3

    09/27/2014 16:57:28.948 [7024]:  Security info:

    09/27/2014 16:57:28.948 [7024]:   Owner: S-1-5-18

    09/27/2014 16:57:28.948 [7024]:   Group: S-1-5-18

    09/27/2014 16:57:28.948 [7024]:   DACL information: 4 entries:

    09/27/2014 16:57:28.948 [7024]:   ACE[0]: Type = 0x00, Flags = 010, Mask = 001f01ff, SID = S-1-5-18

    09/27/2014 16:57:28.948 [7024]:   ACE[1]: Type = 0x00, Flags = 010, Mask = 001f01ff, SID = S-1-5-32-544

    09/27/2014 16:57:28.948 [7024]:   ACE[2]: Type = 0x00, Flags = 010, Mask = 001200a9, SID = S-1-5-32-545

    09/27/2014 16:57:28.948 [7024]:   ACE[3]: Type = 0x00, Flags = 010, Mask = 001200a9, SID = S-1-15-2-1

    09/27/2014 16:57:28.963 [7024]: Assembly Install: Failing with hr=80070005 at RemoveDirectoryAndChildren, line 398

    09/27/2014 16:57:28.963 [7024]: Detailed info about C:\Windows\assembly\tmp\WGGUV4IP\Microsoft.IdentityManagement.Logging.dll

    09/27/2014 16:57:28.963 [7024]:  File attributes: 00000080

    09/27/2014 16:57:29.088 [7024]:  Restart Manager Info: 1 entries

    09/27/2014 16:57:29.088 [7024]:   App[0]: (7024) Windows Installer (msiserver), type = 3

    09/27/2014 16:57:29.088 [7024]:  Security info:

    09/27/2014 16:57:29.088 [7024]:   Owner: S-1-5-18

    09/27/2014 16:57:29.088 [7024]:   Group: S-1-5-18

    09/27/2014 16:57:29.088 [7024]:   DACL information: 4 entries:

    09/27/2014 16:57:29.088 [7024]:   ACE[0]: Type = 0x00, Flags = 010, Mask = 001f01ff, SID = S-1-5-18

    09/27/2014 16:57:29.088 [7024]:   ACE[1]: Type = 0x00, Flags = 010, Mask = 001f01ff, SID = S-1-5-32-544

    09/27/2014 16:57:29.104 [7024]:   ACE[2]: Type = 0x00, Flags = 010, Mask = 001200a9, SID = S-1-5-32-545

    09/27/2014 16:57:29.104 [7024]:   ACE[3]: Type = 0x00, Flags = 010, Mask = 001200a9, SID = S-1-15-2-1

    09/27/2014 16:57:29.104 [7024]: Assembly Install: Failing with hr=80070005 at RemoveDirectoryAndChildren, line 398

    09/27/2014 16:57:29.104 [7024]: Detailed info about C:\Windows\assembly\tmp\NJBBJ7LC\Microsoft.IdentityManagement.CredentialManagement.Portal.Gates.dll

    09/27/2014 16:57:29.104 [7024]:  File attributes: 00000080

    09/27/2014 16:57:29.244 [7024]:  Restart Manager Info: 1 entries

    09/27/2014 16:57:29.244 [7024]:   App[0]: (7024) Windows Installer (msiserver), type = 3

    09/27/2014 16:57:29.244 [7024]:  Security info:

    09/27/2014 16:57:29.244 [7024]:   Owner: S-1-5-18

    09/27/2014 16:57:29.244 [7024]:   Group: S-1-5-18

    09/27/2014 16:57:29.244 [7024]:   DACL information: 4 entries:

    09/27/2014 16:57:29.244 [7024]:   ACE[0]: Type = 0x00, Flags = 010, Mask = 001f01ff, SID = S-1-5-18

    09/27/2014 16:57:29.244 [7024]:   ACE[1]: Type = 0x00, Flags = 010, Mask = 001f01ff, SID = S-1-5-32-544

    09/27/2014 16:57:29.244 [7024]:   ACE[2]: Type = 0x00, Flags = 010, Mask = 001200a9, SID = S-1-5-32-545

    09/27/2014 16:57:29.244 [7024]:   ACE[3]: Type = 0x00, Flags = 010, Mask = 001200a9, SID = S-1-15-2-1

    09/27/2014 16:57:29.275 [7024]: Assembly Install: Failing with hr=80070005 at RemoveDirectoryAndChildren, line 398

     Any suggestions/hints? I belive it is something with SharePoint (SP Foundation 2013 is used/ no farms).

    By the way - in the similar setup in test environment it went OK. Right now it is failing on the production


    Borys Majewski, Identity Management Solutions Architect (Blog: IDArchitect.NET)

    Saturday, September 27, 2014 8:27 PM

Answers