locked
NEC DVD ND-3520A using cdrom.sys driver Vista Ultimate RRS feed

  • Question

  • I'm having a problem with my optical drive. NEC ND-3520A DVD/CD-RW(DL) drive has been having issue since i installed Ultimate. At first it wouldnt even show up in Vista. After a firmware update to 3.07 (current firmware release) the driver now shows up. My problem now is that it will not read Dual Layer discs, and also have a lot of trouble reading cd's and dvd's. I've had the system hang and freeze a handful of times.

    I tried using a solution i found here in the forums of erasing the registry keys for the UpperFilters and LowerFilters on the drive. That didn't change anything for me. Having looked closely at the driver that is being applied, its cdrom.sys from Windows. I do not know the particulars about this driver but does this driver not support dvd's or dual layer discs? the drive definitely does not seem to like working with that driver, so if someone can try to help me find another driver to try/use it would be much appreciated.

    Asus A8R32-MVP mobo//AMD Athlon 64 x2 4400+//2gb Corsair DDR//ATI Radeon x1900 512mb//Soundblaster Xfi Platinum//NEC ND-3520A DVD/CD-RW(DL)

    Thursday, February 8, 2007 12:09 AM

All replies

  • anyone else have this problem? can help me? bump?
    Thursday, February 8, 2007 11:28 PM
  • I'm having trouble with mine too. NEC-3520A ... I backed up a bunch of mp3s onto DVD-R and +R media and when it gets to around the last file on the disk, the copy process just kinda stops and the drive slows down and doesn't do anything. This is extremely aggrivating. I can't find any posts about it online other than this one either... So rest assured... You aren't the only one.
    Let's dedicate this thread to finding a solution. For starters what are you talking about with those registry values? Could you direct me to them so I could give them a try too ? Thanks.
    Saturday, February 10, 2007 11:13 PM
  • UPDate: Doesn't work using regular CDs either. Each one I try gets about half way through and says "Cannot read from source."

    Edit:
    I was trying to read a blank CD. I'm an idiot.
    Saturday, February 10, 2007 11:30 PM
  • I've found what my problem is. Don't know if it will help you.
    The best way to describe it is a timeline.

    Timeline:

    1. I burn backups of my mp3's to DVD+R media (I ran out of DVD-R).

    2. I install windows vista (fresh install).

    3. The drive is behaving funky. I update to the latest firmware (3.07)

    4. I try to grab some info off the DVD+R's ... Some of them are successful and some of them stop transferring for no reason and get hung up in the same spot each time.

    5. I put the problem DVD+R in my Ubuntu box and the disc stops reading at the same place that Vista stopped reading it.

    6. I try reading the disc at that location at work in the DVD-Rom drive there... It doesn't read EITHER....

    Conclusion: 1 of two things.

    1. The media is crappy and doesn't perform to standard.

    Much more likely (It's Ri-Data come on they are great! :D ):
    2. Before doing the firmware update, the drive had problems writing to DVD+R media correctly but Nero never complained. Although I never verified data written either which probably would have yielded these errors much earlier than trying to diagnose an aggrivating problem.

    So there you have it my final diagnoses.

    Now to try burning to another DVD+R media disk and see if I can replicate the problem.

    I hope this post helps some people.
    Wednesday, February 14, 2007 2:29 AM