none
iSCSI Initiator Problem: 'Initiator Instance Does Not Exist' RRS feed

  • Question

  • We have SBS 2008 and are trying to connect an iSCSI target to it.  I can see the target, but when I click on 'Log On to Target,' specify the 'CHAP logon information' under 'Advanced', I consistently get the error message:

    'Initiator Instance Does Not Exist'

    I am able to connect to the target just fine on both of our Server 2008 R2 systems. 

    Any thoughts on how to troubleshoot this problem?

    • Moved by Santosh Bhandarkar Thursday, August 1, 2013 2:46 AM Moved from Server General Forum
    Wednesday, July 31, 2013 9:07 PM

All replies

  • Hi ,

    Thank you for posting your issue in the forum.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best Regards,

    Andy Qi


    Andy Qi
    TechNet Community Support

    Friday, August 2, 2013 12:27 PM
    Moderator
  • Hi Andy,

    Thank you for your assistance.

    Jason

    Tuesday, August 6, 2013 2:43 PM
  • Hi Naveen,

    Thank you for the information, however, I'm not able to use that information to resolve the problem.  It seems very technical and not related to our issue.

    Jason

    Wednesday, August 7, 2013 5:11 PM
  • One more thing - in the iSCSI Initiator Properties, Discovery tab, Target Portals section.  If I add the NAS to this section, I get the same 'Initiator Instance Does Not Exist' error, but then the address shows up under the Target Portals section.

    If I add it as an iSNS server on the bottom of this window, it adds fine and then I see the targets under the 'Targets' tab.  But, when I try and connect to the target, I get the 'Initiator Instance Does Not Exist' error.

    Wednesday, August 7, 2013 5:56 PM
  • Hi,

    For this issue, please try to  uninstalled/reinstalled ISCSI Initiator through device manager to check whether this issue persists.

    If you get any antivirus software installed, please uninstall it firstly.

    http://blogs.msdn.com/b/storwdk/archive/2007/11/15/iscsi-error-codes-and-descriptions-from-iscsierr-h.aspx

    Thanks,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. 

    Friday, August 16, 2013 6:48 AM
  • Hi Leo,

    When looking at device manager, I do not see the iSCSI initiator.  How do you uninstall and reinstall the iSCSI initiator in Windows Small Business Server 2008?

    Jason

    Sunday, August 18, 2013 1:45 PM
  • Hi,

    Does the NAS has any iSCSI Target installed on it. What NAS solution do you use, Does it have an option to use SCSI LUN. Have you configured it to be used by the specific client.


    Thanks,

    Thursday, August 22, 2013 12:48 AM
  • Hi Naveen,

    Yes, the NAS has an iSCSI target configured and I can connect to it just fine with the iSCSI initiator on both of our Windows 2008 R2 servers.

    However, when I try and connect with the SBS 2008 server, I get the 'Initiator Instance Does Not Exist' error, which makes me suspect something is wrong with the SBS 2008 server.

    Our NAS is an iomega StorCenter ix2-dl.

    Jason

    Thursday, August 22, 2013 2:42 PM
  • Hi Bakavan,

    I know that there is no issue with windows server 2008 R2 when connecting to the NAS, but only with SBS 2008 server.

     Now do you have any other SBS 2008 server, if the same error occurs when connecting it?

    Have you successfully connected the NAS before from this SBS 2008 server?

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. 

    Tuesday, September 17, 2013 7:13 AM
  • Hi Leo,

    Unfortunately,  we don't have any other SBS 2008 servers we can try it on, and we have never successfully connected the NAS to our SBS 2008 server.

    Jason

    Wednesday, September 18, 2013 1:13 AM
  • Hi BakaVan,

    From your description and my research, it seems like less customer have this issue, now please try to contact NAS vendor  ix2 to check whether it is supported connecting from SBS server 2008.

    http://support.lenovoemc.com/ix2

    http://go.iomega.com/en-us/products/network-storage-desktop/storcenter-network-storage-solution/network-hard-drive-ix2/?partner=4760

    Thanks,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. 

    Tuesday, September 24, 2013 6:34 AM
  • Hi

    I Have the same Problem with SBS 2011 Server. We use QNAP and it works with other servers too. So It must be something related to the SBS server.

    Wednesday, October 30, 2013 9:20 AM
  • I can't even find the local iscsi initator adapter. It looks like something is not started here. Any success yet finding a solution?
    Wednesday, October 30, 2013 9:26 AM
  • I can't even find the local iscsi initator adapter. It looks like something is not started here. Any success yet finding a solution?

    On the iSCIS Initiator Properties (from e.g. control panel) click the Discovery tab, click Add, then you MUST to go to the "Advanced..." and select the Local Adapter (Microsoft iSCSI Initiator) letting it "default" does not work correctly.
    Saturday, August 9, 2014 5:26 PM
  • When I go to the iSCSI Initiator Properties, then Discovery tab, then 'Add Portal' under 'Target Portals', then click on the 'Advanced' button, in the 'General' tab under 'Connect by using' then selecting the dropdown box beside 'Local Adapter', the only option available is 'Default'

    We are able to connect to the NAS over iSCSI on our new Server 2012 R2 server, but our old SBS 2008 still will not connect with the same message as from over a year ago: 'Initiator Instance Does Not Exist'.

    Monday, August 11, 2014 2:43 PM
  • When I go to the iSCSI Initiator Properties, then Discovery tab, then 'Add Portal' under 'Target Portals', then click on the 'Advanced' button, in the 'General' tab under 'Connect by using' then selecting the dropdown box beside 'Local Adapter', the only option available is 'Default'

    We are able to connect to the NAS over iSCSI on our new Server 2012 R2 server, but our old SBS 2008 still will not connect with the same message as from over a year ago: 'Initiator Instance Does Not Exist'.


    Did you ever find a solution?  I just encountered the same issue on windows server 2012 r2 datacenter.
    Monday, January 11, 2016 12:47 AM
  • No, still no solution to this problem - hopefully the problem will go away when our SBS 2008 server gets retired next month.  We did not have the problem on Server 2012 R2 Standard, and were also able to get Hyper-V Server 2012 to connect to it just fine. It seemed like it was something funny with SBS, but after your note about the same issue with 2012 R2 Datacenter, perhaps there is something else going on.
    Monday, January 11, 2016 2:33 AM
  • No, still no solution to this problem - hopefully the problem will go away when our SBS 2008 server gets retired next month.  We did not have the problem on Server 2012 R2 Standard, and were also able to get Hyper-V Server 2012 to connect to it just fine. It seemed like it was something funny with SBS, but after your note about the same issue with 2012 R2 Datacenter, perhaps there is something else going on.

    I hacked at it on mine this evening and got it going again (after I posted, because it seems like you, me, and one other guy are the only ones who have seen this issue). My procedure: 1. stop iscsi service 2. rename/delete iscsi config registry key (HKLM:\SOFTWARE\Microsoft\Windows NT\CurrentVersion\iSCSI) and all sub keys. 3. reboot server 4. open the iscsi initiator properties and go through the initial configuration again.

    My specific case is a windows 2012 R2 datacenter server in a cluster managed by virtual machine manager 2012 r2.  The iscsi connection in question (which was the only one on that computer, with only parallel connections from other nodes in the cluster i.e. two nodes connecting to one iscsi target and no others) was not managed by VMM.

    • Proposed as answer by Sener A Sunday, July 2, 2017 2:37 AM
    Monday, January 11, 2016 2:54 AM
  • Ran into this same issue on a Windows 8 box.  Jordan's fix worked for me.
    Tuesday, April 4, 2017 3:26 PM
  • Ran into the same issue on Win10 (1703). This procedure worked at me.. Thanks
    Sunday, October 1, 2017 7:26 AM
  • Hi, I just ran into this problem trying to connect to my SYNOLOGY NAS with my Windows 10 Pro client PC.

    Solution for me was:

    1. open compmgmt.msc
    2. Device Manager
    3. Storage Controller
    4. In my case there was a "unknown controller"
    5. right click on "unknown controller" and "search for drivers"

    After a couple of seconds the "unknown controller" was replaced by "Microsoft iSCSI initiator"

    This fixed the problem for me.

    Hope it helps someone else.


    --- workaholic

    Monday, October 9, 2017 4:41 PM
  • Thank you!
    Thursday, October 19, 2017 10:33 PM
  • I had the same problem on a Microsoft 2008 R2 SBS server and my solution was similar to that provided by workaholic above.

    What worked for me was to open Control Panel > Device Manager and expand Storage Controllers where there was listed an Unknown Device like workaholic mentioned.  However, when I attempted to update the driver it stated that I already have the most recent driver for my device "Microsoft iSCSI Initiator".  Confident that it was most likely the correct device and I did a simple DISABLE and ENABLE on the device and when it was re-enabled the title changed from Unknown Device to Microsoft iSCSI Initiator.  So I went back to the iSCSI Initiator control panel and on the Discovery tab clicked the Discover Portal button which opened a window for me to enter the ip address or dns name of my target system and this time it proceeded to find my iSCSI target.

    Hope this helps!


    Monday, March 12, 2018 9:19 PM
  • Ran into the same issue on a Windows 2012 R2 Standard server. I deleted the registry key like you said and rebooted and now it is working. Thanks for the help!

    Lyle Epstein
    Kortek Solutions
    http://www.korteksolutions.com

    Saturday, July 13, 2019 8:21 PM