none
DPM Agent Communication Error RRS feed

  • Question

  • We get the following error sporadically, and it seems to always deal with an Exchange Server service stealing the DPMRA port. Is there any way to get this to stop. We have to put the mailbox server in 2010 into DAG maintenance and restart services. This is not optimal. The below error is what we receive. Seems to be the Microsoft Exchange Replication Service:

    DPM failed to communicate with servername because of a communication error with the protection agent. (ID 53 Details: Server execution failed (0x80080005))

    We run DPM 2012

    Thanks

    Sunday, September 28, 2014 11:42 PM

Answers

  • mkcj84,

    What version of DPM are you on> with RU3 for DPM2012R2 you can set what ports DPM uses

    http://support.microsoft.com/kb/2966014/en-us

    This update lets administrators configure the DPMRA port and select a nondefault port by following these steps:
    1. Install UR3 for DPM 2012 R2.
    2. Run Setagentcfg.exe by using the following command:

      setagentcfg.exe s <protected_server_FQDN> <alternative_port>

      Notes
      • In this command, <var><alternative port></var> represents the nondefault port.
      • By default, this command should be located in the following folder:
        %PROGRAMFILES%/Microsoft System Center 2012 R2/DPM/DPM/Setup
    3. Verify that a new entry is created in the following registry subkey:
      HKEY_LOCAL_MACHINE \Software\Microsoft\Microsoft Data Protection Manager\Agent\2.0\PsPortConfig
    4. Copy the setagentcfg.exe file from the DPM server to the following folder on the protected computer:
      %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin
    5. Run the following command on the protected server:
      setagentcfg.exe e DPMRA <alternative port>
      Note Use the same port number that is specified in step 1.
    6. Restart the DPM server.
    7. Restart the DPMRA service on the protected server.


    Regards, A.Nadar, This posting is provided &quot;AS IS&quot; with no warranties, and confers no rights.

    • Marked as answer by mkcj84 Wednesday, November 5, 2014 12:09 PM
    Tuesday, November 4, 2014 11:47 PM
    Moderator

All replies

  • Hi

    What is the network latency between dpm and the exchange server? If you manually run the backup does it succeed? Are you running the latest rollup for dpm and agent for exchange?


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, October 2, 2014 8:20 PM
  • 1. Latency is not high at all, they are same site

    2. Will not succeed, just gives the communication error

    3. Latest Rollup for Exchange, I believe 5 or 6

    4. DPm 2012 R2 RU1, the RU2 and 3 didn't seem to apply to our config. 

    Friday, October 3, 2014 2:49 AM
  • mkcj84,

    What version of DPM are you on> with RU3 for DPM2012R2 you can set what ports DPM uses

    http://support.microsoft.com/kb/2966014/en-us

    This update lets administrators configure the DPMRA port and select a nondefault port by following these steps:
    1. Install UR3 for DPM 2012 R2.
    2. Run Setagentcfg.exe by using the following command:

      setagentcfg.exe s <protected_server_FQDN> <alternative_port>

      Notes
      • In this command, <var><alternative port></var> represents the nondefault port.
      • By default, this command should be located in the following folder:
        %PROGRAMFILES%/Microsoft System Center 2012 R2/DPM/DPM/Setup
    3. Verify that a new entry is created in the following registry subkey:
      HKEY_LOCAL_MACHINE \Software\Microsoft\Microsoft Data Protection Manager\Agent\2.0\PsPortConfig
    4. Copy the setagentcfg.exe file from the DPM server to the following folder on the protected computer:
      %PROGRAMFILES%\Microsoft Data Protection Manager\DPM\bin
    5. Run the following command on the protected server:
      setagentcfg.exe e DPMRA <alternative port>
      Note Use the same port number that is specified in step 1.
    6. Restart the DPM server.
    7. Restart the DPMRA service on the protected server.


    Regards, A.Nadar, This posting is provided &quot;AS IS&quot; with no warranties, and confers no rights.

    • Marked as answer by mkcj84 Wednesday, November 5, 2014 12:09 PM
    Tuesday, November 4, 2014 11:47 PM
    Moderator