locked
Cannot Uninstall Internet Explorer 7 with WIndows server 2008. RRS feed

  • Question

  • I am using WIndows server 2008(Operatiing System).

    I am unable to find Uninstall IE 7.0 either at Add/Remove Programs or other areas. In a Scenario where i need to use IE 8.0 and  here i downloaded free version IE 8.0 and installed (Not sure whether its replaced IE 7.0 or two versions exists together). When I Invoke IE 8.0 one single instance where i go and check the same in Task Mgr - Processes here the list shows 2 IE Processes opened. (Where i manually opened one IE 8.0 Browser due to this issue I am unable to automate the system.)

    Thanks

    Sathya

     

     

     

    • Edited by Sathya_tel Tuesday, September 21, 2010 4:25 PM
    Tuesday, September 21, 2010 11:22 AM

Answers

  • Hi,

     

    I tested the relationship between the IE tab and iexplore.exe and found that they have no direct relation. For why there are two iexplore.exe process when run it just once, please refer to the following link:

    http://ask-leo.com/why_are_there_two_iexploreexe_internet_explorer_processes_when_ive_run_it_just_once.html

    Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    For the software development issue, the best resource is Microsoft Developer Network Forum. They are familiar with the development issue. I recommend you ask for further assistance in Microsoft Developer Network Forum below:

    http://social.msdn.microsoft.com/Forums/en/categories/

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, September 22, 2010 7:37 AM
  • Hi,

     

    I would like to confirm that have you submit the question in Microsoft Developer Network Forum and what is the current situation? If there is anything that I can do for you, please do not hesitate to let me know, and I will be happy to help.

    I agree. you can split the thread and move this part in MSDN Forum.

    Thanks.


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    Friday, September 24, 2010 6:54 AM

All replies

  • Hi,

    you can't uninstall IE 7 from Windows Server 2008 because it's a component of operanting system and even because you have replaced it with IE 8. Two IE processes that you see in Task Manager are both IE 8.

    HTH


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    Tuesday, September 21, 2010 11:57 AM
  • Hey Edoardo Benussi,

    Thanks for your Quick Reply.

    I agree that IE 7.0 cannot be uninstalled from Windows server 2008 as it is a component of Operating System.

    could you please clarify the below queries:

    1) If i Install IE 8.0 will it get replace IE 7.0 or both Instances IE 8.0 & IE 7.0 will be available?

    2) I manually open only one IE 8.0 browser, when i check the same in the Task Mgr-Processes list it shows two processes. (why it shows two processes-could you please brief what could be the issue-If any problem exists how to overcome.)

    3) Due to the above issue i was unable to automate the VB script using QTP 9.5.

    Thanks

    Sathya

     

     

     

     

     

     

    Tuesday, September 21, 2010 4:34 PM
  • could you please clarify the below queries:

    1) If i Install IE 8.0 will it get replace IE 7.0 or both Instances IE 8.0 & IE 7.0 will be available?

    2) I manually open only one IE 8.0 browser, when i check the same in the Task Mgr-Processes list it shows two processes. (why it shows two processes-could you please brief what could be the issue-If any problem exists how to overcome.)

    3) Due to the above issue i was unable to automate the VB script using QTP 9.5.


    1) if you install IE 8.0, it replaces IE 7.0 and only 8.0 version will be available.

    2) number of iexplore.exe instancies depends on number of tabs that are opened in IE. more tabs, more processes. you can have even five, six, seven processes.

    3) can you explain better the problem ? what is QTP 9.5 ?


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    Wednesday, September 22, 2010 7:26 AM
  • Hi,

     

    I tested the relationship between the IE tab and iexplore.exe and found that they have no direct relation. For why there are two iexplore.exe process when run it just once, please refer to the following link:

    http://ask-leo.com/why_are_there_two_iexploreexe_internet_explorer_processes_when_ive_run_it_just_once.html

    Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

     

    For the software development issue, the best resource is Microsoft Developer Network Forum. They are familiar with the development issue. I recommend you ask for further assistance in Microsoft Developer Network Forum below:

    http://social.msdn.microsoft.com/Forums/en/categories/

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, September 22, 2010 7:37 AM
  • Hey Edoardo Benussi,

    Sytem Requirements which i used:

    Operating System: Windows server 2008.

    HP - QTP Tool(Functional Testing Tool) - 9.5 version.

    Internet Explorer - 8.0.

    Here I am using VBScript to automate the website to run with QTP Application(Quick Test Professional) using a .VBS (extension file).

    Below is the code for VB script:

    Dim qtApp
    Set qtApp = CreateObject("QuickTest.Application") - creating object for the QTP Application.
    qt\App.Launch
    qtApp.Visible = True
    '*****************************Adding Libraries***********************************************
    'strqpath = "D:\Automation\Automation-Aug30th\QA\Automation_30Aug_2010\Bin\Library\"
    'strlibpath1=strqpath&"Library File\Libraryutills.txt"
    'Set qtTest = qtApp.Test
    'Set qtLibraries = qtApp.Test.Settings.Resources.Libraries ' Get the libraries collection object
    'qtLibraries.Add strlibpath1,1

    qtApp.Open "D:\Latest\Enrollment",True (' Open the test in read-only mode - This is the Test script which Invokes IExplorer and runs the test script on top of the web application.)

    (The below command which i used in QTP.exe application to invoke Iexplore.exe using the below URL path.)

    SystemUtil.Run "IEXPLORE.EXE","http://www.google.com" - (this is the command Which Invokes IExplore.exe instance)

    running the above command displays "Internet Explorer has stopped working".

    Then i clicked on "debug the program" ( the below listed content is the Output from Debug Progam).

    'iexplore.exe': Loaded 'C:\Program Files\Internet Explorer\iexplore.exe'
    'iexplore.exe': Loaded 'C:\Windows\System32\ntdll.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\kernel32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\advapi32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\rpcrt4.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\user32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\gdi32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\msvcrt.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\shlwapi.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\shell32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\ole32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\iertutil.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\urlmon.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\oleaut32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\imm32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\msctf.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\lpk.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\usp10.dll'
    'iexplore.exe': Loaded 'C:\Windows\winsxs\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.6002.18005_none_5cb72f96088b0de0\comctl32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\ieframe.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\comdlg32.dll'
    'iexplore.exe': Loaded 'C:\Program Files\Internet Explorer\IEShims.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\MicAgentInjector.dll'
    'iexplore.exe': Loaded 'C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4016_none_d0893820442e7fe4\msvcr80.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\psapi.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\acx_trap.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\AcxSettings.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\std-vc-mt.dll', Binary was not built with debug information.
    'iexplore.exe': Loaded 'C:\Windows\System32\msvcp71.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\msvcr71.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\imagehlp.dll'
    'iexplore.exe': Loaded 'C:\Windows\winsxs\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4016_none_d0893820442e7fe4\msvcp80.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\AsmHook.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\bbHookLoaderU.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\acx_srv.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\AcxOutputChannel.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\MicPackVariant.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\ime_srv.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\MngLoaderU.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\NetDispExpose.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\mscoree.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\vb_trap.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\msvbvm60.dll', Cannot find or open a required DBG file.
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\ie_hooksU.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\version.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\wininet.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\normaliz.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\mosifs32.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\thrdutil.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\mmalloc_logic.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\WIAgentLogFileU.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\oleacc.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\setupapi.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\userenv.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\secur32.dll'
    'iexplore.exe': Loaded 'C:\Windows\System32\propsys.dll'
    'iexplore.exe': Loaded 'D:\Program Files1\HP\QuickTest Professional\bin\IfsHookManager.dll'
    The thread 'Win32 Thread' (0x660) has exited with code 0 (0x0).
    Unhandled exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    First-chance exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    Unhandled exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    First-chance exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    Unhandled exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    First-chance exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    The thread 'Win32 Thread' (0x1038) has exited with code 0 (0x0).
    Unhandled exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    First-chance exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    Unhandled exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    First-chance exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    Unhandled exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    First-chance exception at 0x765ad1be in iexplore.exe: 0xC0000005: Access violation reading location 0x00000001.
    The thread 'Win32 Thread' (0x1610) has exited with code 1 (0x1).
    The thread 'Win32 Thread' (0x1330) has exited with code 1 (0x1).
    The thread 'Win32 Thread' (0x17dc) has exited with code 1 (0x1).
    The thread 'Win32 Thread' (0xedc) has exited with code 1 (0x1).
    The thread 'Win32 Thread' (0x10cc) has exited with code 1 (0x1).
    The thread 'Win32 Thread' (0x11e4) has exited with code 1 (0x1).
    The program '[4288] iexplore.exe: Native' has exited with code 1 (0x1).

    Where if i run the Systemutil.run "Iexplore.exe", "http://www.google.com" runs individually in the QTP Application it works fine.

    If it runs through configuration script the above mentioned issue occurs.

     

     

    Wednesday, September 22, 2010 11:06 AM
  • Hi,

     

    I would like to confirm that have you submit the question in Microsoft Developer Network Forum and what is the current situation? If there is anything that I can do for you, please do not hesitate to let me know, and I will be happy to help.

     

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, September 24, 2010 4:41 AM
  • Hi,

     

    I would like to confirm that have you submit the question in Microsoft Developer Network Forum and what is the current situation? If there is anything that I can do for you, please do not hesitate to let me know, and I will be happy to help.

    I agree. you can split the thread and move this part in MSDN Forum.

    Thanks.


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    Friday, September 24, 2010 6:54 AM
  • Hey Arthur_Li / Edoardo Benussi,

    Thanks for your help.

    As you said i posted the Question in the Microsoft Development Network Forum while ago.

    The below link:

    Internet Explorer Developer Center > Internet Explorer Development Forums > Internet Explorer Web Development > Invoking IExplore with VBscript command "Systemutil.run" displays "Internet Explorer has stopped working".

    Thanks

    Sathya

     

    Friday, September 24, 2010 9:29 AM