locked
UM Presence for a user on Exchange 2016 Mailbox RRS feed

  • Question

  • Hi All,

    I have a mixed mode environment, with Exchange 2013 and 2016 servers.  If a user is housed on an Exchange 2013 mailbox, and access their mailbox via the 2016 OWA, I can see a UM (Skype for Business) presence.  But, an Exchange 2016 user doesnt see presence; in fact the interface is purely the cutdown Exchange 2016 version (more like O365).  

    It looks like you dont get to see presence if the mailbox is 2016 - can someone confirm that for me?

    Thanks

    Craig

    Friday, May 27, 2016 11:51 PM

Answers

  • Hi All,

    I have a mixed mode environment, with Exchange 2013 and 2016 servers.  If a user is housed on an Exchange 2013 mailbox, and access their mailbox via the 2016 OWA, I can see a UM (Skype for Business) presence.  But, an Exchange 2016 user doesnt see presence; in fact the interface is purely the cutdown Exchange 2016 version (more like O365).  

    It looks like you dont get to see presence if the mailbox is 2016 - can someone confirm that for me?

    Thanks

    Craig

    Did you enable the OWA virtual directory on the 2016 server for instantmessaging?

    https://technet.microsoft.com/en-us/library/bb123515(v=exchg.160).aspx

    InstantMessagingCertificateThumbprint

    Optional

    System.String

    The InstantMessagingCertificateThumbprint parameter specifies the trusted certificate used to communicate between the instant messaging server and the Mailbox server. Use the Get-ExchangeCertificate cmdlet to find the thumbprint of the certificate.

    InstantMessagingEnabled

    Optional

    System.Boolean

    The InstantMessagingEnabled parameter specifies whether to enable instant messaging in Outlook on the web.

    InstantMessagingServerName

    Optional

    System.String

    The InstantMessagingServerName parameter specifies the fully qualified domain name (FQDN) of the instant messaging server or set of servers behind a load balancing device.

    InstantMessagingType


    Blog:    Twitter:   

    • Proposed as answer by Lynn-Li Monday, May 30, 2016 8:24 AM
    • Marked as answer by Andy DavidMVP Sunday, June 26, 2016 11:56 AM
    Saturday, May 28, 2016 11:18 AM
  • Thanks Andy.

    When I run the:

    New-SettingOverride -Name   -Component OwaServer -Section IMSettings -Parameters @(“IMServerName=<lync\sfb server=”” or=”” pool=”” fqdn=””>”,”IMCertificateThumbprint=”) -Reason “Configure IM” -MinVersion “15.01.0225.41”

    command, then run >Get-OwaVirtualDirectory -server servername | select instant*

    command, the InstantMessagingCertificateThumbprint and InstantMessagingSerName field are blank, and InstantMessagingType is none.

    So, I tried to set those manually set-owavirtualdirectory command.

    Just so I'm confirming the certificate, this should be the certificate on the Exchange 2016 server which has IM services assigned to it?   Also, does that certificate need to have the same subject name as the OWA itself?

    Thanks

    Craig


    It can be any certificate that is trusted by Exchange and Lync/skype actually but typically its the same one used for the UM services. I find things work better if the Common Name of the cert matches the Exchange Server FQDN.

    Blog:    Twitter:   


    Sunday, May 29, 2016 11:27 AM
  • Managed to fix this.  Turns out I had used the certificate assigned to the IIS site whereas it needed to be the UM cerfificate.  As soon as I changed that it started to work.

    Thanks all.

    • Marked as answer by Andy DavidMVP Sunday, June 26, 2016 11:56 AM
    Friday, June 24, 2016 2:50 PM

All replies

  • Hi All,

    I have a mixed mode environment, with Exchange 2013 and 2016 servers.  If a user is housed on an Exchange 2013 mailbox, and access their mailbox via the 2016 OWA, I can see a UM (Skype for Business) presence.  But, an Exchange 2016 user doesnt see presence; in fact the interface is purely the cutdown Exchange 2016 version (more like O365).  

    It looks like you dont get to see presence if the mailbox is 2016 - can someone confirm that for me?

    Thanks

    Craig

    Did you enable the OWA virtual directory on the 2016 server for instantmessaging?

    https://technet.microsoft.com/en-us/library/bb123515(v=exchg.160).aspx

    InstantMessagingCertificateThumbprint

    Optional

    System.String

    The InstantMessagingCertificateThumbprint parameter specifies the trusted certificate used to communicate between the instant messaging server and the Mailbox server. Use the Get-ExchangeCertificate cmdlet to find the thumbprint of the certificate.

    InstantMessagingEnabled

    Optional

    System.Boolean

    The InstantMessagingEnabled parameter specifies whether to enable instant messaging in Outlook on the web.

    InstantMessagingServerName

    Optional

    System.String

    The InstantMessagingServerName parameter specifies the fully qualified domain name (FQDN) of the instant messaging server or set of servers behind a load balancing device.

    InstantMessagingType


    Blog:    Twitter:   

    • Proposed as answer by Lynn-Li Monday, May 30, 2016 8:24 AM
    • Marked as answer by Andy DavidMVP Sunday, June 26, 2016 11:56 AM
    Saturday, May 28, 2016 11:18 AM
  • Thanks Andy.

    When I run the:

    New-SettingOverride -Name   -Component OwaServer -Section IMSettings -Parameters @(“IMServerName=<lync\sfb server=”” or=”” pool=”” fqdn=””>”,”IMCertificateThumbprint=”) -Reason “Configure IM” -MinVersion “15.01.0225.41”

    command, then run >Get-OwaVirtualDirectory -server servername | select instant*

    command, the InstantMessagingCertificateThumbprint and InstantMessagingSerName field are blank, and InstantMessagingType is none.

    So, I tried to set those manually set-owavirtualdirectory command.

    Just so I'm confirming the certificate, this should be the certificate on the Exchange 2016 server which has IM services assigned to it?   Also, does that certificate need to have the same subject name as the OWA itself?

    Thanks

    Craig

    Saturday, May 28, 2016 9:33 PM
  • Thanks Andy.

    When I run the:

    New-SettingOverride -Name   -Component OwaServer -Section IMSettings -Parameters @(“IMServerName=<lync\sfb server=”” or=”” pool=”” fqdn=””>”,”IMCertificateThumbprint=”) -Reason “Configure IM” -MinVersion “15.01.0225.41”

    command, then run >Get-OwaVirtualDirectory -server servername | select instant*

    command, the InstantMessagingCertificateThumbprint and InstantMessagingSerName field are blank, and InstantMessagingType is none.

    So, I tried to set those manually set-owavirtualdirectory command.

    Just so I'm confirming the certificate, this should be the certificate on the Exchange 2016 server which has IM services assigned to it?   Also, does that certificate need to have the same subject name as the OWA itself?

    Thanks

    Craig


    It can be any certificate that is trusted by Exchange and Lync/skype actually but typically its the same one used for the UM services. I find things work better if the Common Name of the cert matches the Exchange Server FQDN.

    Blog:    Twitter:   


    Sunday, May 29, 2016 11:27 AM
  • The reason I wondered is that an Exchange 2013 server in the same environment where the UM certificate matches the common name works fine. That said, I don't even see the sign in request starting, ie no error messages showing in the owa client so not convinced it's even starting. One thing I wasn't sure about was the need for SfB configuration to make it work - do you still need to complete the trusted app stuff there? Thanks Craig
    Sunday, May 29, 2016 12:20 PM
  • Sunday, May 29, 2016 11:50 PM
  • Yes done that. Does it matter if you have more than one listing in there?
    Monday, May 30, 2016 8:42 AM
  • Does it matter if you have more than one listing in there?

    Hi,

    Sorry, I don't understand it. Do you mean more than one Common Name listing in Certificate?

    And does it work after you have done all necessary steps?

    Best Regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Lynn-Li
    TechNet Community Support

    Wednesday, June 1, 2016 9:53 AM
  • No, I mean when specifiying the "New-SettingOverride" command.  If I do a "get-settingoverride | fl" command I can see several listed from my testing.

    It doesnt work having performed the steps.  It does however work if I access the mailbox from the OWA on the Exchange 2013 server.

    Friday, June 3, 2016 1:28 PM
  • Managed to fix this.  Turns out I had used the certificate assigned to the IIS site whereas it needed to be the UM cerfificate.  As soon as I changed that it started to work.

    Thanks all.

    • Marked as answer by Andy DavidMVP Sunday, June 26, 2016 11:56 AM
    Friday, June 24, 2016 2:50 PM