locked
stsadm just hangs during any command operation with it. RRS feed

  • Question

  • I've been brought on to a new position in which I need to do an assessment of the existing MOSS 2007 farm.

    One of the problems I'm having is that when I try an stsadm command it just hangs.

    Relevant Information:

    I'm using the farm administrator account to do this.

    I get no output errors; it's like the command never finishes or returns anything.

    Something as simple as: C:\ stsadm -o getadminport just doesn't ever finish.  It just hangs.

    If there are errors, I don't see anything being put into ~\12\LOGS\<logfile> as there is no log file with a current date.

    Any suggestions on trouble shooting this would be much appreciated!  Thanks.

    Thursday, December 5, 2013 1:56 PM

Answers

  • I have had this happen a couple of times due to the following reasons:

    - Failed upgrade or farm stuck in upgrading status. Had to re-run psconfig

    - path was over 255 characters to stsadm. created a system variable named spt and gave it the path to the 12 hive.

    - did not run command shell as admin

    Let us know what happens :) 

    • Marked as answer by R0n Burgundi Monday, November 2, 2015 10:04 PM
    Thursday, December 5, 2013 7:06 PM

All replies

  • Is logging enabled?

    Try running ULS Viewer against the real-time log and see if there are any exceptions that come up as you run the command



    • Edited by Jason Warren Thursday, December 5, 2013 7:01 PM typo
    Thursday, December 5, 2013 7:01 PM
  • I have had this happen a couple of times due to the following reasons:

    - Failed upgrade or farm stuck in upgrading status. Had to re-run psconfig

    - path was over 255 characters to stsadm. created a system variable named spt and gave it the path to the 12 hive.

    - did not run command shell as admin

    Let us know what happens :) 

    • Marked as answer by R0n Burgundi Monday, November 2, 2015 10:04 PM
    Thursday, December 5, 2013 7:06 PM