locked
net use is not a recognized command RRS feed

  • Question

  • Hi,

    I've a windows 7 x64 and since two days ago when I run a network script I get the followin error:

    net use is not a regonized command and the same with the xcopy command.

    The laptop is new and I'm installing software at this moment that's why I suppose when installing any of the software it changed anything of the environment variables or something so.

    Can anybody help me?

    Thanks in advance.

    Regards.

    Wednesday, September 12, 2012 2:35 PM

Answers

  • Hi,

    I've a windows 7 x64 and since two days ago when I run a network script I get the followin error:

    net use is not a regonized command and the same with the xcopy command.

    The laptop is new and I'm installing software at this moment that's why I suppose when installing any of the software it changed anything of the environment variables or something so.

    Can anybody help me?

    Thanks in advance.

    Regards.


    I agree with you, it sounds as though the Path statement is missing or parts of it are missing. Go to Control Panel > All Control Panel Items > System > Advanced system settings > Advanced Tab > Environment Variables at the bottom. Scroll down to Path, click Edit and check it/change it.

    The Path statement needs to contain at least %SystemRoot%\System32;%SystemRoot%;%SystemRoot%\System32\Wbem

    • Marked as answer by droig Thursday, September 13, 2012 6:54 AM
    Wednesday, September 12, 2012 6:19 PM

All replies

  • Hi,

    I've a windows 7 x64 and since two days ago when I run a network script I get the followin error:

    net use is not a regonized command and the same with the xcopy command.

    The laptop is new and I'm installing software at this moment that's why I suppose when installing any of the software it changed anything of the environment variables or something so.

    Can anybody help me?

    Thanks in advance.

    Regards.


    I agree with you, it sounds as though the Path statement is missing or parts of it are missing. Go to Control Panel > All Control Panel Items > System > Advanced system settings > Advanced Tab > Environment Variables at the bottom. Scroll down to Path, click Edit and check it/change it.

    The Path statement needs to contain at least %SystemRoot%\System32;%SystemRoot%;%SystemRoot%\System32\Wbem

    • Marked as answer by droig Thursday, September 13, 2012 6:54 AM
    Wednesday, September 12, 2012 6:19 PM
  • This is the problem. I added this line to the path and it works fine again.

    What I don't understand is that I've compared my laptop with another one (both are new and of the same model) and the another laptop works fine also but the path doesn't contain this line.

    Thanks.

    Thursday, September 13, 2012 6:54 AM