none
I am unable to see my master page in master page gallery

    Question

  • I have created a sharepoint hosted app in visual studio 2013. I have uploaded my master page, in masterpage module(created by me). My master page is applicable only for app page, but not to the entire site. I am unable to see my master page in master page gallery in sharepoint online
    Tuesday, March 8, 2016 6:01 AM

All replies

  • Make sure that your master page is published and not in draft mode.

    Site Settings >Design Manager >Edit Master Pages 


    Cheers,

    Visual Studio Developer Tools Download

    Tuesday, March 8, 2016 1:20 PM
  • Master page which i created in app(Visual Studio) is not visible in master page gallery in site
    Tuesday, March 8, 2016 1:30 PM
  • HI Sai Mounika,

    Is publishing feature enabled on that site? Please make sure that it is enabled and update us.

    Thanks.


    Thanks

    Wednesday, March 9, 2016 9:29 AM
  • Hie don'zz, yes publishing feature is enabled in that site. Where I strucked is the master page is limited to app itself, its not visible in site's master page gallery. Is this correct process or some other way suggestable?
    Wednesday, March 9, 2016 9:34 AM
  • Hi Mounika,

    are you able to see Master page thru designer?


    Thanks

    Wednesday, March 9, 2016 9:38 AM
  • Its not visble thru designer Don'zz. When I deploy my app whatever master page I have created in app(Visual Studio) is applicable for only that page, when I navigate to site settings or some other, my master page is not applied.

    Wednesday, March 9, 2016 9:42 AM
  • HI Mounika,

    Please visit the below website once.

    http://spr.com/deploying-master-pages-sharepoint-2013-online-host-web-autohosted-app-office-365/


    Thanks

    Wednesday, March 9, 2016 10:35 AM
  • I have gone through that website already, its done by using Auto-hosted app. I am facing problem with Sharpoint-hosted apps.
    Wednesday, March 9, 2016 10:37 AM
  • Check the Module element.xml file: Module Name, File Path, File Url

    Thanks

    Wednesday, March 9, 2016 10:40 AM