locked
Browsing Excel sheet in after closing the sheet in team site HTTP 400 Bad Request RRS feed

  • Question

  • Hi ,

    I am trying to open ms document  and open Excel sheet in sharepoint site .  its open sucessfully when i  closed  the  excel sheet  or ms document  its closed but in sharepoint site  one error has come  error message  "HTTP 400 Bad Request". and one   more thing  user is getting this issue in only  one site in other site he is not facing such type of issue .

    this error has come only  when user close the document and  excel sheet .

    I assume that it can be browser setting but user is able to browse the site  so  i think its not browser issue .

    Please help

    Thanks

    Jandel Singh

     

     

     

     

    • Moved by Mike Walsh FIN Wednesday, February 16, 2011 3:17 PM Not a BI q (From:SharePoint - Business Intelligence (pre-SharePoint 2010))
    Wednesday, February 16, 2011 10:31 AM

Answers

  • Hi Jandel,

     

    The possible cause of this problem may be the IE adds values to the Accepted Documents key in the registry. This registry key is passed to the web server on the other end when a connection is made, and this value is larger so it gets split into two packets. The device on the other end is not handling a multi packet request, so it sends back the generic error message in that case which is “Error 400 – Bad Request”.

     

    To solve this problem, we can manually restore the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Accepted Documents

    1.       Click Start -> Run, type: REGEDIT in the Run box and then press Enter.

    2.       Navigate to above registry key and then export the “Accepted Documents” key to backup.

    3.       Right click on the “Accepted Documents” -> Delete.

    4.       Export the registry key from another working machine and the export above registry key from that good workstation.

    5.       Copy/import the exported the registry key to the current problematic machine.

    6.       Restart the system.

     

    Also make sure you have install this Service Pack for your SharePoint Server: http://support.microsoft.com/kb/841876. It seems that this problem may occur if you do not install this.

     

    Thanks & Regards,

    Peng Lei

    • Marked as answer by David HM Wednesday, February 23, 2011 5:50 AM
    Thursday, February 17, 2011 1:45 AM