locked
Internet Printing Protocol / CUPS selector RRS feed

  • Question

  • Hi,

    While installing printers I noticed that there is STILL no option to connect CUPS/ipp printer. After "scanning TCP port" the wizard gives up and asks to choose the correct one. It lists some really exotic printservers, but no ipp (port 631).

    "Browsing the network" shows only smb printers, and so, I was forced to enter manually http://[ip-address]:631/printers/[printer-name]

    I don't know if this is the right forum, I can't see 'suggestions' forum.

    Tuesday, August 18, 2009 12:32 PM

Answers

  • Please follow the steps below to install the printer.

    1. Click Start, click Control Panel and double click Devices and Printers.
    2. Click Add a Printer.
    3. Select "Add a local printer".
    4. Select "Create a new port". Choose "Local Port" as the type of the port.

    5. In the box "Enter a port name", type the address as the following format.

    http://[ip-address]:631/printers/[printer-name]

    Then click Next.

    6. Choose the correct driver in the driver list. If no available driver, click the button Windows Update, wait for the process finishes and then look for the driver again.
    7. Finish the installation.

    If the printers cannot be installed, or it does not work after installing, please let us know the model of the printer.


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Monday, August 24, 2009 6:04 AM
    Monday, August 24, 2009 4:39 AM

All replies

  • Please follow the steps below to install the printer.

    1. Click Start, click Control Panel and double click Devices and Printers.
    2. Click Add a Printer.
    3. Select "Add a local printer".
    4. Select "Create a new port". Choose "Local Port" as the type of the port.

    5. In the box "Enter a port name", type the address as the following format.

    http://[ip-address]:631/printers/[printer-name]

    Then click Next.

    6. Choose the correct driver in the driver list. If no available driver, click the button Windows Update, wait for the process finishes and then look for the driver again.
    7. Finish the installation.

    If the printers cannot be installed, or it does not work after installing, please let us know the model of the printer.


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Monday, August 24, 2009 6:04 AM
    Monday, August 24, 2009 4:39 AM
  • Is this working for anyone?  When I try to enter the Port Name, I get an "Invalid Port Name" message.  I've tried the suggested format and several optional ones as well.  I've disabled the Windows firewall, but I still cannot get add an IPP printer in Windows 7.  Below is the format that I successfully used in Vista:

    ipp://[server IP or hostname]/ipp/[printer name]


    Wednesday, September 30, 2009 3:21 PM
  • I have exactly the same problem. And it seems to, that we are not the only one.

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/8ed249b5-c6be-4a8b-bc2f-c684fdf273f2
    http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/f5e69f33-29ff-4c86-a7ed-3b066f0b642d

    Arthur Xie's solution doesn't work for me.
    I wastet x houres and cannot print anything with my working machine, that's very frustrating.

    All the other pc can print without any problem...
    Monday, October 12, 2009 9:42 PM
  • Arthur, your suggestion does not work. The dialog responds that "'http://xxx.yyy.org:631; is an invalid port name." Further, none of the above suggestions work. Can someone help?  This worked fine under XP (but never got it working on Vista).
    Tuesday, November 3, 2009 11:43 PM
  • It worked without problens on Vista. The problem apears with Win7... :-(
    Is a solution know meantime?
    Thursday, November 12, 2009 11:33 PM
  • Install "Support for internet printing" in Server components
    • Proposed as answer by rent-it.net.ua Wednesday, December 2, 2009 11:49 AM
    Wednesday, December 2, 2009 11:44 AM
  • Same problem in a Windows 7 Starter, no problem with pc's running XP Prof. or Vista Home printing to a CUPS server 1.3.9. According to this link the solution is enable the Internet Printing Client:

    http://support.microsoft.com/kb/969708/en-us/

    But when I try to follow the procedure, I can no see the Internet Printer Client under Print Services. The previous link applies to all versions of Windows 7.

    Any news about this issue?
    Monday, January 18, 2010 8:30 PM
  • Same problem in a Windows 7 Starter, no problem with pc's running XP Prof. or Vista Home printing to a CUPS server 1.3.9. According to this link the solution is enable the Internet Printing Client:

    http://support.microsoft.com/kb/969708/en-us/

    But when I try to follow the procedure, I can no see the Internet Printer Client under Print Services. The previous link applies to all versions of Windows 7.

    Any news about this issue?
    Exactly the same problem - no Internet Printer Client under Print services only "Fax and Scan"
    Wednesday, January 27, 2010 4:29 PM
  • Same problem in a Windows 7 Starter, no problem with pc's running XP Prof. or Vista Home printing to a CUPS server 1.3.9. According to this link the solution is enable the Internet Printing Client:

    http://support.microsoft.com/kb/969708/en-us/

    But when I try to follow the procedure, I can no see the Internet Printer Client under Print Services. The previous link applies to all versions of Windows 7.

    Any news about this issue?
    I've got an answer on another thread - it does appear that IPC isn't available at all on Windows 7 Starter. I awaiting clarification as the answer said they would remove the references to Windows 7 Starter from the above article - rather than state it wasn't in Windows & Starter. (if that makes sense!)
    Friday, January 29, 2010 12:05 PM
  • Arthur -

    I'm trying to get my HP Laserjet 1020 working over tcp/ip with Windows 7 with no luck.  Printer is set up for Raw printing on CUPs.  I can successfully print to the printer from Windows XP using http printing with address http://pjz-server:631/printers/Raw.  When I try the same on my windows 7 netbook it cannot connect to the printer and the test page fails.  I used the steps you listed and selected the windows 7 32bit driver downloaded directly from HP.  Any ideas?

    Wednesday, April 21, 2010 3:27 AM
  • Please follow the steps below to install the printer.

    1. Click Start, click Control Panel and double click Devices and Printers.
    2. Click Add a Printer.
    3. Select "Add a local printer".
    4. Select "Create a new port". Choose "Local Port" as the type of the port.

    5. In the box "Enter a port name", type the address as the following format.

    http://[ip-address]:631/printers/[printer-name]

    Then click Next.

    6. Choose the correct driver in the driver list. If no available driver, click the button Windows Update, wait for the process finishes and then look for the driver again.
    7. Finish the installation.

    If the printers cannot be installed, or it does not work after installing, please let us know the model of the printer.


    Arthur Xie - MSFT


    I do hope that a moderator looks at this as I see Arthur has not been here in a while and he has been busy elsewhere in these forums.

    This problem does still exist where users cannot add a printer that is set up using CUPS. I have followed these instructions which really seem that they should work but alas no. I am certain this is not a Driver issue as I am getting the:

    'http://xxx.xxx.xxx.xxx:631/printers/name' is an invalid port name

    I even opened the URL in IE and copied and pasted it in to the "Enter Port Name" config line. I built a new PC from scratch ... same issue.

    I am using Windows 7 Professional so I do not have the starter addition issue.

    I have started and stopped the printer spooler service. I have gone in and unchecked the Internet Printing Service with reboots between steps ... habit ;)

    No Firewall

    I have worked on my Google PHD researching this and have come to the conclusion that there is most definitely an issue with Windows 7 and IPP printing. Such a basic protocol should not have been overlooked as I have read that Microsoft and Novell(Suse) are buddies now and Novells iPrint is IPP.

    Sorry about the rant any help would be appreciated, perhpas I missed something.

    Wednesday, May 26, 2010 7:20 PM
  • N-Bid,

     

    I concur; it appears that IPP is completely broken in Windows 7.

    At any rate, my experience is the same as others:

    • Internet Printing Client is enabled under Windows Features -> Print and Document Services (this with Windows 7 Enterprise; it appears that some other Windows 7 flavors can't even get this far)
    • Arthur's instructions fail with "http://10.0.0.3:631/printers/hp_color_LaserJet_2550_series is an invalid port name"
    • This using a port name  that works fine in XP
    Sunday, May 30, 2010 6:02 PM
  • I had the same issue, after playing around for a while this worked:

    Add a Network Printer

    Shared printer by name: http://xxxxxxx:631/printers/[printer name]

    and install your driver

     

    • Proposed as answer by Chemophobic Sunday, October 16, 2011 3:22 PM
    Friday, July 2, 2010 3:54 AM
  • One of my colleges showed me how its done:

     

    1. Install the printer as a local printer 1st.

           Start --> Devices and Printers --> add Printer --> Add a Local Printer --> Use Existing Port --> Remember to do a windows update here if the drivers of the printer you want to install is not in the list. I had to do the update a few times before the driver appeared. Select the printer driver --> Follow the prompts You dont have to share the printer or anything....

    Remember to name the printer test or something

     

    2. Install the network Printer

           Start --> Devices and Printers --> add Printer --> Add a network, wireless o Bluetooth printer --> THe printer I want isnt listed --> enter  'http://xxxxxxx:631/printers/[printer name]' without quotes into the Select a shared Printer by name field and click next

    You will be prompted to select the printer driver here. Because you have already done a windows update and installed the printer locally in step 1, the driver should be listed here. If not repeat step1

    select the printer driver and click next. You will be prompted to enter a name for the printer and to print a test page on the following screens.

     

    Let me know if you run into any issues!

     

    • Proposed as answer by wasare Monday, August 16, 2010 4:35 PM
    Thursday, July 15, 2010 5:02 AM
  • Please follow the steps below to install the printer.

    1. Click Start, click Control Panel and double click Devices and Printers.
    2. Click Add a Printer.
    3. Select "Add a local printer".
    4. Select "Create a new port". Choose "Local Port" as the type of the port.

    5. In the box "Enter a port name", type the address as the following format.

    http://[ip-address]:631/printers/[printer-name ]

    Then click Next.

    6. Choose the correct driver in the driver list. If no available driver, click the button Windows Update, wait for the process finishes and then look for the driver again.
    7. Finish the installation.

    If the printers cannot be installed, or it does not work after installing, please let us know the model of the printer.


    Arthur Xie - MSFT


    Hi. Dredging up an old thread here.

    The above solution does not work.

    The solution on the following knowledge base article does not work:

    http://support.microsoft.com/kb/969708/en-us (installed the hotfix and it did not work)

    I followed this thread, as well as these trying various solutions and no joy:

    http://social.technet.microsoft.com/Forums/en-GB/w7itproui/thread/f5e69f33-29ff-4c86-a7ed-3b066f0b642d

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/8ed249b5-c6be-4a8b-bc2f-c684fdf273f2

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/a965d71f-e0b0-4c32-a163-de8c6a81f722

    The setup involves several Windows XP machines that can print to CUPS (ubuntu machine) without problems, yet the lone Windows 7 Starter edition box can not.

    Is there any way I can get this to work besides the solutions I have already tried?

    • Proposed as answer by DamPayne Wednesday, September 1, 2010 12:24 PM
    • Unproposed as answer by DamPayne Sunday, March 27, 2011 10:06 PM
    Wednesday, August 18, 2010 10:20 AM
  • 1. Ensure Internet Printing Client is activated first. Do this by going into "Turn Windows Features On/Off" in "Programs and Features" Control Panel item. The option is located under "Print and Document Services".

    2. Install required printer driver.  (Select another printer then select "Print Server Properties" in Task Bar - Note only appears after you select a printer that is already installed.) 

    3. Start --> Devices and Printers --> add Printer --> Add a network, wireless...Bluetooth printer --> The printer I want isn't listed --> enter  'http://xxxxxxx:631' (x being Printer IP address) without quotes into the Select a shared Printer by name field and click next

    You will be prompted to select the printer driver here. Because you have already installed the printer driver locally in step 1, the driver should be listed here. If not, do above step first.

    then select the printer driver and click next.

    Assumptions:

    1. The default protocol for IPP is 631 - however this can be changed on some printers.

    2. :631 IP port will need to be either unblocked or port forward setup if coming from external network (or other port if 631 is not used).

    3. You are attempting to setup connection direct to the printer via its internal NIC. If you are using an IIS Server to share the IPP functions then you would use the format http://[ip-address]:631/printers/[printer-name as you could have multiple printers shared this way and different names are required. If you are talking direct to a printer however keep it as basic http://{ip-address}:631 the printer will then be named by Windows as whatever the Host Name is configured at the printer, so be sure to change this to something relevent. (this is usually done by web access direct to the printer interface).

    Hope this helps.

     

    • Proposed as answer by DamPayne Sunday, March 27, 2011 10:05 PM
    • Edited by DamPayne Sunday, March 27, 2011 11:34 PM clarity
    Wednesday, September 1, 2010 12:49 PM
  • Please follow the steps below to install the printer.

    1. Click Start, click Control Panel and double click Devices and Printers.
    2. Click Add a Printer.
    3. Select "Add a local printer".
    4. Select "Create a new port". Choose "Local Port" as the type of the port.

    5. In the box "Enter a port name", type the address as the following format.

    http://[ip-address]:631/printers/[printer-name ]

    Then click Next.

    6. Choose the correct driver in the driver list. If no available driver, click the button Windows Update, wait for the process finishes and then look for the driver again.
    7. Finish the installation.

    If the printers cannot be installed, or it does not work after installing, please let us know the model of the printer.


    Arthur Xie - MSFT


    Hi. Dredging up an old thread here.

    The above solution does not work.

    The solution on the following knowledge base article does not work:

    http://support.microsoft.com/kb/969708/en-us (installed the hotfix and it did not work)

    I followed this thread, as well as these trying various solutions and no joy:

    http://social.technet.microsoft.com/Forums/en-GB/w7itproui/thread/f5e69f33-29ff-4c86-a7ed-3b066f0b642d

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/8ed249b5-c6be-4a8b-bc2f-c684fdf273f2

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/a965d71f-e0b0-4c32-a163-de8c6a81f722

    The setup involves several Windows XP machines that can print to CUPS (ubuntu machine) without problems, yet the lone Windows 7 Starter edition box can not.

    Is there any way I can get this to work besides the solutions I have already tried?

    Windows 7 Starter can't use IPP at all

    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/233bb347-43ad-4cf5-82a7-f7d503fe56ae

    In its case its not a bug but a feature.

     

     

    Saturday, September 18, 2010 4:29 PM
  • Is there any update on this issue?

    I've been bashing my head against a wall for days now trying to get this to work on Server 2008.

    It took less than 2 minutes on an XP client to install, connect and print a test page.

    I'm getting the same errors as everyone above - when trying to add a network printer (or standard TCP/IP port) it doesn't detect and when I push the address 'http://192.xxx.xxx.xxx:631/printers/name' nothing will print.

    Tring to install a new local port it won't continue saying 'http://192.xxx.xxx.xxx:631/printers/name' is an invalid port name.

    I've installed the Internet Printing Client Feature and restarted the spool service (even restarted the server) and tried it all again.

    On various linux boxes, CUPS on each picks up the printer and can print a test page fine.

    I can browse to the CUPS management pages on Server 2008 and print test pages from there.

    The only other thing I can find mentioned anywhere is at:

    http://support.microsoft.com/kb/982643/en-us

    and when trying to get it results in:

    "Hotfix Request
    The system is currently unavailable. Please try back later, or contact support if you want immediate assistance.http://support.microsoft.com/contactus/?ws=support"

    and has been doing so since I started this adventure 2 days ago.

    Why is it so hard do do something that used to work seamlessly???
    Thursday, September 30, 2010 4:19 AM
  • It's now several weeks later and I haven't got any further (after installing the hotfix - made no difference whatsoever).

    Anyone else?

    Friday, October 22, 2010 5:05 AM
  • One of my colleges showed me how its done:

     

    1. Install the printer as a local printer 1st.

           Start --> Devices and Printers --> add Printer --> Add a Local Printer --> Use Existing Port --> Remember to do a windows update here if the drivers of the printer you want to install is not in the list. I had to do the update a few times before the driver appeared. Select the printer driver --> Follow the prompts You dont have to share the printer or anything....

    Remember to name the printer test or something

     

    2. Install the network Printer

           Start --> Devices and Printers --> add Printer --> Add a network, wireless o Bluetooth printer --> THe printer I want isnt listed --> enter  'http://xxxxxxx:631/printers/[printer name]' without quotes into the Select a shared Printer by name field and click next

    You will be prompted to select the printer driver here. Because you have already done a windows update and installed the printer locally in step 1, the driver should be listed here. If not repeat step1

    select the printer driver and click next. You will be prompted to enter a name for the printer and to print a test page on the following screens.

     

    Let me know if you run into any issues!

     

    Thanks Botzer!  The first method did not offer much success, but this solution works perfectly.  XP was so much easier!  While I am happy there is a way to access IPP in Windows 7 Home Premium x86, it pains me to think that M$ still has not figured out how to play well with others.  It isn't always an option to install a printer locally first, and while using a disk would also work, this isn't always an option either.  IPP is an age-old protocol.  Perhaps someday M$ will realize they are not the only one to make rules for computing.  There is a big wondrous world out there.  Leave your own backyard once in a while Micro$oft and discover what the rest of us are doing!
    Friday, October 29, 2010 10:59 PM
  • IPP Printing was consciously disabled by Microsoft in Windows 7 Starter.  This is odd because netbooks (where Starter edition appears) are always trying to print to public printers.

     

    Leave feedback to Microsoft here if you want to see it get added back in the service pack.  The more responses they see, the more likely they will do it.

    http://mymfe.microsoft.com/Windows%207/Feedback.aspx?formID=195

    • Proposed as answer by LongJohn Monday, November 8, 2010 10:00 PM
    Monday, November 8, 2010 10:00 PM
  • 1. Install required printer driver.  (Select another printer then select "Print Server Properties" in Task Bar - Note only appears after you select a printer that is already installed.) 

    2. Start --> Devices and Printers --> add Printer --> Add a network, wireless...Bluetooth printer --> The printer I want isn't listed --> enter  'http://xxxxxxx:631' without quotes into the Select a shared Printer by name field and click next

    You will be prompted to select the printer driver here. Because you have already installed the printer driver locally in step 1, the driver should be listed here. If not, do above step first.

    then select the printer driver and click next.

    Assumptions:

    1. The default protocol for IPP is 631 - however this can be changed on some printers.

    2. :631 IP port will need to be either unblocked or port forward setup if coming from external network (or other port if 631 is not used).

    3. You are attempting to setup connection direct to the printer via its internal NIC. If you are using an IIS Server to share the IPP functions then you would use the format http://[ip-address]:631/printers/[printer-name as you could have multiple printers shared this way and different names are required. If you are talking direct to a printer however keep it as basic http://{ip-address}:631 the printer will then be named by Windows as whatever the Host Name is configured at the printer, so be sure to change this to something relevent. (this is usually done by web access direct to the printer interface).

    Hope this helps.

     

    Worked for me with a small print server I run (modded NSLU2 (network USB server) with CUPS installed) althought in "printer was not listed" i needed to enter full path ie.  http://[servername]:631/printers/[printer-name]

     

    Windows 7 Utilmate 

    Sunday, December 5, 2010 8:19 PM
  • I had the same issue, after playing around for a while this worked:

    Add a Network Printer

    Shared printer by name: http://xxxxxxx:631/printers/[printer name]

    and install your driver

     

    This worked perfectly for me. To get the correct drivers I had to connect it to my USB port first, then going back to my initial setup I could install it this way. For some reason it wouldn't work by modifying an existing printer to use an internet port. Adding a network printer worked like a charm though.
    Sunday, October 16, 2011 3:24 PM
  • One of my colleges showed me how its done:

     

    1. Install the printer as a local printer 1st.

           Start --> Devices and Printers --> add Printer --> Add a Local Printer --> Use Existing Port --> Remember to do a windows update here if the drivers of the printer you want to install is not in the list. I had to do the update a few times before the driver appeared. Select the printer driver --> Follow the prompts You dont have to share the printer or anything....

    Remember to name the printer test or something

     

    2. Install the network Printer

           Start --> Devices and Printers --> add Printer --> Add a network, wireless o Bluetooth printer --> THe printer I want isnt listed --> enter  'http://xxxxxxx:631/printers/[printer name]' without quotes into the Select a shared Printer by name field and click next

    You will be prompted to select the printer driver here. Because you have already done a windows update and installed the printer locally in step 1, the driver should be listed here. If not repeat step1

    select the printer driver and click next. You will be prompted to enter a name for the printer and to print a test page on the following screens.

     

    Let me know if you run into any issues!

     

    This got me closer than any of the other strategies but now when any print jobs are sent the light on my printer flashes for a moment and displays "Wasting Data", then after a warmup if it was sleeping it just goes to "Ready" status.  My printer is a Samsung clp-510.  I have it hooked up to a cups server and have been able to print from ubuntu and Windows XP computers but not from this Win 7 pro machine.

    Correction, once I got to "Wasting Data", it was just a matter of selecting a better driver.  The Samsung universal driver was not working but the more model specific driver works for color printing at least.  I can live with this!

    • Edited by Hydely Tuesday, January 10, 2012 5:15 PM
    Monday, January 9, 2012 6:45 PM
  • I know that this may not be directly related to this topic: but if Win7 fails to connect to the CUPS server or network printer, this could be a result of a proxy server being configured in IE. I was unable to print to my network Printer (CUPS), and after I tried to reinstall the printer Win7 did not even detect it. I eventually found out that the problems started after I configured a proxy server in IE. Once I removed the setting, the printer was picked up without any problem. So, my suggestion would be to set IE to directly connect to the internet.<o:p></o:p>


    Monday, March 5, 2012 5:26 PM
  • I had success using the instructions on this guys page.  The Internet Printing Protocol Client must be enabled in system features.

    To summarize:

    1. Open the 'Devices and Printers' screen.

    2. Select 'Add a printer'

    3. Select 'Add a network, wireless or Bluetooth printer'

    4. Cancel the search and select 'The printer that I want isn't listed' 

    5. In the 'Select a shared printer by name' enter the IPP server name.  http://ipaddress:631/printers/printername

    6. Select the driver.

    http://jacksonengineering.net/proj_cups.php

    Tuesday, April 10, 2012 4:40 AM
  • I was having this same problem. What I did was I added the Internet Printing Client feature. After that I restarted the print spooler service.

    Once I got that installed I added a new printer. --> Add a network printer --> The printer that I wanted isn't listed --> select a shared printer by name --> http://[ip address]:[port]/printer.

    Wednesday, July 18, 2012 10:14 PM
  • how did you know wich port is was and how must i type this printer name then hp photosmart 7150
    Saturday, September 22, 2012 6:58 PM
  • I was having this same problem. What I did was I added the Internet Printing Client feature. After that I restarted the print spooler service.

    Once I got that installed I added a new printer. --> Add a network printer --> The printer that I wanted isn't listed --> select a shared printer by name --> http://[ip address]:[port]/printer.

    how did you know wich port is was and how must i type this printer name then hp photosmart 7150
    Saturday, September 22, 2012 6:58 PM
  • Thank you - this worked fine after countless "cannot find printer" boxes. *This should be selected as the correct answer* (and not the one from Arthur Xie).

    I just had one problem on the way: merely adding Internet Printing Client (I had it disabled) was not enough - I needed to restart the Print Spooler service.

    Wednesday, November 14, 2012 12:31 PM
  • I get the "invalid port name" error as well - still can't add the printer

    Monday, September 16, 2013 5:22 PM