none
Error 2147942464 BMR with SS of HYPER-V Host fails RRS feed

  • Question

  • I have a data protection group to create a Bare Metal Restore with System State backup of our HYPER-V host server.  (The host server itself with everything on it)  The DPM 2010 software is running on one server with 2008R2.  The HYPER-V Server is a separate box running 2008R2 Enterprise. This is the error mesage I receive on the protected (HYOER-V) server event logs:

    The backup operation that started at '‎2010‎-‎09‎-‎25T07:57:08.740488500Z' has failed with following error code '2147942464' (The specified network name is no longer available.). Please review the event details for a solution, and then rerun the backup operation once the issue is resolved.

    I also have two other data protection groups backing up that same server to capture the VM's and C:\ and D:\ so the network name failure seems incorrect to me.

    The DPM server successfully performs BMR + SS backups of our other servers: a database servers running SQL on 2008R2, application servers running 2008R2 as well as exchange and terminal services servers running 2008 or 2003.

    Any insights or advice would be greatly appreciated.

    Thanks in advance.

     

     

     

    • Moved by T Franke Friday, October 1, 2010 8:06 PM Redirect (From:DPM Hyper-V and CSV Clusters)
    Thursday, September 30, 2010 4:31 PM

Answers

All replies

  • Here are a couple of things that you need to check:

    1) Does a local system state backup when ran succeed or fail?
    2) If you open an elevated command prompt and execute "VSSADMIN List Writer" are any in a failed state?
    3) Check the application and system event logs, are there any errors there from source "Backup", "VSS", "Volsnap"? If so, what are they?
    Cheers, Tyler F [MSFT] - This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, October 1, 2010 8:38 PM
  • Tyler,

    Thank you for responding.

    A 'System State Only' backup from the HYPER-V host to the DPM server did succeed without any errors.

    The output from 'VSSADMIN List Writers' showed all writers to be 'stable' and 'no errors'.

    I examined the application and system event logs.  There were no errors for VSS or VOLSNAP only informational messages.  The errors for BACKUP occurred with each of my attempts to backup HYPER-V host to DPM and were the same as my original post.

    Can you give me more advice?

     

     

    Sunday, October 3, 2010 8:04 PM
  • Try the BMR restore and if it fails, then go to Program Files\Microsoft DPM (or Data Protection Manager)\DPM\Temp and find the *.errlog file with the most recent time date stamp on it.  Do this on both the DPM server as well as the Hyper-V machine.  Open these files in Excel and then filter on the "Level" and look for any Warning or Fatal events that happened very recently.  If you find any, can you post that information?  Be sure to include which machine it came from and if needed, you can replace your machine names with generic names.  Thanks!


    Thanks, Chris Bu - MSFT This posting is provided "AS IS" with no warranties, and confers no rights
    • Proposed as answer by ShaneB. _ Tuesday, December 20, 2011 3:19 PM
    Monday, October 4, 2010 7:24 PM
    Moderator
  • Since the BMR is at an Inconsistent Replica state, a restore is not allowed.  The BMR selection does not even exist in the Recovery list.   When I tried to correct the inconsistent replica I received the same error message as listed in my original post.

    I checked the errlogs after the latest consistency check. There was one level=FATAL item with information:

    <Status xmlns="http://schemas.microsoft.com/2003/dls/StatusMessages.xsd" StatusCode="-2137453902" Reason="Error" CommandID="RAWriteDatasetFixup" CommandInstanceID="ecb3fe30-6aec-4efb-a113-e22bb774307c" GuidWorkItem="fe5aeb8c-880c-4691-9a39-ee72e886b664" TETaskInstanceID="037e9011-a84d-4501-9a5e-636a435323a7"><ErrorInfo xmlns="http://schemas.microsoft.com/2003/dls/GenericAgentStatus.xsd" ErrorCode="30061" DetailedCode="-2137453902" DetailedSource="2"><Parameter Name="AgentTargetServer" Value="DPMServer.xxxxx.local"/></ErrorInfo><RAStatus><RAWriteDatasetFixup xmlns="http://schemas.microsoft.com/2003/dls/ArchiveAgent/StatusMessages.xsd"><LWVStatus BytesTransferred="1040" NumberOfFilesTransferred="9" NumberOfFilesFailed="0" DataCorruptionDetected="false"/><HWVStatus BytesTransferred="55526998" NumberOfFilesTransferred="9" NumberOfFilesFailed="0" DataCorruptionDetected="false"/><FixupStatus BytesTransferred="100620435456" NumberOfFilesTransferred="1" NumberOfFilesFailed="0" DataCorruptionDetected="false"/></RAWriteDatasetFixup></RAStatus></Status>

    What else should I try?

    Tuesday, October 5, 2010 10:18 PM
  • Hello,

    Are you still having this issue?


    Thanks,
    Shane

    Thursday, December 1, 2011 9:34 PM
  • Housekeeping - closing old post.  Open a new post if you still have a need.

    My DPM blog ystartsev.wordpress.com

    Thursday, January 31, 2013 6:50 AM
    Moderator