Com Surrogate RRS feed

  • Question

  • I keep on receiving an error message stating that 'COM Surrogate has stopped working'. I have no idea as to what has caused this and am baffled as to what I need to do to rectify it. This happens when I go into my computer. If any one can help It would be extremely grateful.

    Wednesday, August 22, 2007 11:56 AM


  • COM Surrogate (dllhost.exe) is an application that is often used by Windows Explorer to isolate itself from buggy codecs (if explorer would load the codecs in its own process, it would crash as it did in XP, so explorer spawns dllhost to actually process the thumbnails, etc. outside of its process space).

    Upgrading the codecs installed on the machine should fix the vast majority of the cases.

    Removing Data Execution Prevention for dllhost.exe is a very bad idea, it opens the machine to a potential security vulnerability (since now the system does not prevent code from residing in pages without the NX bit). So please do not turn off DEP. More information about DEP can be found here (http://support.microsoft.com/kb/875352, while the contents refer to Server 2003, most of it is unchanged for Vista/Server 2008)

    Alexander Sklar | Software Development Engineer - Windows Serviceability

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, February 10, 2009 10:52 AM

All replies

  • Hey Willian, I've got exact the same problem. Before, I had windows XP and I had alot of music videos and movies and stuff which I saved and transfered to my new computer with windows vista support. And everytime I open the map whit the old files I receive an error message where it says "COM Surrogate has stopped working" and that is a big problem. Do you got any answers now or do you still have the sama problem because I'm getting frustrated not to open my old files.
    • Proposed as answer by adriana buzzi Tuesday, January 20, 2009 2:36 AM
    Wednesday, August 29, 2007 7:02 PM
  • Hi,


    I have had no luck every time I go into my computer and look and certain files it comes up. Also if I use my portable hard drive and open it up using vista the same problem happens. I have emailed Microsoft and have had no reply as yet so I am still just at a loss. Yes my problems is with music and video files too. It is really irritating.

    Thursday, August 30, 2007 11:03 AM
  • I'm still not sure what the message "COM Surrogate has stopped working" even is.  Those of you that posted above say it's bad.  Is it, "Now I can't listen to Bohemian Rhapsody bad" or "My computer's about to crash" bad?  Can anyone shed some light on this?

    • Proposed as answer by cpaulhill1 Thursday, January 22, 2009 8:06 PM
    Sunday, September 9, 2007 6:11 AM
  • HI,


    All I can do to share some light on this problem is that whenever I go into certain files in 'my computer' a notice box pops up and displays a message informing me that the ' com surrogate is not working properly'. To which I am still baffled by as it only pops up with this box and nothing else. I do not think it will ruin your computer but I am not a PC know all. I would consult a technician if you are more concerned with the problem.


    Monday, September 10, 2007 8:37 PM
  • It's baffling and maddening. 

    When you Google it, some people will link it to either Nero or Roxio EasyCD Creator.

    However, I have done a fresh install with Windows Vista Home Premium and, after a week, the same thing's happening.

    I suspect that it has -- at least on my system -- something to do with Windows Mobile Device Center.  Put that's just a guess.
    Wednesday, September 12, 2007 1:04 AM
  • Also - see this thread:


    Wednesday, September 12, 2007 1:09 AM
  • This is a big, ongoing, unfixed problem on thousands of VisDuh PCs. I have tried bunches of fixes and tweaks in the last couple months, with no success. Removed URGE, tried all the updates and hotfixes and work arounds we can find, tried turning off Antivirus and Defender and everything else, safe mode, reinstalled Windows 4 times -- still the same stupid problems over and over and over and over, ad nauseum.

    I think it is somehow related to the ongoing problem with Windows VisDuh calculating how long it is going to take to rename/copy/move some file. The hotfix for that quickened the problem somewhat, but it still is slower than XP or ME or 2000 or even DOS 3.3, it seems.

    I wonder if this problem is related to Win Media (non)Player messing up all the time: playing mp3s and wma's and other files at variably slow speeds and with crackling noises?

    I hope MSFT finally comes up with a real solution to the problem(s) and SOON and gets it out everywhere.

    We feel like invoicing them for all the 100 or so lost hours of productivity on this mess.

    HELP! PLEASE! Somebody?

    Thanks for all the posts, I will keep searching and waiting and praying and muttering under my breath.

    Friday, September 14, 2007 7:49 AM
  • i installed nero 6.6 yesterday, since then i was receiving the "com surrogate error" i removed the program and so far no error messages, hope this helps. bye the way i am using vista home premium.


    Wednesday, September 19, 2007 12:31 AM
  • I'm having the same problem with the "com surrogate" error popping up.  It just started and I haven't had time to figure out what causes it...  I tried installing my nero program but it won't work with Vista (I had XP until the hard drive failed) so I uninstalled it but that was a couple of weeks ago and the "com surrogate" error showed up just a few days ago...  I would be nice if Microsoft could fix all the "bugs".    I'm not real happy with vista!


    Thursday, September 20, 2007 4:27 PM
  • Guys, if someone knows what the heck it is? I've got this message tonight (the one about com surrogate), and it freaked me out! I haven't installed any new software, I've had this PC for a while and never had anything like this before... So I don't know if it is some kind of malicious software from Internet (which it shouldn't be since I have Norton Internet Security and it's been working fine) or a glitch of Windows XP? HELP!!!

    Sunday, September 23, 2007 4:28 AM
  • Hello Guys,


    I am so hoping this will help, I have just installed vista ultimate a few weeks ago,

    and have closly monitored each and every software that I installed, I have tried several things to get rid of this bad dream, and found something that seems to work.

     This last attempt has worked for 3 days, without a problem, maybe you can try it.


    go to ur folder options, and under tools, folder options, and under the View tab, try this, check the first box, that says, Always show icons, never thunbnails, and also, uncheck display icon on thumbnails, and apply.. I will continue to try to find an answer if this does not seem to work for you, Please post and let me know.



    • Proposed as answer by Tarandash Wednesday, August 12, 2009 9:53 PM
    Sunday, September 23, 2007 5:11 PM
  • No, it is not malicious software -- virus, trojan, etc.  It's just a GIANT nuisance.
    Sunday, September 23, 2007 10:50 PM
  • Totally worked for me, got a feeling its in the video card and showtime, in nero.

    but soon as i did this, it never came back again, really sorry it didnt help ya



    Tuesday, September 25, 2007 1:01 AM
  • I get the same message every time my Thinkpad boots but other times as well.  It popped up every few seconds when I was trying to sync my iPod yesterday for the first time on this machine.  I'm not noticing any problems it causes - just that it's a supreme annoyance!!  Please send help Smile ......


    Tuesday, September 25, 2007 1:28 AM
  • The Com Surrogate problem is not just with Vista - I'm using XP and have had this curse for two months.


    Wednesday, September 26, 2007 2:45 PM
  • I just got this message too after re-installing my operating system. But after I re-installed my Registery Booster 2 that I had purchased and running a scan, it fixed it. I didn't have to do anything more. Before that I was very frustrated like all of you. Everything I was picking up pointed toward  the Vista OS and I have XP. I did notice that the error came up not when I installed the Windows Media 11 but after I did an update of my operating system online with Microsoft. I noticed while it was installing the updates, you have to see it quickly as it's showing the files downloading, that there was a file being installed to the Media Player 11. Registry Booster 2 is a purchase, not free, but I went through the Microsoft web site and got it half off. Don't know if the offer is still there. When you purchase it, it also gives you Systems Tweaker free.


    have a great day! im2bz2bcn


    Sunday, September 30, 2007 4:31 PM
  • I am also trying to figure out why the heck I'm getting these COM surrogate not working popups, and I am dismayed to see everyone having the same experience and Microsoft not doing anything to fix it.  I associate mine with URGE because it seems to happen when I'm trying to use the Windows Media play associated with Urge and it didn't begin to happen until I downloaded Urge.  If anyone from Microsoft is "listening", would you PLEASE give us a fix for this???  It's driving us all nuts.

    Sunday, October 14, 2007 10:26 PM
  • I am getting this message when I am in Outlook Express on XP o.s.  What in world is it?  How can I fix it?


    Saturday, October 27, 2007 12:25 AM
  • Removing Nero did not do anything on my system to alleviate the problem.
    Saturday, October 27, 2007 1:17 AM
  • This seems to work for me so far.  Thanks alot!!!


    Saturday, October 27, 2007 8:15 AM

    Hi Kiifer,


    I have encountered this COM Surrogate today for the first time after I got my Sony Laptop 3 months ago. I too have Nero downloaded from Mininova so it could be linked to this. But thanks to your recommendation the problem seems to have disappeared and no error message has appeared when accessing video files.

    Very relieved as I thought it was a malicious virus!!


    Great work, thanx.



    Sunday, November 11, 2007 2:31 AM
  • After using Nero's General Clean Tool......   I am no longer receiving the Com Surrogate message....   Thank goodness  


    Sunday, November 11, 2007 5:01 AM
  • The com surrogate shim is used for preview handlers, which generate both the preview and also the icons. If the piece of software generating the icons crashes because it can#'t read the file properly, it takes down the process. Because Vista initializes these extensions in a separate process, the shell survives and reload, and retries.

    Biggest offenders in my experience are Adobe Reader 8 and DirectShow filters on badly formatted avi (divx et al).

    Tough one to diagnose though.
    • Proposed as answer by J Schewe Sunday, March 29, 2009 12:41 AM
    Thursday, November 15, 2007 11:51 AM

    If you've been getting the error COM Surrogate has stopped working whenever you browse folders containing video or media files, here is the solution.

    This problem is caused because of codecs and other COM components installed by various softwares that aren't fully Vista-compatible, like some versions of DivX or Nero.


    There are a number of possible solutions to this problem, and the right solution depends greatly on what software is actually causing the problem. Some of the most well-known problem causing softwares are DivX and Nero, but there are others that cause the problem as well.

    Possible Solutions

    • If you are using DivX, you should be upgraded to the very latest version (6.5+)
    • If you are using Nero, you can try upgrading to the latest version (
    • If you’ve upgraded Nero and Divx and still have the problem, you can try renaming the file C:\Program Files\Common Files\Ahead\DSFilter\NeVideo.ax to NeVideo.ax.bak.  You may also need to rename NeVideoHD.ax to NeVideoHD.bak
      This will break Nero Showtime, however.

    You can disable Thumbnail previews, which should make the problem go away, but isn't the optimal solution.


    The older ffdshow codec pack has been known to cause some problems. The ffdshow tryouts codec pack seems to work better. Might want to try using this one:  http://ffdshow-tryout.sourceforge.net/


    If you'd like to uninstall Nero entirely, there is a utility that they provide to help with complete uninstall that helps a lot in instances where you have a bad installation of an older version. http://www.nero.com/nero7/eng/FAQs_Nero7_NeroVision.html


    Some users have recommended installing the Vista Codec Package in order to update all your codecs to the correct versions. I can't confirm that this works because I have not tried it myself. As always, be careful when installing unknown components and create a restore point.


    You can use the very useful MMCompView free utility from Nirsoft to disable any codecs on the system. This is very useful to help troubleshoot exactly which component is causing the problem.


    There's another possible solution below of turning off DEP for dllhost, which might not work for everybody. You may have to add divx+nero executables to the DEP ignore list.






    This fix that might solve the problem in a much easier way. Essentially, turning off Data Execution Prevention on dllhost (the COM surrogate) can fix this problem for some people. This solution is detailed below.

    Right click on Computer, and choose Properties

    Click on Advanced System Settings, and then under Advanced, click Settings

    Select the "Data Execution Protection" tab, and then click “Turn on DEP for all programs and services except those I select”

    Click on the Add button, and then browse to C:\Windows\System32\dllhost.exe as shown

    Click Open, and then OK.

    Here's what you should see…

    Now you can browse video folders without problems!


    This solved my problem 100%...


    This info was passed to me and I am passing it foward.



    Thursday, November 15, 2007 7:11 PM
  • I hope I am not alone in this but since trying this suggestion I have lost access to a couple of my programs. How do I get them back? The original error message has not come up since and at this point I would rather have access to the programs I use regularly and will just close the error box with the surrogate issue when it comes up. I hope someone can help since I would rather not have a four hundred dollar paperweight due to this problem that I have yet to see anyone from Microsoft reply about. 

    Sunday, November 18, 2007 4:15 PM
  • Hi Geno 2,

    For us to help you, we need to know which programs you lost access to.

    Let us know so we can help you.



    Sunday, November 18, 2007 11:06 PM
  • How much time ya got?  I lost access to my Money account, my internet for a while, my daughters downloaded games from Nick Jr arcade, and my system has become a turtle since the first time I got this as an error message. The computer manufacturer says I would need to send my laptop to Texas for a week if I want them to just look at this problem. 

    • Proposed as answer by lior.telit Tuesday, September 10, 2013 6:32 AM
    • Unproposed as answer by lior.telit Tuesday, September 10, 2013 6:33 AM
    Monday, November 19, 2007 10:21 PM
  • im reciving an error message stating that surrogate has stopped working. i have no idea as to what has caused this, and a want to know how to rectify it. if any can help be extremely grateful


    Wednesday, November 28, 2007 12:04 AM
  • i too have been having similar problems.com surrogate uses more than 67MB ram at a time.the cpu usage jumps 100%,other applications automatically end if com... (process) is stopped in task manager.it's high time microsoft did something about it.maybe xp was better afterall..please do inform if u find a solution to the problem or if u get to know that microsoft has an answer to it.thank u..
    Wednesday, November 28, 2007 6:09 PM
  • I don't know if it applies to the COM Surrogate problem, but DBarr describes my computer exactly. I get the stalling Media Player, constantly running hard drive, and snooze every time I attempt a file manager process, especially on network shares.


    It was a lame XT laptop with 728 MB RAM that I upgraded to Vista for testing. Even though it passed the Vista equipment test, I just assumed it was fighting inadequate RAM and weak video.

    Friday, November 30, 2007 12:35 AM

    Just my two cents on how I fixed my problem. After I installed Vista, I got the error after I installed Dvix Codec (Even the latest version.) Also, none of my thumbnails for photos would show.


    All I did was just uninstalled Dvix and installed Vista Codec Package and I haven't had a error since.

    Sunday, December 2, 2007 1:52 AM
  • My problem wasn't only restricted to COM Surrogate b ut also to Explorer stopped working.  I followed Richard_55 advice and so far so good - it seems to be working.  I wil  be monitoring situation and report back.  Thnx Richard_55.

    Monday, December 3, 2007 4:35 PM

    I went into folder options in pesonalization in control pannel and changed view options to allways show icons not thumbnails in view pane and it stopped occuring.
    Sunday, December 9, 2007 6:47 PM
  • As I have said,  I followed Richard_55 advice and installed said file as per link provided by him.  No problem since thein.

    Sunday, December 16, 2007 1:58 AM

    i read that its nero or divx  so u might need to update both or jus check this site


    Friday, December 21, 2007 10:18 PM
  • The first time I've seen this message was when I had connection problems with the internet.  It started with a virus(cookie) that corrupted the communication pathway that DiVIx updater was using.  Since then all media players (Nero, Windows Media, ITunes, Quick Time, Winamp (although it causes a media failure with winamp), Roxio, Movie Maker, DvD maker) that uses these com channels relies on the DLL file (surrogate).  And of course, when I need to list the file name that is causing the problem, I can't remember it.  I'll post it the next time I reboot the system.  But if you do get the message, open up your task manager and look under process; the file is there listed as Com Surrogate. 


    I believe, from the symptoms and the course of events on boot up, the Windows Defender is kicking all media communication calls through this "surrogate" to make sure no top secret information is sent.  I get this message more often when I'm not connected to the internet compared to when I am connected.  The media programs are trying to update themselves or send out secret world destructive information out to the rest of the community that will eat away at the very fiber of today's society and our reliance on technology to get our kicks off. 


    The alternative is that the file itself is corrupted and needs to be reset both in registry and at the physical location.  Or ... we could all stop using computers and media and whatnot and live our lives like neanderthals going around with clubs and beating on things (preferably the microsoft headquaters). 


    Just a thought though
    Saturday, December 29, 2007 10:01 PM
  • This seems to have worked for me (view as icon never thumbnail). At least I don't get those irritating COM Surrogate blah blah messages anymore. It's not an ideal solution, more of a work around, but I can live with that until I decide to install XP again. There are so many annoying glitches and bugs in Vista. I've only been using it a few weeks. I'm sure I'll find plenty more. What a joke!
    Monday, December 31, 2007 7:30 AM
  • 1: Occasionally the error pops up because you have Divx installed on your system, you can solve it through changing to Xvid or this error with Divx seems to be cleared up using the latest Divx update to codec version 6.5 fixes the issue, but it also seems to remove the thumbnails.


    2: Some versions of Nero have caused this error and it can be resolved in that case by removing their filters.
    The filter NeVideo.ax either needs to be renamed or removed, and it's found at C:\Program Files\Common Files\Ahead\DSFilter.

    This error has also been seen when the Explorer generates a preview for Video files.


    Hope this helps.



    Saturday, January 19, 2008 12:28 PM

    it worked for me... thanks man, but this is only a way around it not a solution... one of the reasons i got vista is for the folder thumbnails... but until microsoft fixes this... i will have to live with what i have and that sucks...
    Thursday, January 24, 2008 2:04 PM
  • I simply turned the silly thing off so it would stop pestering me 20 times a day.. Hopefully they will fix the problem eventually, but i am not going to hold my breath on it.
    Saturday, February 23, 2008 2:03 AM
  • anyone have a solution for the COM surrogate mesage I receive?  I use a lot of modified picture file type including RAW.


    Sunday, March 9, 2008 4:11 PM

    Ty going to control pannel / folder options / view / check box near the top in files and folders allways show icons never thumbnails.  I hope this works for you .  Good luck!

    Please post to other people Its just a quick fix which seems to be linked to nero etc. etc.

    Sunday, March 9, 2008 6:19 PM

    Ty going to control pannel / folder options / view / check box near the top in files and folders allways show icons never thumbnails.  I hope this works for you .  Good luck!
    Sunday, March 9, 2008 6:21 PM
  • Ty going to control pannel / folder options / view / check box near the top in files and folders allways show icons never thumbnails.  I hope this works for you .  Good luck!


    Sunday, March 9, 2008 6:22 PM
  • This worked out perfectly for me. No more problems with the "COM Surrogate" issue.

    Tuesday, March 11, 2008 5:04 PM
  • I just got a new computer and when I went to transfer over movie and I tried to play it I got the same message. BUT it's a SIMPLE FIX !! I noticed other programs I tried to play it with wouldn't work either so I went to free-codecs.com and downloades the Satsuki codecs Pack. This seemed to resolve the problem since the computer just could not read the files!!!!


    Sunday, March 30, 2008 4:22 AM
  • Don't Worry this turned out to be an easy fix. I got a new computer and had the exact same problem but I noticed no other program would open my movie either. So I went to free-codecs.com and downloades Satsuki codec pack and this allowed my computer to read these file. NO MORE MESSAGE !!!!


    Sunday, March 30, 2008 4:26 AM
  • I see a lot of discussion with this error coming up for Vista users and people using there PC's as a jukebox. We received the same error at work on a server running server 2003. This PC is very well secured so there should be no viruses or etc touching it and there is no music or anything of that sort.  In doing research we have not been able to find anything regarding this error, however, I wanted to share my experience with all of you to hopefully help in tracking this problem down.  Thanks.

    Tuesday, April 29, 2008 12:32 PM
  • In comparing our image server settings, the one receiving the Com Surrogate problem, with another image server on our network my boss made a change that seems to have corrected the problem.  He went in to Adminstrative Tools/Services and stopped the "Backup Exec Remote Agent for Windows Servers" service. He is thinking this has something to do with network load balancing.  The reason he thinks this is because when he logs on he always receives a services failed to start error. However when I log in a get a COM Surrogate error.  Sorry if this is confusing, it is confusing to us, however I wanted to throw everything out there.  Thanks

    Tuesday, April 29, 2008 12:53 PM
  • GET A MAC!!


    Monday, May 26, 2008 9:35 PM
  • I already had Xvid-1.1.3 installed. uninstalled and reinstall. And yes it occurred when explorer was generating a preview of video file. For some reason unknown the Xvid codec seems to have been corrupted in some way. Unistall and reinstall worked for me. Hope this helps someone else. If you don't have it it can be downloaded here http://www.xvid.org/Downloads.15.0.html
    Monday, June 16, 2008 1:33 AM
  • I was getting the "COM Surrogate"  message and I tried your adviser and so far so good, My computer is brand new, purchased a week ago. Thank you


    Monday, July 14, 2008 11:07 AM
  • that is not a solution!!! The fact still remains that you can't view a thumbnail of a media file without the COM surrogate error. Just ignoring it doesn't fix it.
    Tuesday, August 5, 2008 5:49 AM
  • Hey babny 002 dont have a go at me Its a quick fix solution that worked for me (thought I'd share!).

    Have a go at Viz-Doh! programmers perhaps its in built to conflict with nero or other media so you have to buy a microsoft product (maybee I'm just sinical)?.


    Regards Andrew
    Tuesday, August 5, 2008 1:02 PM
  • Wednesday, August 13, 2008 9:12 PM
    Wednesday, August 13, 2008 9:25 PM
  • Hi I got the solution to this problem which I was also facing as u all. Here is the solution:

    Essentially, turning off Data Execution Prevention on dllhost (the COM surrogate) can fix this problem for some people. This solution is detailed below.

    Right click on Computer, and choose Properties

    Click on Advanced System Settings, and then under Advanced, click Settings

    Select the "Data Execution Protection" tab, and then click â€œTurn on DEP for all programs and services except those I selectâ€?

    Click on the Add button, and then browse to C:\Windows\System32\dllhost.exe as shown

    Click Open, and then OK.

    Here's what you should see…

    Now you can browse video folders without problems!


    Raj Kumar Arora

    Thursday, August 14, 2008 9:35 PM
  • Hi there

    The 'Comm Surrogate' error was driving me mad, but this fix seems to have done the trick.

    Thank you...

    Monday, August 25, 2008 7:05 PM

    Hi guys the only way I found to fix the problem was to do a system restore back a couple of days
    Thursday, September 4, 2008 3:21 PM
  • You are correct, which I can back up with a simple test just seen on my own Vista machine.  Using both 7-zip and Windows' built in "Extract" for unzipping the VS2005ImageLibrary.zip (image icons for Visual Studio,) I get the crazy calculated time error, followed by either "Explorer has stopped functioning" or "COM Surrogate has failed..." errors.  I have gone into the zip file, and file by file am extracting...  The problem seems to be related between the number of files and/or data size, and whether or not a "thumbs.db" file is included in the folder which also contains the files being moved.
    Monday, September 8, 2008 1:37 AM
  • I don't know if this will help anyone but XP users might find the following of interest...


    I ran the msconfig utility and went through a tireless process of trying to figure out which process was causing my COM Surrogate error to pop up.  It turns out (for me anyway) that the service causing my problems was "SQL Server VSS Writer".  I am pretty sure that this is a Microsoft service used as part of Visual Studio but I could be wrong.


    Anyway I then ran services.msc, disabled the SQL Server VSS Writer service and rebooted.  Problem solved.  I now no longer have any problem with the COM Surrogate issue.


    I don't run Vista so I can't comment on whether this will work for everyone but for those that run XP it is worth a try if you have SQL Server VSS Writer installed on your system.

    Tuesday, September 9, 2008 10:37 AM
  • Hi this com surrogate is a pain in the arse ,my onboard Lan cannot find my bt home hub could problems be related, any ideas please

    Tuesday, September 9, 2008 9:33 PM
  • Hello ,everybody!
    I`ve got my laptop( Acer Aspire 5920G,1,83 intel core Duo processor and ram 3gb;Vista home premium ) since 3 months and like every normal user i wanted  to have different usefull programs like Nero,BS player....
    But you know that internet it`s like a big sea full with dangerous viruses,malicius software and other stupid things wich are making our live like users ,black!
    Sometimes i download a Trojans togheter with these programs ,or some of the Nero Software was completely loosing of time.Meantime these bad experiences i tryed few antivirus programs wich was rubish:1st-AVG free,(2 weeks using -1 trojan and two adware) 2nd-Avast -i still was having the 1 trojan and becouse he make an backdoor the trojans become 2 ....then my system tryed to protect it self.System recovery ...result- again with AVG -1 trojan and 2 adware....then i try Norton ..
    norton is good software ,but still i was having the trojan...(i found the infected file with Spyware Doctor) soo i start to search in system for the file wich is infected using the windows explorer (wich now is stoping working to me sometimes) and i find the file ,i delete it and the trojan disapear! I was glad,but not for long...the Norton stoped working,i and i was thinking that is a time to buy a secure antivirus program.(panda)
    I have a problem with COM surrogate,and i dont know what is causing this problem,every time i click on a movie folder it appears! I read some postings but i still dont know what to do,couse i dont want to do things worse in the system...
    I am affraid that since i had this update of the vista before 2 days (11.09.2008) i have new problems ,and new messages are appearing,even my windows explorer it`s stoping ! I am not shure that this is cousing all these problems,but i hope that i can find cure for my pc.Maybe preinstalling will help,but this is just an option wich i will do only if things goo worse...
    I am confused! The newest version of Panda- Global Security,it cost me 56,60 euro and it`s working prety well!
    My antivirus program is not finding any Trojans or Worms.Just some Adware and Spyware,wich are not soo dangerous ,but still can afect the PC. I hope some day ,some one will find something to completely stop all these viruses and jokes ,and hope Microsoft will help us to remove all these erors.I think that it`s my fault that i have soo much problems becouse i am try to make my pc to work with all he`s features ,and extra`s...but the best thing that all we can doo is to be carefull what we are downloading ,and try to be patient ...thanks !  Excuse me for my bad english!
    Friday, September 12, 2008 10:44 PM
  • I received it too, and what I did was go to this website:http://www.howtogeek.com/howto/windows-vista/fix-for-com-surrogate-has-stopped-working-error-in-vista/ after searching COM Surrogate on Google.


    Then I went to their Vista Codec link and installed it. Now the COM Surrogate error doesn't pop up anymore.


    Maybe you guys should try that?

    Wednesday, September 17, 2008 3:53 AM
  • I receive the same error messege every time I open any folder containing video files.  It is very anoying but otherwise seems harmless.  I can't seem to find any way to stop it from happening if you minimize the messege instead of closing it it seems to stop it from repeating itself.  MS should fix this.

    Saturday, September 27, 2008 8:27 AM
  • Hi guys found a nice quick easy fix. I think what causes this is a bug in xvid codec. Go to xvid website and download latest fix. I think its version 1.3 or something similar. released around april 2008. This worked for me and i got back all my thumbnails for my vids. Hope this helps


    Thursday, October 2, 2008 11:17 PM

    experienced the same on Nero...when i deleted the dllhost.exe thing as was suggested..puff..problem solved.Thanks
    Wednesday, October 8, 2008 2:06 PM
  • I hope this helps someone, it fixed my surrogate error problems with minimal effort.  I had just installed a new motherboard and had to reinstall XP Professional in fix mode, which made me install SP2, SP3 and all additional updates.  First, I found the following in the Microsoft documentation:


    Using the System-Supplied Surrogate

    To use the system-supplied surrogate for your DLL server, register the DLL specifying an empty string or NULL for the DllSurrogate named-value in the registry. When an activation request for a DLL server so designated comes to COM, COM launches the default surrogate process and the requested DLL (by specifying the CLSID on the launch command line internally) at the same time to avoid a separate call.


    This is my fix.  From the command prompt I brought up regedit.  I searched the entire registry for the word DllSurrogate.  Like it says, almost all of them will come up with no value, or "NULL" as in nothing in the field.  I found one out of about 30 that was filled in and referred to a file in the system32 folder.  The file didn't exist.  I deleted (emptied) the value entry and this solved my problem. 

    Saturday, October 11, 2008 9:10 PM
  • Hey Guys!!!!

    Are you still interesting in a solution regarding the Com Surrogate error or did you find the solution???
    Monday, October 20, 2008 8:26 AM
  • Interesting .... I had the problem, then received a message from Samsung's Studio 3 (the software for my Samsung phone) that its Automatic Update Tool caused the problem.   Opened Studio3 and applied the Automatic Update Toll ...... and it worked!

    Friday, October 24, 2008 2:15 PM
  • kiifer, this worked for me.



    Sam Anco

    Thursday, October 30, 2008 12:14 PM
  • This worked for me and I've tested on several of the documents that were causing the problem... how can something so simple as folder settings bypass Microsoft.

    Thankyou kiifer@hotmail.com you are a star

    Friday, October 31, 2008 3:51 PM
  • My problem with COM Surrogate message used to occur whenever I browse folders with video files. My computer is loaded with Windows Vista, WMP 11 and DivX That COM Surrogate message completely disappeared when I downloaded and installed the Vista Codec Package (Freeware from the link mentioned). Viewing of thumbnails had never been a problem anymore. Thanks.
    Monday, November 3, 2008 1:40 AM
  • thanks alot this programme really worked. i would reccomend to any one with the annoying

    COM SURROGATE. ****** A+++++++++++++++++++++++++++++


    Friday, November 14, 2008 7:42 PM
  • I have the same problem, and did not even know what it meant.  I have copy and pasted the page on an email, and sent it to my son, who will let me know what it all means.   Believe me, he will know.   When I hear from him, I will post the answer.

    Tuesday, December 2, 2008 9:44 PM
  •   I was just realizing, that my problem started when I downloaded the apple ipod and player,  I had to uninstall, as it was

    not what I wanted.   Well, when I tried to uninstall, it would not.   My windows media player stopped working, and I started getting all this com surrogate messeges.   I have tried to get some help from a reliable sourse and will post the advice on here as soon as I get it. 

    Tuesday, December 2, 2008 10:02 PM
  • I fixed this error by going to http://www.xvidmovies.com/codec/ and downloading the latest codec - http://download.divxmovies.com/XviD-1.1.3-27042008.exe

    Friday, December 5, 2008 8:45 PM
  • I just recently encountered this problem and here is the site that helped me out to fix this problem.


    Hope that this helps you guys out.
    Thursday, January 22, 2009 8:06 PM
  • Thursday, January 22, 2009 8:07 PM
    • Proposed as answer by Glowner Thursday, February 5, 2009 9:35 PM
    • Unproposed as answer by Alexander SklarEditor Tuesday, February 10, 2009 10:53 AM
    Thursday, February 5, 2009 9:35 PM
    Sunday, February 8, 2009 10:07 PM
  • COM Surrogate (dllhost.exe) is an application that is often used by Windows Explorer to isolate itself from buggy codecs (if explorer would load the codecs in its own process, it would crash as it did in XP, so explorer spawns dllhost to actually process the thumbnails, etc. outside of its process space).

    Upgrading the codecs installed on the machine should fix the vast majority of the cases.

    Removing Data Execution Prevention for dllhost.exe is a very bad idea, it opens the machine to a potential security vulnerability (since now the system does not prevent code from residing in pages without the NX bit). So please do not turn off DEP. More information about DEP can be found here (http://support.microsoft.com/kb/875352, while the contents refer to Server 2003, most of it is unchanged for Vista/Server 2008)

    Alexander Sklar | Software Development Engineer - Windows Serviceability

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, February 10, 2009 10:52 AM
  • It is an error with video codec.  Either your codec isnt compleatly updates (it could be nero, ffdshow, divx, and many others....) OR its a semi corrupted video file.  My sugestion is to:
    1. update all your video codecs.
    2. Find out which folder with video files in it that is cuasing the problem (it can be either the preloading or running of certain video files thats cuases the error).
    3. If it is only a few files, convert them into a different format, then convert them back to the format you want them in.
    4. VLC media player has a "repair" option, it doesnt always work, but 40% of the time it can fix the problem with the file.
    Saturday, March 14, 2009 5:05 AM
  • i received the terrible COM Surrogate message as well... i found out that i had a program by the name of Cineform NEO Player... wasnt quite sure how i got it but i think it had something to do with my new version of iTunes. gave me a couple of read me's with the including of Quicktime... i removed such a program and now i have the message no more! i hope this will help anyone else with this such problem!

    Friday, March 27, 2009 7:43 PM
  • Thanks for the info Kiifer, I followed your suggestion and it worked for me as well - I like my laptop again yay!
    However, is it wrong that I'm a little annoyed it was so simple?!

    Much appreciated x
    Monday, April 20, 2009 1:43 AM
  • cini had this problem on my laptop it started off with that gay message coming up all of the time and culminated with me being unable to watch any videos on my laptop only sounds , turned out cineform NEO PLAYER codecs were installed and didnt work properly so i removed them and installed Windows Essentials Media Codec instead . it works perfectly now. pity it took till 130am and me deleting things i thought caused it to figure it out :)

    and it looks like a couple of people already solved it on here wish i would have read the whole page before setting out to do it myself lol
    Saturday, May 16, 2009 12:40 AM
  • Add Acronis Backup & Recovery 10, build 11105, on Server 2008 to that List:
    Open an Archive of a backup, remove the i.e. USB drive containing that archive while exploring, and you will have that "COM Surrogate" until you close the affecting Windows-Explorer window. Once the window is closed everything is fine.

    So any "Explore-within-explorer" utility like some compression programs do can cause that too. I cannot name a different one than that specific Acronis version right now since WinRAR and 7-Zip don't plug themselves into explorer.exe like that.

    • Edited by Setsunaaa Monday, September 28, 2009 12:26 PM formatting was lost.
    Monday, September 28, 2009 12:10 PM
  • I downloaded Klite Codec Pack and uninstalled DivX, it works~! My players works properly as usual without com surrogate crashing. Good day, everybody!

    Saturday, November 7, 2009 5:46 PM
  • Mazurkan, just try and open with a different program, example, it does it to me when I try to open a video with MPCSTAR 4.5, so I open files with VLC media player and it works! Give it a try!
    Thursday, July 1, 2010 1:06 PM
  • All that is going to accomplish is making your system vulnerable to infection. Not to mention this was not your idea, Chrispy_Cracker posted this same thing word for word back in November of 07.

    So Raj stop riding on other people coat tails.

    Monday, December 17, 2012 4:56 AM
  • kiifer,

    This has fixed this annoying issue. Thank You so much :) All the other solutions involved nero, divx and kis. I have none of those programs on my computer. I only got this error when i tried to access my external hard drive. Before I read this I actually remove the hard drive from the case thinking the psu in the external enclosure was malfunctioning.... A simple solution that MS could have posted, updated but no, they send you on a wild goose chase running useless commands in CMD, going into safe mode and running check disk.... What a waste of time. I wish I would have found this before i yanked out my external hard drive from it's enclosure :P

    • Edited by caddy_boy Sunday, July 7, 2013 11:11 PM had to say thanks to kiifer
    Sunday, July 7, 2013 10:58 PM

    Problem: My Windows 7 x86 (32bit) Virtual Instance on Parallels Mac was having issues with launching Internet Explorer 11 after a forced upgrade from Internet Explorer 10. And since one of the websites needed for work rely on and are only compatible with Internet Explorer, this was driving me nuts. Every time I would launch Internet Explorer, I would get bombarded with a series of COM Surrogate errors that would never stop until I had ended the tasked via Task Manager and/or restarted the virtual machine.

    Diagnosis: After attempting all the currently available solutions on the internet..: Updating Windows 7/8 Codecs, Adding Data Execution Prevention (DEP) entries for both COM Surrogate and Windows Host Process for my x86 Windows 7, Running an Antivirus scan, attempting to find a way to downgrade Internet Explorer 11 (nearly impossible), and even removing my Parallels Display Adapter form the Device Manager..
    HERE IS THE SOLUTION that worked for me:
    1. Hit Windows + R (Run) and launch "inetcpl.cpl" (Internet Explorer Settings)
    2. Go to the Advanced Tab, and Click "Reset..."
    3. Check "Delete Personal Settings" and click Reset. Tada!
    Enjoy :)
    Sunday, December 22, 2013 2:59 AM
  • I have had this problem for a while now. I am not a computer professional. Pretty

    far from that actually. I Read a lot of suggestions which never helped,

    and some even made things worse. but I found a simple solution that I haven't seen anywhere.

    Since the issue is related to explorer I simply removed the last update

    of internet explorer:

    control panel ---- >

    programs and features ----->

    on the left side I clicked view installed updates ---->

    search for 'internet explorer', and clicked uninstall ---->

    Restart the computer.

    So far so good. 24 hours without the annoying surrogate com error.

    Monday, May 26, 2014 3:25 PM