locked
Disable Computer not reachable Monitor RRS feed

  • Question

  • Hello,

    We have several servers in Azure that have a auto power off time but a manual start time. What we are trying to do is to disable the Health Service Watcher (Computer Not Reachable). We still want all the other alerts to happen.

    I created a Group called  ""Disable - Failed to Connect to Computer ALERT"

    so I went to override for Computer Not Reachable and Disable the monitor for

    Group -"Disable - Failed to Connect to Computer ALERT - Generates Alert - FALSE

    Class  - Operation Manager Managed Computer Client Health Service Watcher Group - Generates Alert - False

    But when the server shutdown's and powers on we still get the SCOM New and closed alerts for the server

    Alert: Failed to Connect to Computer

    Source: XXXX.XXXX.XXXX

    Path: Microsoft.SystemCenter.AgentWatchersGroup

    Last modified by: System

    Last modified time: 10/1/2019 2:07:40 PM Alert description: The computer XXXX.XXXX.XXXX was not accessible.

    I did not place a override for the rule of "computer not reachable". Cause the alert i based on the Monitor.

    Any ideas on how to stop the computer not reachable alert for the group "Disable - Failed to Connect to Computer ALERT"


     

    Tuesday, October 1, 2019 9:08 PM

Answers

  • I can't believe that I did have the window big enough to see the Enforce Tick.  So silly of me.

    That fix the issue about not being alerted when the server is shutdown/start up.


    • Marked as answer by Goce_D Wednesday, October 2, 2019 11:11 PM
    Wednesday, October 2, 2019 11:11 PM
  • Hi,

    Thank you very much for the update. I'm glad the problem is solved now. If we are Using the Enforced Attribute in Overrides, it seems that there are other override takes precedence when two or more overrides of the same type and context conflict.


    Here's a short summary for the problem.

    Problem/Symptom:
    ===================
    Platform: System Center Operations Manager
    Problem details: 
    We have several servers in Azure that have a auto power off time but a manual start time. What we are trying to do is to disable the Health Service Watcher (Computer Not Reachable). We still want all the other alerts to happen.


    Possible Cause:
    ===================
    The are two or more overrides of the same type and context conflict.


    Solution:
    ===================
    check the "Enforced" checkbox to make this override takes precedence.
    That fix the issue about not being alerted when the server is shutdown/start up.


    Regards,

    Alex Zhu
    -----------------------------------------------
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    • Marked as answer by Goce_D Thursday, October 3, 2019 9:43 PM
    Thursday, October 3, 2019 7:15 AM

All replies

  • I have now also placed a override on the rule Computer Not Reachable - Success.

    Still getting alerts when the server goes down .

    Wednesday, October 2, 2019 3:01 AM
  • Hi,

    Create a group for those VMs, and then disable the Health Service Heartbeat Failure and Computer Not Reachable monitors for the group you created by creating overrides.

    You can find information on how the heartbeats works in SCOM and what monitors they use in the official documentation here:

    How Heartbeats Work in Operations Manager

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, October 2, 2019 7:35 AM
  • Hi,

    Per the quick test in the lab, I've disabled the following rule/monitor and the alter doesn't show any more.

    monitors:
    Health Service Heartbeat Failure
    Computer Not Reachable

    rule:
    Computer Not Reachable - Success




    Hope the above information helps.

    Regards,

    Alex Zhu
    -----------------------------------------------
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    Wednesday, October 2, 2019 8:14 AM
  • Hi,

    what kind of objects does your group   "Disable - Failed to Connect to Computer ALERT" contain? Computer objhects or Health Service Objects?

    You need to check the class the monitor is targed to and the chose the same type of objects for your group. Pretty sure those have to be Agent Service Health Watcher objects for this to work. 

    Regards,


    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Wednesday, October 2, 2019 8:52 AM
  • Hello Everybody,

    Here are the overrides I have for both Monitors and rule

    I then went to the rule a bit more and saw the following.Enfore was was ticked. So I have placed a ticked there now

    The Monitor also was not enforce

    Here is the group

    I will give this a go now. I will let you know the outcome

    Wednesday, October 2, 2019 10:14 PM
  • I can't believe that I did have the window big enough to see the Enforce Tick.  So silly of me.

    That fix the issue about not being alerted when the server is shutdown/start up.


    • Marked as answer by Goce_D Wednesday, October 2, 2019 11:11 PM
    Wednesday, October 2, 2019 11:11 PM
  • Hi,

    Thank you very much for the update. I'm glad the problem is solved now. If we are Using the Enforced Attribute in Overrides, it seems that there are other override takes precedence when two or more overrides of the same type and context conflict.


    Here's a short summary for the problem.

    Problem/Symptom:
    ===================
    Platform: System Center Operations Manager
    Problem details: 
    We have several servers in Azure that have a auto power off time but a manual start time. What we are trying to do is to disable the Health Service Watcher (Computer Not Reachable). We still want all the other alerts to happen.


    Possible Cause:
    ===================
    The are two or more overrides of the same type and context conflict.


    Solution:
    ===================
    check the "Enforced" checkbox to make this override takes precedence.
    That fix the issue about not being alerted when the server is shutdown/start up.


    Regards,

    Alex Zhu
    -----------------------------------------------
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    • Marked as answer by Goce_D Thursday, October 3, 2019 9:43 PM
    Thursday, October 3, 2019 7:15 AM