locked
Error uploading a document to SharePoint 2007 sites RRS feed

  • Question

  • Recently, a series of document libraries have started reporting "An unexpected error has occurred" when uploading a single document.  This occurs in some, but certainly not all document libraries over a number of sites.  We've found that the document actually does get uploaded.  We've haven't tested every site, but we believe that if the error occurs on one document library, it will occur on all document libraries in a site.  If it works on one, it will work on all in the site.

    Using the Upload Multiple Documents process does not cause the error.

    The SharePoint logs report the following:

    Application error when access /#####/####/###/Shared Documents/Forms/EditForm.aspx, Error=Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).   at System.Guid..ctor(String g)     at Microsoft.SharePoint.SPFieldLookup.get_LookupWebId()     at Microsoft.SharePoint.WebControls.LookupField.get_LookupList()     at Microsoft.SharePoint.WebControls.LookupField.get_DataSource()     at Microsoft.SharePoint.WebControls.LookupField.CreateChildControls()     at System.Web.UI.Control.EnsureChildControls()     at Microsoft.SharePoint.WebControls.BaseFieldControl.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Control.LoadRecursive()     at S...

    In the site that threw the above error, I created a NEW Document Library and Picture library.  Neither library threw an error when a document and image were added respectively.  So the issue seems to only affect current libraries.

    With a little training, this is likely to be viewed as an annoyance by our customers rather than a cause for alarm.  In the mean time, does anyone have thoughts on how to resolve this error?

    bc


    • Edited by Mike Walsh FIN Wednesday, August 10, 2011 9:09 AM SP 2010 off-topic and irrelevant to the question
    Tuesday, August 9, 2011 11:59 PM

All replies

  • HI,

    Have you tried using explorer view?

    If not then try using that and do let me know if it works or not.

    Have you done any kind of customizations?

     


    Thanks, Rahul Rashu
    Wednesday, August 10, 2011 5:23 AM
  • Explorer View has always been hit or miss with us.  Sometimes it works and sometimes not.  At the moment it's throwing an error that I need permission to move the document even though the account being used has Full Control to all sites.  I've verified that permissions didn't get dropped in this instance.

    SharePoint 2007 isn't vanilla out of the box, but it's pretty close.  Recently we've starting working towards a 2010 deployment and have been concentrating our efforts there.  Regardless, there have been no changes for quite some time.

    To recap:

    • The error is being seen on a number of sites, but not all sites.
    • The document does get uploaded despite the error message.
    • Using Upload Multiple Documents works all the time without the error message.
    • The error does not appear to be browser related.  The same error is returned using Firefox.
    • I have seen references to the GUID error, but it's always in the context of using the CEWP.

    bc

    Thursday, August 11, 2011 11:50 PM