none
Installing DPM 2012 agent - error 4 and error 346 RRS feed

  • Question

  • I'm unable to install the DPM 2012 agent on a target computer in a different forest. I've been able to handle others in the target forest - just this one particular host is a problem.

    I installed the DPM agent locally by following the suggested guidelines of doing so from a cmd prompt and passing in the FQDN of the DPM server as a parameter.  Installation completes successfully but I don't see this host on the DPM console.  If I attempt to attach the target server from DPM, I immediately get Error 346 re: the inability to retrieve the configuration information.

    From the DPM server's System log, I also get error 4 re: KRB_AP_ERR_MODIFIED.

    The one thing of note is this:

    • DPM is let's say:  dpm.company.com.
    • Inside comany.com, I am already protecting let's say sql1.company.com.
    • The target computer I am having problems with is sql1.company.net.  That is, while they are in different domains, the server I'm having a problem with has an identical hostname to a SQL server already being protected.

    Error 4 has description stating: "If the server name is not fully qualified, and the target domain (company.com) is different from the client domain (company.net), check if there are identically named server accounts in these two domains, or use the FQDN to identify the server".

    However, I am using FQDN.  Also there are no firewalls in between the 2 forests and the 2-way trusts exist as I am already protecting computers, cross-forest. 

    Has anyone come across this before?


    • Edited by Dave-LVP Friday, November 15, 2013 2:18 PM There was a typo in my post.
    Wednesday, November 13, 2013 5:18 PM

All replies

  • Hello.
    I have the same problem (Error 346) and I have verified that the problem is related to the computers having the same "name", but different FQDN.

    Did you get any solution for this?

    Best Regards

    /Peter

    Thursday, June 5, 2014 6:09 PM
  • Peter,

    Nice work. You helped solved my issue which I've been investigating for two days.

    My company has 2 domains that we are trying to consolidate into one. I need to install the agent on a server in the domain we are trying to decommission so that I can back it up to tape (the server is being decommissioned as well). I was unable to get the DPM 2012 agent to install on a server in the old domain (trusted domain "B") because trusted domain "A" had a DNS record (CNAME) that was named the same as the hostname of the server I was attempting to install the agent on. I temporarily removed the DNS record and the agent installed successfully.

    Wednesday, June 25, 2014 4:24 AM