locked
Multiple instances of Word launching when opening files from Explorer window RRS feed

  • Question

  • I am seeing an odd behavior with Word 2010 (32 bit) that I could not replicate in earlier versions of Word.

    Here are the steps:

    Note: When performing these steps, I am on a 32 bit Windows 7 machine. Word is not running yet, and the Task Manager dialog is open with the processes sorted in reverse alpha order so that WinWord.exe will appear at the top.

    1. Go to a folder containing a set of word documents or templates (all are in either .docx or .dotx format) in Windows Explorer.
    2. Select a group of files (I am selecting 4 .docx files in my tests).
    3. Right-click and select Open.
    4. Four instances of WINWORD.EXE appear in the Task Manager (one of them then goes away, leaving only three instances running, but I think that's beside the point).

    Could someone shed light on why this is happening with Word 2010 and if there's anything that can be done to make it "behave" and open only one instance? 

    PS - The templates contain no code, and no add-ins are loaded at the time that I perform these steps. Also, all Word and Office updates have been installed on the machine.

    Thanks
    Wordyone

    Wednesday, November 3, 2010 10:12 PM

All replies

  • Hi,

    The way both Word and various other programs (like Internet Explorer) work is that they normally run only one instance of their application, but that instance can have multiple windows open. The multiple windows are each main window and so look multiple instances in the taskbar at the bottom.

    Friday, November 5, 2010 7:24 AM
  • But what about the multiple WINWORD.EXE processes in the task manager?  That means there are extra running processes of the Word application, does it not? If I just launch Word and open 4 documents, there is only one WINWORD.EXE instance in the Task Manager.  When doing the steps above, watch the Task Manager dialog box (processes tab) and multiple WINWORD.EXE processes are being spawned.

    Friday, November 5, 2010 3:37 PM
  • I must say I do not know the answer to your question, and am only guessing at possibilities, but IE is a bit of a red herring here as it starts a new Process for each new tab - something Word does not do.
     
    If you open multiple Word Documents from Windows Explorer individually do you see the same behaviour?
     
    If you do it suggests the command invoked to open the document uses a switch to force a new instance, something that is not normal. Off the top of my head I'm not sure how to correct that.
     
    If you don't, it suggests something is stopping Word attaching to the existing instance - most likely some code in an AddIn.
     
    In Word 2010 there is another possibility related to Protected View - are the documents you are testing with, ones that open in Protected View?
     
     

    Enjoy,
    Tony
    www.WordArticles.com
    Friday, November 5, 2010 6:56 PM
  • Thanks Tony,

    I have verified that no add-ins are installed and the documents are not in Protected View.  It does not seem to happen when I separately click and then open each document one by one. 

    Also it seems to be a bug specific to Word 2010, because it doesn't happen when I perform same actions with opening documents into Word 2007.

     

    Friday, November 5, 2010 7:43 PM
  • I don't yet have 2010 on my main machine and have a tendency to reply to posts about it without actually checking, on the basis that it works and that odd behaviour is a result of environmental variables. But I see now that this is a bug in Word 2010, a fairly low impact one perhaps, but still, clearly, a bug.
     

    Enjoy,
    Tony
    www.WordArticles.com
    Saturday, November 6, 2010 8:17 AM
  • I can't offer a solution, but I am having the same problem. If I open 5 Word documents by right-clicking in Windows Explorer, the 1st goes into the current instance of Word, and new instances of Word are started for the other 4 documents. Sometimes I end up with an additional blank document in each new instance. If I open the documents one at a time (by right-clicking) they all go into the existing instance of Word.

    I have not yet installed SP2, and wonder if that might solve the issue.

    Monday, December 6, 2010 7:30 PM
  • SP2? Office 2010 isn't even at SP1 yet. What version of Word are you seeing this issue with?
     

    Enjoy,
    Tony
    www.WordArticles.com
    Tuesday, December 7, 2010 6:50 AM
  • It is Word 2010 RTM that is displaying this problem.  Apparently I'm not the only one who has noticed this issue, but seems like it is an undocumented bug with opening files from Explorer window. Hopefully Microsoft will fix it.

    Thanks
    Wordyone

    Tuesday, December 7, 2010 5:01 PM
  • Thanks, wordyone. You and I see it in 2010, and only 2010. R-B seems to think installing SP2 would fix the issue, so I was wondering what version he was using and seeing the problem with, as it apparently wasn't 2010, and it was him or her that I was addressing in my latest reply.
     

    Enjoy,
    Tony
    www.WordArticles.com
    Tuesday, December 7, 2010 5:12 PM
  • PS - I think that this may also be specific to Windows 7 (i.e., not Vista and XP with Office 2010).
    Tuesday, December 7, 2010 7:24 PM
  • I also have a user on Windows 7 with the latest version of Word 2007 that is having the same problem. I'll check her processes and she'll have 4 WINWORD.EXE open even when Word is closed. What is worse is that this somehow effects her copy and paste. It won't copy new items. It will paste something from 4 copies ago. Reinstalling Word temporarily solved the problem. I have deleted the Normal Template folder with no luck. Any help would be greatly appreciate in this matter. 
    Thursday, February 24, 2011 4:49 PM
  • hiya - i was wondering if you had an update on this issue. it appears SP1 for 2010 doesn't resolve the problem not do any of the windows 7 patches. thanks tons. -kk
    Friday, August 12, 2011 5:23 PM
  • Same problem here with Word and Office 2010. Winword32 hangs and sucks up cpu. Also at SP1, all latest updates.
    Sunday, August 21, 2011 10:20 AM
  • Thank you asking this question. I'll research to see if I can provide any additional details.

     

    Sincerely,

    Susan

    Microsoft Community Support


    Sincerely, Susan Microsoft Community Support
    Friday, September 16, 2011 4:37 PM
    Answerer
  • I'm following this thread now as we've encountered the problem:  Win 7, Word 2010-SP1.    Any insights into the issue and any "fixes"?

    Thursday, October 6, 2011 12:12 AM
  • i have heard nothing as of yet. -kk
    Thursday, October 6, 2011 4:13 PM
  • Hello,

    I have done some research on this issue. I wanted to let you know that it has been reported to our Products group, but currently there is no resolution available. Thank you for your inquiry.

    Sincerely,

    Ross

    Microsoft Word Support


    Ross - Sr. Support Engineer Microsoft Office Word
    Thursday, November 3, 2011 5:23 PM
  • OK. I just upgraded from Office 2003 to 2010 last week, and have been plagued by this problem of multiple instances of WinWord (4, to be exact) running in the background ever since. This seems to happen even if neither Word nor Outlook are opened (but perhaps after they have been run and closed...). The problem is that those instances will consumes 100% of the CPU usage. This is occurring on an HP 6000Pro desktop computer running under the 64-bit version of Windows 7 Pro.

    Any suggestions / fixes would be appreciated.

    Thanks

    Phil

    Sunday, November 6, 2011 8:17 PM
  • Thank you for following up on this, Ross.

    For future reference, is there a more direct way of reporting something like this -- i.e., some other MS website better for reporting bugs directly to the Office group?

    Tuesday, November 8, 2011 5:00 PM
  • While not confirmed from the product team, from what I have understood this is actually a design change.
    Sincerely, Susan Microsoft Community Support
    Monday, December 5, 2011 4:13 PM
    Answerer
  • wait ... you mean this was done on purpose?
    Monday, December 5, 2011 4:30 PM
  • Hello, I'm concerned as well to hear that this might be a design change. This does not make sense. If you are opening several documents from Windows Explorer you don't want 10 or 20 sessions or Word starting up. Please tell us that you will "undo" or that there will be an option for us to turn that feature off.
    • Edited by RachelleT Friday, January 6, 2012 5:40 PM
    Friday, January 6, 2012 5:40 PM
  • This is indeed a problem that seems to have several ways to get it started.  Take a look at this thread for more examples. http://social.technet.microsoft.com/Forums/en-US/outlook/thread/c4aeaf6c-f18d-4f92-acfe-2204f24d426d/

    The hung WINWORD.EXE processes quickly consume all available CPU and must be terminated manually.

    I don't buy the response that this is a design intent.  I can understand the behavior of separate instances when opening files in Protected View but normal use shouldn't have multiple processes.  Further when the calling process shuts down, the WINWORD.exe process should be shut down not left hanging (and consuming lots of cpu to boot).

    Pat Ryan

    Wednesday, January 11, 2012 9:06 PM
  • Yes, I too am having all the same problems highlighted already with Word 2010 (32 bit) with multiple instances of Windword.exe. Additional to what has been mentioned above, if I select say 10 files in Windows Exploer and right click / print in order to print them all with 'one action', it often errors out. It seems this might also be linked to Word trying to open a new instance of Winword.exe for each print and then close it down again. Temporary soluton is to open all the documents up from a single Word session (File / Open) and print each document individually (from the quick access toolbar, I quick print and then close each document - I sometimes have to print 50 - 100 documents!) There needs to be fix for this - talk about a backward step. At our next IT meeting, I'm going to suggest a roll back to Office 2007 where neither of these problems occured until a fix is issued for 2010.

    Mike

    Tuesday, January 31, 2012 5:02 PM
  • Mickle01--

    I am having the multiple instances of WINDWORD.EXE in processes and I'm on Word 2007 so downgrading might not fix your issue. We are using Windows 7 64-bit with Office 2007 installed. It all worked fine under XP. Now attorneys are telling me they can't copy and paste from IE to Word or Word to Outlook. I go into their process view and see multiple instances of WINWORD.EXE open. When I close them all, copy and paste works fine then for a few hours. Also another bug that I have in Word 2007 on Windows 7 is the preview pane not working when trying to view Word Docs. Microsoft tells me to go into Explorer to preview. Ridiculous it doesn't work in Word. 

    Might go back to XP. The preview pane people can live with as stupid as it is but the cut and paste, multiple WINWORD.EXE bug is terrible. 

    Please Microsoft fix these issues. Telling us to upgrade to 2010 isn't a fix. We bought 2007. 

    Thursday, February 2, 2012 8:45 PM
  • Also when I preview a PDF in Word, which used to work, Word tells me "This file can't be previewed because of an error in the PDF Preview Handler for Vista".

     

    I'm on Windows 7. 

     

    You guys at Microsoft are getting lazy. 

    Thursday, February 2, 2012 9:03 PM
  • I also have the same behaviour in my installation (Win7 32 bit, Office 2010, all patches applied), when I select and click to open multiple files to which I want to do a series of similar, systematic changes in a row.

    One side-effect of multiple instances opened is that if I try to repeat the last command (Ctrl-Y) in another document, it will not work - because it is a separate instance (process). The same thing applies to changes to the Normal template - it will always keep the version of the latest document (process) I close, and I might lose any customization I did when running of of the various instances.

    If this was a design decision (as commented in an earlier posting above), it was a bad one IMHO. Even if this speeds up launching open a batch of documents, I have seen more problems than benefits.

    One workaround that seems to work is, you open an instance of Word (with *no active document open*), then select the documents you want to open, and drag-and-drop into the Word window. This seems to force a single instance to be used. (Do not drag-and-drop into a window that has an open document, or the default action is do embed into the open document the files you are dropping...).



    Friday, February 3, 2012 7:33 AM
  • Any ideas SusanBu? Last we heard you were going to check with the Office Team about this. 
    Thursday, February 9, 2012 2:15 PM
  • Having just upgraded from Word 2003 to Word 2010 I find this very frustrating.   I thought new software was supposed to get better not worse.

    Strangely (and fortunately) it does not happen in Excel (although I thought Office was supposed to work consistently).

    Be glad to hear any answers.
    Thursday, March 1, 2012 12:34 AM
  • "GlenSydney" wrote in message news:29e28404-526e-43dd-bd84-e057ba251070@communitybridge.codeplex.com...
    Having just upgraded from Word 2003 to Word 2010 I find this very frustrating.   I thought new software was supposed to get better not worse.
     
     
    If you are saying that you see a button for each document on the taskbar, that is the default in recent versions of Word. To prevent this from happening, clear the “Show all windows in the Taskbar” option at File tab | Options | Advanced.
     
    Note that even if the option is enabled, there should be only one instance of Word running. You can confirm this by starting the Task Manager, where you should see only one winword.exe on the Processes tab.

    Stefan Blom, Microsoft Word MVP
    Thursday, March 1, 2012 7:17 PM
  • Thanks.

    In respect to your first suggestion, I knew that one and already had cleared that box.

    In respect to your second suggestion, Negative, when I open 4 Word files through a My Computer window I see 4 versions of winword.exe in the Processes tab of Task Manager.

    Pretty silly if you ask me.

    Thursday, March 1, 2012 11:17 PM
  • "GlenSydney" wrote in message news:86512589-a01d-4a09-b75e-3aea69555011@communitybridge.codeplex.com...
    In respect to your second suggestion, Negative, when I open 4 Word files through a My Computer window I see 4 versions of winword.exe in the Processes tab of Task Manager.
     
    Pretty silly if you ask me.
     
    OK, that shouldn’t happen. If you restart Windows, and then Word, does that improve the situation?

    Stefan Blom, Microsoft Word MVP
    Thursday, March 1, 2012 11:32 PM
  • um ... no offense stefan, but we're all having this problem on windows 7 with word 2010.
    Friday, March 2, 2012 12:00 AM
  • um ... no offense stefan, but we're all having this problem on windows 7 with word 2010.

        

    Sorry, I missed the first part of this thread because I was using a newsreader to access the forum. SusanBu seems to be saying that the new behavior is the result of a design choice. An obvious workaround is to not open several documents at the same time by double-clicking them in Windows Explorer. More importantly, note that you can make Microsoft aware that you do not like the change; you can post a suggestion at https://feedback.office.microsoft.com/default.aspx.


    Stefan Blom, Microsoft Word MVP

    Friday, March 2, 2012 12:15 AM
  • um ... no offense stefan, but we're all having this problem on windows 7 with word 2010.

        

    ... An obvious workaround is to not open several documents at the same time by double-clicking them in Windows Explorer. ..

    There is a better work-around, see my post above of Friday, February 03, 2012 7:33 AM. Basically the workaround is, have one instance of Word 2010 running but without any open document. Then drag-and-drop the documents you want to open into that open, document-less Word window. Only one instance is created this way.

    As per the behavior itself: if it was unintended, it is a bug; if it was intended, well, then it is a mistake. I prefer Excel's behavior where only one instance is created, unless you force Windows to do create a separate one (e.g. by Control-clicking the icon on the Task bar). Oh well.

    Simão Campos


    Friday, March 2, 2012 7:21 AM
  • "Simao Campos" wrote in message news:de32d65f-055d-4cda-9870-a6388186224f@communitybridge.codeplex.com...
    There is a better work-around, see my post above of Friday, February 03, 2012 7:33 AM. Basically the workaround is, have one instance of Word 2010 running but without any open document. Then drag-and-drop the documents you want to open into that open, document-less Word window. Only one instance is created this way.
     
     
    As always, there are several ways to accomplish the same thing in Word. What is better is simply a matter of taste, though. Personally I’d prefer using the Open dialog box and/or the Recent Documents list to open additional files.
     

    Stefan Blom, Microsoft Word MVP
    Friday, March 2, 2012 7:55 PM
  • "Simao Campos" wrote in message news:de32d65f-055d-4cda-9870-a6388186224f@communitybridge.codeplex.com...
    There is a better work-around, see my post above of Friday, February 03, 2012 7:33 AM. Basically the workaround is, have one instance of Word 2010 running but without any open document. Then drag-and-drop the documents you want to open into that open, document-less Word window. Only one instance is created this way.
     
     
    As always, there are several ways to accomplish the same thing in Word. What is better is simply a matter of taste, though. Personally I’d prefer using the Open dialog box and/or the Recent Documents list to open additional files.
     

    Stefan Blom, Microsoft Word MVP

    Thank you, these are all nice suggestions but they do not help me and they do not overcome what is looking like an obvious mistake in Word 2010.   (I run on Windows XP by the way).

    I run most program windows full screen or close to full screen and don’t have room to drag and drop between Windows.

    I also don’t want to have to close every other Word document before I open some more.   Throughout my day I have a minimum of several Word files open (client invoices) and I then open and close other files over the top of these constantly.

    I also don’t always open recent documents.

    A typical project for me will involve going into a folder in a My Computer / Windows Explorer window and CTRL-clicking several Word documents, several Excel documents and several PDF documents then hitting Enter (once) and presto they all (used to) open in one version of each program.

    Now they open in one version of Excel, one version of Acrobat and 7 versions of Word.

    Hmmmm.......


    Saturday, March 3, 2012 7:31 AM
  • "Simao Campos" wrote in message news:de32d65f-055d-4cda-9870-a6388186224f@communitybridge.codeplex.com...
    ... drag-and-drop ...
    As always, there are several ways to accomplish the same thing in Word. What is better is simply a matter of taste, though. Personally I’d prefer using the Open dialog box and/or the Recent Documents list to open additional files.
     

    Stefan Blom, Microsoft Word MVP

    Indeed, a good alternative to the drag-and-drop method is the Open dialogue box, as it works whether or not there are open documents in Word. One would just control-click on the various documents and click on Open. Of course all files need to be in the same folder, but it is the same as with my previous suggestion.

    It will not solve GlenSydney's issue with opening at one time different types of files - as word will not open an excel or acrobat file. But makes it two steps if having one instance of Word running is really important. (and yes, we are talking about workarounds, not solutions...)

    Saturday, March 3, 2012 9:14 AM
  • "GlenSydney" wrote in message news:1ac328bf-df21-4587-9eb8-4dadaad4d61a@communitybridge.codeplex.com...
    Thank you, these are all nice suggestions but they do not help me and they do not overcome what is looking like an obvious mistake in Word 2010.   (I run on Windows XP by the way).
     
    I run most program windows full screen or close to full screen and don’t have room to drag and drop between Windows.
     
    I also don’t want to have to close every other Word document before I open some more.  
     
     
    That leaves the Open dialog box as the only remaining alternative, I’m afraid. Do send feedback to Microsoft about this behavior: https://feedback.office.microsoft.com/default.aspx.

    Stefan Blom, Microsoft Word MVP
    • Proposed as answer by peebs7384 Thursday, April 19, 2012 5:52 PM
    • Unproposed as answer by peebs7384 Thursday, April 19, 2012 5:52 PM
    Saturday, March 3, 2012 12:30 PM
  • Hi

    I am by far no expert on Word but I did something that may have solved the problem.  I first started noticing a problem because my job calls for me to have several documents opened at once on my computer and we had all just updated from 2007 to 2010.  Every once in a while I would go back to the folder and accidentally click on a document that was already opened.  This would cause a new instance of Word 2010 to open and I would get the "File in use by 'another user'" (me) error.

    This was rediculously annoying since prior versions of Word would just bring the already opened file to the forefront of the desktop.  Once I came across this article I realized that every time I opened a new document a new instance of WINWORD.EXE would open too.  I came to the conclusion (and maybe I was wrong as I have such limited knowledge) that every time a new process of WINWORD.EXE was started, it would be considered 'another user' and thats why it would lock the document if I tried to open an already opened file.  Finally, I had previously read in other threads on the subject of "File in use by 'another user'" error that this was a problem in Word 2003.

    After reading this thread I started playing around with Word Options and found that if you go into "Advanced" under Options and go all the way to the bottom and you will see "Lay out this document as if created in:"  For some reason, my default layout was for Word 2003.  Once I changed it from 2003 to 2010, multiple instances of WINWORD.EXE stopped showing up and I was able to open all documents under one instance.  Better yet, I stopped getting the  "File in use by 'another user'" error.

    I have no why this worked or if this was even the reason but I just wanted to let you all know because maybe you can explain it or it will shed some light on the problem which will lead you to the correct reason.  Either way, hope I helped.

    Thursday, April 19, 2012 6:09 PM
  • Thanks Wordyone - didn;t help in my case.

    I experience the multiple instances of Word 2007 opening under Windows 7 at work. My problem is exacerbated by our electronic document management system (EDMS). People send links to documents in the EDMS, rather than copies of the document itself. The links are hyperlinks and do not provide location information about the document within the EDMS. The consequence is that I can only open the document using File...Open within Word, if I already know where the document is within the EDMS and can navigate to it. In most cases, this is not the case. So, usually, I have to double click on the link, which opens a new instance of Word - EVERY TIME.

    The consequences of this problem are further exacerbated as, in my work environment, Word automatically opens a number of templates containing macros that are part of the Word operating environment in our standard desktop. This results in error messages EVERY TIME a second (third, fourth, etc.) instance of Word is opened and further errors EVERY TIME a second (third, fourth, etc.) instance of Word is closed. The errors arise because Word is trying to use or save a template that is already opened in the first instance of Word. At best, it takes me 5 mouse clicks to close the second instance of Word instead of 1.

    This is highly frustrating and tremendously inefficient. The fact that this behaviour can be controlled in Excel (where the DDE option can be used to control it) and I have not experienced it with PowerPoint nor with Visio, suggests it is not a design intention. However, given the other significant design problems in Office 2007, I may be mistaken in this conclusion.

    I strongly urge the Microsoft people in a position to fix this to do so as a matter of urgency. I have already started switching to OpenOffice Writer, at home.


    Tuesday, May 29, 2012 3:48 AM
  • This looks like being the solution to this problem.

    I just found reference to a related issue in Word, with a discussion of how DDE operations for Word are controlled through the Registry. That reference is in this blog article - http://www.withinwindows.com/2008/08/31/taming-microsoft-word-2007s-file-associations-and-document-windows-part-one/. It actually refers to a method for creating the situation we have experienced when Word always opens new documents in teh same instance instead of creating a new instance.

    Based on this article, I checked the default DDE behaviour in the HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec key in the Windows Registry. I found the default value was set to "[REM_DDE_EXEC][FileOpen(%1)]". I changed this key's default value to "[FileOpen(%1)]".

    Word now behaves itself, opening each new Word document in the existing instance of Word when I double click on it. It even works with emailed links to our EDMS!

    I have been trying to find a solution for months. Hallelujah!

    Tuesday, May 29, 2012 4:09 AM
  • Pierre Phillippe,

    I'm also experincing this issue but do not have the ddeexec key in my registry to modify.  I'd be grateful if you'd let me know the key type and exactly how it's laid out as I'd like to see if this will solve the issue.

    Cheers.


    Jason Bevan MCSE the-it-service

    Tuesday, July 31, 2012 10:10 PM
  • i believe that he is suggesting that we add the key ... however i have two keys at the 'command' level, and neither of them have 'dde'

    see screenshot. the command key is actually hex.

    so do you still think i should add a 'dde' key with the %1 even though i have the %1 and no dde?

    keys found in [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]

    Tuesday, July 31, 2012 11:14 PM
  • Thanks peebs7384!  This worked for me!! Bless you!
    Sunday, August 5, 2012 9:57 AM
  • Thank you much for the solution! I'm having the same issue but am having a hard time getting the exact reg settings to get it resolved.

    I have tried many variations of the default command and command key and created the ddeexec key with the default value of "[FileOpen(%1)]". No matter what combos I try of these three reg values. I'm still having the issue. Would it be possible to post screen shots of exactly how you have the registry configured to resolve this issue?


    • Edited by kit_jj Tuesday, August 7, 2012 5:56 PM
    Tuesday, August 7, 2012 5:56 PM
  • I've got it working right in our environment, finally! The issue was that the Word.Document.12 hive only applies to .docx extensions and since we are working in a mixed environment of .doc and .docx file we had to also change the Word.Document.8 hive. I've copied the reg hacks below in case anyone needs the exact context.

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open]
    @="&Open"
    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]
    @="\"C:\\Program Files (x86)\\Microsoft Office\\Office14\\WINWORD.EXE\" /n  /dde"
    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec]
    @="[REM _DDE_Direct][FileOpen(\"%1\")]"
    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec\Application]
    @="WinWord"
    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec\Topic]
    @="System"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open]
    @="&Open"
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\command]
    @="\"C:\\Program Files (x86)\\Microsoft Office\\Office14\\WINWORD.EXE\" /n  /dde"
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec]
    @="[REM _DDE_Direct][FileOpen(\"%1\")]"
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Application]
    @="WinWord"
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Topic]
    @="System"

    • Edited by kit_jj Thursday, August 16, 2012 10:15 PM
    • Proposed as answer by kit_jj Thursday, August 16, 2012 10:16 PM
    Thursday, August 16, 2012 10:04 PM
  • check this link this may help you out

    http://answers.microsoft.com/en-us/office/forum/office_2010-word/multiple-instances-of-word-when-opening-documents/5dca0bf2-7e50-4f89-a9b9-6d1d07f62a84?msgId=e475f8fd-956a-4d08-9ca9-bca2c43ed466

    Friday, August 17, 2012 10:04 AM
  • 091012DEC12

    Here is another point being missed regarding the issue of "nes instance" of MS Word 2010 opening for each document, besides more RAM usage....more real estate wasted on the Windoze (mis-spelled on purpose) task bar, or desktop managers such as ALT DESK.

    I followed the steps above clear the “Show all windows in the Taskbar” option at File tab | Options | Advanced" which gives me only one instance of MS Word regardless of the number of documents I have open at the time, BUT I have not found a good way to navigate from document to document, YES I can minimize the document Window, but and stack the documents, but this seems quite archaic, like Win 3.1, compared to MS Word 2007 and older.

    Craig Knapp

    age 51

    anonymous posting is for wimps!

    craig.knapp1@yahoo.com

    Sunday, December 9, 2012 9:15 AM
  • "Craig Knapp" wrote in message news:0633aac4-fdee-45dd-90be-52a89546ca3d@communitybridge.codeplex.com...
    I followed the steps above clear the “Show all windows in the Taskbar” option at File tab | Options | Advanced" which gives me only one instance of MS Word regardless of the number of documents I have open at the time, BUT I have not found a good way to navigate from document to document, YES I can minimize the document Window, but and stack the documents, but this seems quite archaic, like Win 3.1, compared to MS Word 2007 and older.

     
     
    Note that you can use Ctrl+F6 (and Ctrl+Shift+F6) to navigate between document windows in Word.

    Stefan Blom, Microsoft Word MVP
    Sunday, December 9, 2012 12:32 PM
  • Thank you for sharing this fix. The registry key(s) shown in kit_jj's post for modifying DDE behavior did not resolve the issue for me. It did change the opening behavior in that Word doesn't open multiple instances any longer. But now, only the first document that I have selected opens--the others do not open at all.  Has anyone else had definite success with the registry key workarounds? If so, can you tell me what exactly you changed?
    • Edited by wordyone Monday, May 6, 2013 10:52 PM added clarification
    Monday, May 6, 2013 5:46 PM
  • Hi Pierre Phillippe,

    As more and more of our customers are having problems with this 'feature', I wanted to thank you for the solution you proposed/referred to.

    I see this thread already runs for 2 years, and no MVP can come up with this ?

    Therefore, Merci beaucoup !

    Tuesday, July 9, 2013 9:50 AM
  • The registry hack solved my problem with one exception, which will apply only to Office developers. If I launch WinWord from with Visual Studio (to test a plugin) and then open a file from a website, it still opens a second copy of Word. 

    If I run outside of Visual Studio with the plugin installed, the web document opens in the existing instance, as desired. So it's just a testing inconvenience. But if anyone has a further solution to this, I would like to hear it.

    Tuesday, March 4, 2014 3:52 PM
  • Five years have passed since this topic was started.... It is now January 2015. And Word 2010 is still launching multiple times, each time a Word document is opened from Windows Explorer. 
    Friday, January 16, 2015 1:54 PM
  • Koero, did you try the registry hack proposed in this forum?

    I started getting multiple instances of Word 2010 two days ago in Windows 7 on my company PC after a reboot following a Windows updates pushed out by the IT department.

    This also happened immediately after a Windows update on May 27, 2014, but somehow I was able to stop that behavior then.  That fix happened after I restored a old copy of Normal.dotm but evidently that was not the solution because restoring that copy did not fix the problem today.

    The fix suggested by peebs7384 in this forum on April 19, 2012 of changing the "Lay out this document" setting did not work on my PC.

    One support person who has both the 2010 and 2013 versions indicated that he also gets multiple instances with 2010 but not with 2013.

    I plan to ask my IT department to attempt a fix tomorrow and will suggest that they try registry hack posted in this forum by kit_jj on Aug 16, 2012 (based on Pierre's posting) (thanks kit_jj and Pierre).

    By the way, kit_jj's posting has only 1 vote & I would had hoped to see more votes.  Now that I look more closely I see that this solution was "Proposed as answer by kit_jj" himself.  At least others have posted comments that indicate that fixes posted by kit_jj & Pierre have worked (at least partially).

    Any ideas as to why this started happening again?

    Sunday, January 25, 2015 4:29 PM
  • Noting again, when Ctrl+O is used from within Word you do not get multiple instances of Word.

    Charles Kenyon Madison, WI

    Sunday, January 25, 2015 10:25 PM
  • The good news is that the problem is fixed.  The bad news is I don't know how it got fixed.  The problem somehow disappeared without doing a registry hack or changing any other setting.  For what it's worth, this is part of what happened.  In trying to connect remotely to my IT support to share my screen and show them the problem, I was having network connectivity problems.  IT therefore asked me to log off Windows and log back in.  After doing that, when I shared my screen, all doc's opened in a single instance of Word.  As I indicated in my previous post, the problem disappeared also somehow in May 2014.

    Charles, I'm aware of the option to use Ctrl+O and I would have used that if the problem could not be fixed.  However, it would mean that I would have to change the setup / configuration / mode of operation on my PC which now employs a lot of my custom Windows toolbars (on the taskbar) with shortcuts to directories and Word documents.

    In addition Charles's tip above, for those that still have the problem …

    Repeating Siamo Campos's tip from Feb 2012: One workaround that seems to work is, you open an instance of Word (with *no active document open*), then select [in Windows Explorer] the documents you want to open, and drag-and-drop into the Word window. This seems to force a single instance to be used. (Do not drag-and-drop into a window that has an open document, or the default action is do embed into the open document the files you are dropping...)

    Additional tips: (1) Pin commonly-accessed documents in Word itself under recent documents, (2) In the Ctrl+O ("Open") window, add "Favorites" shortcuts to go directly to commonly-accessed folders. This will help reduce the need to navigate / drill down/up/over to the folder you want.  (3) Write macros to open commonly-accessed documents.  You can also create keyboard shortcuts to execute the various macros.  For example, I configured Alt+2 to execute my macro which opens my "To Do" document; plus if "To Do" is already open and I'm in another document, Alt+2 switches me to my "To Do" document.  This is SO NEAT; it saves me a lot of time.  (4)  In Windows 7 if you are in a Windows Explorer folder and see a document you want to open, you can do Shift+RightClick on the document | Copy as path; then switch to Word | Ctrl + O | Ctrl+V | Enter.  (Siamo's tip is probably easier depending on the location of the windows.)  (5) You can also use Shift+RightClick to copy a folder's path | switch to Word | Ctrl+O | Ctrl+V enter to open that directory in Word.  (6) Set up WinExp to display the current folder's path as shown in the upper part of the image below.  Then click on the path to get the path in its native form as shown in the lower part of the image.  Hit Ctrl+C to copy the path.  Then switch to Word | Ctrl+O | Ctrl+V enter to open that folder in Word.

    Forget the image.  When I tried to submit this post, social.technet said it needs to verify my account before it will accept an image.  I don't have time to do that now.

    • Proposed as answer by Charles Kenyon Tuesday, January 27, 2015 3:00 AM
    Tuesday, January 27, 2015 1:56 AM
  • I recently migrated from 2010 (where I also had this problem) to 2013 in a new computer. I opened a batch of files by selecting the icons and hitting enter, and it still generated several instances of WINWORD.EXE. I then used my method above (drag and drop over an open WinWord instance without an active document), and only one instance remained launched.

    In conclusion, whichever "bug" or "feature" was present in WinWord 2010 that caused multiple instances being launched when opening multiple files at the same time, it remains in WinWord 2013.

    NOTE - I have a mix of DOC / DOCX files in both "native"and "compatibility mode". I have a gut feeling that the this may be part of the picture (untested, though).

    Simão Campos

    • Proposed as answer by jlmiller Wednesday, January 28, 2015 1:12 AM
    • Unproposed as answer by jlmiller Wednesday, January 28, 2015 1:12 AM
    Tuesday, January 27, 2015 10:04 AM
  • I too have seen this in a Citrix session where a client goes to a company folder and double click on multiple documents and that is reflected in task manager as multiple instances of Word (winword.exe).

    I had him close them all out and instead open multiple documents from within Word.  This only showed 1 instance of winword.exe  in task manager processes.

    Someone already stated that with multiple copies of word open it becomes difficult to do certain operations, whereas when a single copy of word is opened with multiple windows those operations still works.

    So I instruct the users to use only 1 copy of the application and use the file open to open multiple documents if they need to have multiple documents open.


    Jon Miller, RCS Technologies

    • Proposed as answer by jlmiller Wednesday, January 28, 2015 1:20 AM
    Wednesday, January 28, 2015 1:20 AM
  • It happens in 2007 and 2013 also.  We've had this issue for quite a while.  I keep trying, but have not been successful, in finding the answer, but it is exactly as you have stated.  When a second instance of Word is opened, or if Word is opened from Windows Explorer, it does not display settings from the registry.
    Wednesday, January 27, 2016 6:34 PM
  • I've got it working right in our environment, finally! The issue was that the Word.Document.12 hive only applies to .docx extensions and since we are working in a mixed environment of .doc and .docx file we had to also change the Word.Document.8 hive. I've copied the reg hacks below in case anyone needs the exact context.

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open]
    @="&Open"
    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]
    @="\"C:\\Program Files (x86)\\Microsoft Office\\Office14\\WINWORD.EXE\" /n  /dde"
    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec]
    @="[REM _DDE_Direct][FileOpen(\"%1\")]"
    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec\Application]
    @="WinWord"
    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec\Topic]
    @="System"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open]
    @="&Open"
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\command]
    @="\"C:\\Program Files (x86)\\Microsoft Office\\Office14\\WINWORD.EXE\" /n  /dde"
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec]
    @="[REM _DDE_Direct][FileOpen(\"%1\")]"
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Application]
    @="WinWord"
    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Topic]
    @="System"

    I have Office 2016 on Windows 7 and The following registry works for me

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open]
     @="&Open"

     [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]
     @="\"C:\\Program Files\\Microsoft Office\\Root\\Office16\\WINWORD.EXE\" /n  /dde"

     [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec]
     @="[REM _DDE_Direct][FileOpen(\"%1\")]"

     [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec\Application]
     @="WinWord"

     [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec\Topic]
     @="System"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open]
     @="&Open"

     [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\command]
     @="\"C:\\Program Files\\Microsoft Office\\Root\\Office16\\WINWORD.EXE\" /n  /dde"

     [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec]
     @="[REM _DDE_Direct][FileOpen(\"%1\")]"

     [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Application]
     @="WinWord"

     [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Topic]
     @="System"

    • Proposed as answer by Mark_O_1027 Saturday, September 23, 2017 12:32 PM
    Wednesday, June 21, 2017 3:42 AM
  • Thanks to the work of kit_jj and Lei Fen I was able to modify the registry settings of their proposed answers to work on Word 2016 32-bit installations within Windows 10.  I am not an expert and don't fully understand the command switches used but the registry settings below seem to work perfectly for me.  Prior to applying these settings, all Word documents following the first that were opened through any source other than Word's Open menu would throw an error that Word had stopped working properly and I needed to close Word.  All documents remained open and functioned properly but the message was annoying.  After applying the registry settings, no more error message.

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open]
    @="@C:\\Program Files (x86)\\Microsoft Office\\Root\\VFS\\ProgramFilesCommonX86\\Microsoft Shared\\Office16\\oregres.dll,-3"

    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command]
    @="\"C:\\Program Files (x86)\\Microsoft Office\\Root\\Office16\\WINWORD.EXE\" /n  /dde"

    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec]
    @="[REM _DDE_Direct][FileOpen(\"%1\")]"

    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec\Application]
    @="WinWord"

    [HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\ddeexec\Topic]
    @="System"


    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open]
    @="@C:\\Program Files (x86)\\Microsoft Office\\Root\\VFS\\ProgramFilesCommonX86\\Microsoft Shared\\Office16\\oregres.dll,-3"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\command]
    @="\"C:\\Program Files (x86)\\Microsoft Office\\Root\\Office16\\WINWORD.EXE\" /n  /dde"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec]
    @="[REM _DDE_Direct][FileOpen(\"%1\")]"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Application]
    @="WinWord"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Topic]
    @="System"
    • Proposed as answer by Charles Kenyon Friday, September 29, 2017 4:30 PM
    Saturday, September 23, 2017 12:42 PM
  • Charles,

    I have been able to locate and change all these lines  EXCEPT for these - I don't seem to have a " the ones which have a "ddeexec" level within my Word.Document.12.\Shell\Open  structure - any suggestions?

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec]
    @="[REM _DDE_Direct][FileOpen(\"%1\")]"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Application]
    @="WinWord"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Topic]
    @="System"

    Wednesday, February 14, 2018 5:27 PM
  • Charles,

    I have been able to locate and change all these lines  EXCEPT for these - I don't seem to have a " the ones which have a "ddeexec" level within my Word.Document.12.\Shell\Open  structure - any suggestions?

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec]
    @="[REM _DDE_Direct][FileOpen(\"%1\")]"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Application]
    @="WinWord"

    [HKEY_CLASSES_ROOT\Word.Document.8\shell\Open\ddeexec\Topic]
    @="System"

    Late reply to Lonna:

    If you do not add those entries but make the other changes does it fix the problem?

    If not, try adding those entries.

    Always make a backup of your Registry before doing any editing!


    Charles Kenyon Madison, WI

    Thursday, August 30, 2018 5:54 PM