locked
Issues with Cisco Jabber for Windows 7 RRS feed

  • Question

  • Hello everyone,

    We are having problems to getting Cisco Jabber to work: DirectAccess is using a IPv6 tunnel to connect the client to the internal network it seems Jabber doesn’t work with IPV6.

    When we configure our DNS name as an external domain... Jabber works fine. This isn’t a practical solution because so many internal site are using that domain so we have configured it as a internal domain. That is not working, it seems Jabber has issues detecting an external network when the DA link is active, and it thinks that is a internal network... then it attempts to connect to the internal network and not through the gateway.

    Any ideas? Thank you.

    Thursday, July 23, 2015 9:46 PM

All replies

  • Hi,

    If I understand correctly, Jabber is trying to connect through the DirectAccess tunnel instead of connecting to your gateway.

    Is Jabber using multiple hostnames to connect to your infrastructure?
    ex: 1 internet hostname for external access through your gateway while outside your corporate network and one intranet hostname when the client is inside the corporate network.

    Gerald

    Monday, July 27, 2015 12:21 PM
  • Hello, Yes that is correct. We have a different hostname when accessing from Internet, and another when inside the corporate network. Thank you.
    Monday, July 27, 2015 12:58 PM
  • Have you tried to exclude the internal domain name in the NRPT tables?

    DirectAccess configuration -> Step3 -> DNS : Create an entry for your internal Hostname without adding the DNS Server Address.

    If the laptop is not able to resolve the Internal name while outside your network, it should try to contact the Internet name using IPv4.

    Gerald

    Monday, July 27, 2015 1:04 PM
  • Yes, and that worked. However it's something not "doable" here, since we have thousands of applications that are part of this same domain... we would have to create individual record for every single URL/application, it would be something hard to manage.

    So right now we are trying to find a way to make Jabber work with that, however not going Direct Access... and just using the Internet gateway. Officially Jabber client (currently) does not support IPV6, and we believe this is why it's now working with DirectAccess. So if we could find a way to force Jabber to use always Internet gateway.. we believe that would solve our issue. But Jabber has this "mechanism" where it detects the current network, and it's trying to use the internal DNS when connected through Direct Access.

    Thanks again!

    Monday, July 27, 2015 1:20 PM
  • You dont need to exclude the full domain... Just create an entry for the hostname of your internal jabber server...

    Ex: yourdomain.local can use DirectAccess but jabberserver.domain.local can't

    Gerald

    Monday, July 27, 2015 1:34 PM
  • Thanks Gerald, it's still not working... somehow Jabber does not get connected. I will keep trying and update this once I get news.
    Tuesday, July 28, 2015 12:55 AM
  • Hello community, We are having a very similar or identical problem: we are installing the Cisco Jabber solution without inconvenience in our infrastructure (LAN, WiFi, remote access via VPN, through the Firewall), but we can not run Jabber with DirectAccess.The Jabber client automatically discovers the services in all cases (SRV records), the user is able to authenticate and use the messaging services. Even through DirectAccess, it manages to control its desktop phone (which is not really necessary if we consider that the user accesses the corporate network from his home with DirectAccess).

    But the problem occurs when we want to take control of the softphone using DirectAccess. The connection is never established. By performing a packet capture in the Firewall, we do not observe SIP connection attempts, however in the Jabber log, there are records that indicate connection attempts using the IPv4 of the CUCM server instead of the FQDN (DirectAccess requires FQDN since it uses a tunnel IPv6). All our configuration of CUCM, IM & P, etc., is made with FQDN. Could anyone solve this problem?

    Thank you.

    Tuesday, March 28, 2017 11:25 PM