locked
SSTP - Connection Ended RRS feed

  • Question

  • Would someone be able to possible help with a SSL VPN SSTP issue?

    The problem I'm having is getting the VPN connected. I get the message saying Connection Started and then around a second later one saying Connection failed.

    I have seen may references to this online with the problem being the certificate however I have imported the certificate onto the test machine (which is a Windows 7 Pro x64 SP1). I have also checked I'm able to get to the CRL which I am (from both the server and client). The only messages in the system even logs on the server are:  

    • SSL Certificate Settings created by an admin process for Port : 0.0.0.0:6002 .
    • CoId={6BE0C652-681D-4804-ABC2-0CFF6D68156E}: Disabling PPP AUTH for {domain}\\{username} on port VPN0-249.
    • The Remote Access Server acquired IP Address 10.17.22.236 to be used on the Server Adapter.

     

    I have tried this (I saw this on another fourm post on here but still no luck)

    NoCertRevocationCheck

    Registry subkey: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Sstpsvc\Parameters
    Registry entry: NoCertRevocationCheck
    Data type: REG_DWORD

    Couple of other bits of information:

    •  - The client is not part of the domain
    •  - The server is not part of the domain
    •  - I'm able to use RemoteApp applications OK though the portal
    •  - When the connection fails a windows called 'Reconnect UAGSSTPVPN' appears.
    •  - I have imported the CRL list onto the client and server

    If anyone is able to help I would really appreciate it.

    Thanks, Joe

     

    Thursday, May 12, 2011 9:08 PM

All replies

    •  - The server is not part of the domain

    Thanks, Joe

     


    Hi Joe,

    please note the UAG server domain membership requirement, as mentioned here: Setting up Remote Network Access:

    " Note that SSTP deployment requires that Forefront UAG servers belong to a domain."

     

    Regards,


    -Ran

    • Proposed as answer by Ran [MSFT] Sunday, July 24, 2011 7:35 AM
    Saturday, May 14, 2011 1:42 PM