locked
SharePoint 2007 404 error RRS feed

  • Question

  • I have SharePoint 2007 install and running on my local work station. I can view the Central Administration site no problem. I have setup another site for development purposes, but when I try to view the development site thru IE I get a 404 error. I can see the new site in IIS 7.0 so I thinking it may be a permission issue, but I am not a netadmin and I cannot confirm my assumptions. Any help would be greatly appreciated.
    Wednesday, May 2, 2012 6:45 PM

Answers

  • A couple thoughts:

    • It sounds like you created your web application but did you also create a site collection within that web application?  If not, then you need to create a site collection or else there is no site to navigate to
    • If you did create a site collection, then what port is your web application on?  Are you using host headers?
    • If you are using host headers, then there may be a DNS issue.  Try pinging the new site to see if it returns correctly.  If not, try updating your hosts file to ensure the DNS resolves to the correct server
    • Marked as answer by BAMA_50 Thursday, May 3, 2012 3:26 PM
    Thursday, May 3, 2012 2:40 PM

All replies

  •  If you could try this and report back... Surf to http://www.fiddler2.com/fiddler2/ and use Fiddler2 to see where the URL (HTTP) traffic is being redirected to that would help.  It's a very clean and easy tool to use.  Feel free to drop the logs back here.

    Thanks
    Kris Wagner


    Kris Wagner, MVP, MCITP, MCTS Twitter @sharepointkris Blog: http://www.sharepointkris.com/blog

    Wednesday, May 2, 2012 6:56 PM
    Moderator
  • Kris,

    I have fiddler installed. Can you give me a little more detail on I should be posting regarding the logs? I do see where the request comes in when the site is called by IE.

    Wednesday, May 2, 2012 7:51 PM
  • A good start would be posting any of the log entries around the 404 message.  Are there any account details being passed that stand out as unusual accounts ?

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Wednesday, May 2, 2012 7:58 PM
  • Yes I see the entry for the 404 error in fiddler. Here is copy of the header log from the 404 entry.

    Header

    GET /default.aspx HTTP/1.1
    Accept: application/x-ms-application, image/jpeg, application/xaml+xml, image/gif, image/pjpeg, application/x-ms-xbap, */*
    Accept-Language: en-US
    User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3)
    Accept-Encoding: gzip, deflate
    Connection: Keep-Alive
    Cookie: MSOWebPartPage_AnonymousAccessCookie=42980; WSS_KeepSessionAuthenticated=42980
    Host: bhm-bargo-w7:26256
    Authorization: NTLM TlRMTVNTUAADAAAAAAAAAFgAAAAAAAAAWAAAAAAAAABYAAAAAAAAAFgAAAAAAAAAWAAAAAAAAABYAAAABcKIogYBsR0AAAAP4lhZ9ubz2M/z5QoX/OMW0Q==

    Wednesday, May 2, 2012 8:20 PM
  • Just a thought but have you granted any access to the web application you're being denied to?  From Central Admin, Application Management check the web application policy to see if anyone has access.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Wednesday, May 2, 2012 8:34 PM
  • The only permission that is granted is to the NT AUTHORITY\LOCAL SERVICE. You have to remember that this
    SharePoint installation is on my work station for development purposes.<o:p></o:p>


    Thursday, May 3, 2012 1:46 PM
  • A couple thoughts:

    • It sounds like you created your web application but did you also create a site collection within that web application?  If not, then you need to create a site collection or else there is no site to navigate to
    • If you did create a site collection, then what port is your web application on?  Are you using host headers?
    • If you are using host headers, then there may be a DNS issue.  Try pinging the new site to see if it returns correctly.  If not, try updating your hosts file to ensure the DNS resolves to the correct server
    • Marked as answer by BAMA_50 Thursday, May 3, 2012 3:26 PM
    Thursday, May 3, 2012 2:40 PM
  • Can you add permission for the local user account you're using? If NT Authority\Local Service is the only account that has access then your currently logged on user account doesn't.  What identity are you using? or at the very least add the Administrators local user group.

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Thursday, May 3, 2012 2:40 PM
  • Sephiroth makes a good point, do you have a site collection in your web application?

    Paul Turner http://redmanta.co.uk/blog Twitter: @RedMantaUK MCTS:WSS,MOSS,2010 MCITP:2010.
    Please remember to click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.

    Thursday, May 3, 2012 2:41 PM
  • Yes. I have added myself..

    Thursday, May 3, 2012 3:02 PM
  • As I stated in my first posting I am not a netadmin, but I am willing to learn. Thanks to all who help me resolve this issue. Once I added the development site url to the site collection the issue was resolved.

    Thursday, May 3, 2012 3:34 PM
  • I apologize for replying to ask a question, but i cannot find a link to actually ask a question, So here goes...

    I am running Windows 2008R2 in a Hyper-V behind a sonic wall. I have 8GB of memory. I am running SQL Server 2008R2 and SharePoint 2007. I have started all services, built top collection set my home site, made sure shared services is running on all sites. No matter what we try( this is my college class, and we can't figure it out) we cannot connect from home. We have disabled Windows Firewall on our VServers completely. We on our a Workgroup, if we join the domain ADDS deletes our databases users, or alters permissions, even though we run mixed mode. Any suggestions for the Sonicwall?


    • Edited by JustMarried'12 Thursday, May 3, 2012 9:44 PM mistated version of SQL Server
    Thursday, May 3, 2012 9:43 PM
  • JustMarried'12 - at the top of this thread, there is a "Ask Question" button ;)  There is a similar button at the top of the forum itself
    Thursday, May 3, 2012 11:36 PM