locked
Subscribed to Confluence ics feed, calendar is blank in OWA and Outlook RRS feed

  • Question

  • We've got several users who have subscribed to calendars hosted on our Confluence servers via OWA but the subscribed calendars are coming up blank. When this was first tested it all worked fine but I've got a subscription to my team calendar and I'm seeing the same behaviour. I've tested via Invoke-WebRequest on all of the Exchange Mailbox servers to confirm that they can reach the ics location and all of the servers are returning the content as expected.

    We can't subscribe via the Outlook client method as we're predominantly a Mac organisation.

    4-server DAG, all running Exchange 2016 CU16 with Windows and .net 4.8 patched to June 2020 (CU17 and July patches planned for deployment in the next couple of weeks).

    There seems to be a documentation black hole here as I can't find any reference to which logs I need to be checking to see why these failures might be occurring, and virtually every search I perform for these terms comes back with results for publishing one's own calendar to an ics feed for others to subscribe to. If someone can point me in the right direction here I might be able to fix it without opening a support case.

    Thursday, July 16, 2020 4:20 PM

All replies

  • Hi Joeykins,

    Could you see your subscribed calendars in Other Calendars in OWA and Outlook?

    Could you add, delete and modify your calendar?

    1. Please try to unsubscribe from the calendar and then subscribe again to see if it can be displayed.

    2. You could also try to recycle OWA application pool and run IISreset in CMD as an administrator on your Exchange server.

    3. By the way, I found that in some cases, the browser can also cause the calendar to not display properly. Please try to change the browser to view the calendar.

    In addition, you could check whether have related error information in the Event Viewer and if there have error message when you subscribe the calendars. If you find any error message, please share with us, please note that hide your private information.

    This Exchange Server 2016 - Collaboration Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Regards,

    Lucas Liu


    Exchange Server 2016 - Collaboration forum will be migrating to a new home on Microsoft Q&A! We invite you to post new questions in the new forum.

    For more information, please refer to the sticky post.

    Friday, July 17, 2020 8:14 AM
  • We've already done the remove & re-add stuff which hasn't helped. I've cycled that app pool now and it doesn't seem to have helped (removed and added the subscription after cycling too).

    I've done an IISReset as well which also hasn't helped.

    As I've said I don't know which log files or Event Source/IDs I'm looking for with this issue so if you can point me at the correct locations to be looking for this info it'd be really helpful please.

    Monday, July 20, 2020 4:30 PM
  • Hi Joeykins,

    Does the issue occur to all subscribed users, or does it occur to some of the subscribed users? 

    Microsoft officially did not provide or summarize the relevant event id. I recommended that you check whether there are related error logs in the event viewer when issue occur.

    1. Please try to change the browser and check again.

    2. Considering that this is a third-party calendar, it is recommended that you contact the supplier to see if certain prerequisites need to be met.This is the official forum of Confluence, where you can conduct related consultations.

    This Exchange Server 2016 - Collaboration Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Regards,

    Lucas Liu


    Exchange Server 2016 - Collaboration forum will be migrating to a new home on Microsoft Q&A! We invite you to post new questions in the new forum.

    For more information, please refer to the sticky post.

    Wednesday, July 22, 2020 9:23 AM
  • I added a subscription to a .ics hosted on our Confluence webservers a few weeks ago and it worked great. After successfully testing it I issued the guidance to a wider audience but now that lots of people have added subscriptions to different calendars here we've started to encounter problems.

    It's not an issue with permissions as I've explicitly tested accessing the ics file anonymously via Invoke-WebRequest, and I've confirmed it's not a network/proxy issue.

    Wednesday, July 22, 2020 12:03 PM
  • Hi Joeykins,

    According to the information you provided, all users who subscribed to this calendar can use it normally. The error occurred when some users subscribed to other calendars. Check to see if this problem is caused by OWA restrictions. So please try to cancel the subscription of other calendars and only subscribe to Confluence to see if it can be displayed normally.

    This Exchange Server 2016 - Collaboration Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Regards,

    Lucas Liu


    Exchange Server 2016 - Collaboration forum will be migrating to a new home on Microsoft Q&A! We invite you to post new questions in the new forum.

    For more information, please refer to the sticky post.

    Friday, July 24, 2020 9:21 AM
  • Hi Joeykins,

    Do suggestions above help? If you have any questions or needed further help on this issue, please feel free to post back. If the issue has been resolved, please mark the helpful replies as answers, this will make answer searching in the forum easier.

    Thanks for your understanding.

    This Exchange Server 2016 - Collaboration Forum will be migrating to a new home on Microsoft Q&A, please refer to this sticky post for more details.

    Regards,

    Lucas Liu


    Exchange Server 2016 - Collaboration forum will be migrating to a new home on Microsoft Q&A! We invite you to post new questions in the new forum.

    For more information, please refer to the sticky post.

    Wednesday, July 29, 2020 9:05 AM