none
Exchange 2013 Logs - External SMTP Logs

    Question

  • Hi there,

    I'm trying to look at external logs as i'm having delayed emails but I can't see any logs from external SMTP servers, I've enabled logging on receiver and when I check logs for TRANSPORT\SmtpReceive all I see are logs between the Exchange servers in the DAG and NOT any external SMTP connections or errors.  Looked everything but can't find it!  Where can I grab these.

    Thanks!

    Sunday, November 20, 2016 10:18 PM

All replies

  • Hi there,

    I'm trying to look at external logs as i'm having delayed emails but I can't see any logs from external SMTP servers, I've enabled logging on receiver and when I check logs for TRANSPORT\SmtpReceive all I see are logs between the Exchange servers in the DAG and NOT any external SMTP connections or errors.  Looked everything but can't find it!  Where can I grab these.

    Thanks!

    Enable logging on the receive connector that accepts mail from the internet.


    Blog:    Twitter:   

    Sunday, November 20, 2016 11:24 PM
  • Hi Ed,

    I have but no external logs only internal ones.  I enabled logging on Default Front End Transport and logs all internal between the x2 Exchange under a DAG.

    Monday, November 21, 2016 8:47 AM
  • Hi Ed,

    I have but no external logs only internal ones.  I enabled logging on Default Front End Transport and logs all internal between the x2 Exchange under a DAG.

    Hi pjmartins,

    Welcome to our forum.     

    By my understanding, you have configured external SMTP relay in your organization and you want to view log which record email SMTP log. If that, please enable protocol logging on receive connector by the following link, then check its log:

    https://technet.microsoft.com/en-us/library/bb124531(v=exchg.150).aspx

    If there are any questions or issues, please be free to let me know.   


    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    Tuesday, November 29, 2016 5:21 AM
    Moderator
  • Hi Jim,

    Thanks, I have and can't see anything from the outside world, only internally which is strange, I expect to see logs from the outside world but nothing on port 25.  Really strange as i'm getting error connecting from outside to our Exchange, not all emails, but 10% are delayed as shown below.  I'm trying to prove it's not firewall or Exchange.  All emails relay via Symantec.

    2016-11-18 02:32:45 PMDelivery attempt #1
    2016-11-18 02:32:45 PMRecipient server: 0.0.0.0
    2016-11-18 02:32:45 PMResponse: 421 4.4.0 [internal] no MXs for this domain could be reached at this time
    2016-11-18 02:40:12 PMDelivery attempt #2
    2016-11-18 02:40:12 PMRecipient server: 0.0.0.0
    2016-11-18 02:40:12 PMResponse: 421 4.4.0 [internal] no MXs for this domain could be reached at this time
    2016-11-18 02:52:38 PMDelivery attempt #3 (final)
    2016-11-18 02:52:38 PMRecipient server: VALID.IP (DNS HOST)
    2016-11-18 02:52:38 PMResponse: 250 2.6.0 <1479479501244-aa7bc034-225f0dc9-6ad9dba9@ringcentral.com>

    Saturday, December 3, 2016 12:38 PM