Can't run any program as administrator


  • I can't run any program as administrator on Windows 8 Enterprise, 64 bit. I am the only user and administrator. All programs that I have tried now, notepad through cmd, run smoothly as 'normal' none as admin (elevated cmd not from Win+X either). When I try, I see the 'system busy' cursor for a second, then nothing (no error message either). I am not aware of any change in my system since it worked as it should.

    In safe mode I could run sfc/scannow, and open its log. The program finished with reporting that it had found but could not fix some corrupt system files. In the log these lines may refer to some issue (I am no expert):

    CBS    Failed to resume suspended COM objects. [HRESULT = 0x80004015]

    CBS    Failed to initialize all COM objects, ignore the failure since service is shutting

    CBS    Failed during startup processing, continuing with Trusted Installer execution [HRESULT = 0x80070bc2]

    CBS    SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_std.sqm, flags: 0x2 [HRESULT = 0x80004005 - E_FAIL]

    CBS    SQM: Failed to start standard sample upload. [HRESULT = 0x80004005 - E_FAIL]

    CBS    SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_all.sqm, flags: 0x6 [HRESULT = 0x80004005 - E_FAIL]

    CBS    SQM: Failed to start always sample upload. [HRESULT = 0x80004005 - E_FAIL]

    CBS SQM: Warning: Failed to upload all unsent reports. [HRESULT = 0x80004005 - E_FAIL]

    CBS    Startup: Failed to initiate a rollback transaction. A restart will be performed, prior to trying again. [HRESULT = 0x8000ffff - E_UNEXPECTED]

    CBS    Registry value for the force canceled transactions is not available. Resetting. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]

    CBS    Failed during startup processing, continuing with Trusted Installer execution [HRESULT = 0x800f0923]

    ‘Automatic Repair’ also reported to have found but unable to fix some problems, while, however, ‘MS Fixit’ said the system is fine nothing to repair.

    Thank you.

    Saturday, September 07, 2013 6:14 AM

All replies

  • Hi George XY,

    Please try the following methods to solve this issue:

    Method 1: Scan and Restore computer’s health.

    1. Press Windows + x, Click Command Prompt (Admin), and click Yes to continue.
    2. Type DISM.exe /Online /Cleanup-image /Scanhealth, press Enter
    3. Type DISM.exe /Online /Cleanup-image /Restorehealth, press Enter.

    Method 2: Perform system restore to previous working date.

    1. Boot from the Windows 8 DVD.
    2. Click on Repair your computer once you get the welcome screen of      installation with the option Install now.
    3. Click on Advanced Options on the next page.
    4. Select System Restore and check you can start the computer.

    System Restore disclaimer: When you use System Restore to restore the computer to a previous state, programs and updates that you installed are removed.

    Method 3: Perform the Automatic Repair tool

    The Automatic Repair tool automates common diagnostic and repair tasks for startup issues.

    1. Insert a Windows 8 DVD, or a flash drive with the Windows 8 installation files on it, into your computer.
    2. Boot to the System Recovery Options screen, and click on Advanced options and Automatic Repair.
    3. If prompted, choose the OS (ex: Windows 8) that you want to do an Automatic Repair on.
    4. If prompted, select an administrator account.
    5. Automatic Repair will now start "Diagnosing your PC", and attempt to automatically repair them.


    Lany Zhang

    Sunday, September 08, 2013 1:35 PM
  • Thanks Lany, but I said I couldn't run any program, e.g. cmd as admin (Method 1), and that I'd tried Automatic Repair in vain (Method 3). As to Method 2, I'm in another continent, don't have the DVD here.

    However, I've just made a crucial discovery! The problem is only with the shortcuts. All shortcuts, e.g. cmd wouldn't start as admin from the main panel, nor from Win+X. Also, now, when I searched C: for 'command prompt', 15 (!) shortcuts turned out, none started elevated cmd (right click and pick 'run as administrator'). When, however I searched for 'cmd.exe' two direct hits (among several other, irrelevant) did! Then I tried notepad and a few other programs, and found the same. As I reported initially, none start as admin from the main panel, but now they did from the original location of their respective .exe files.

    So, now I tried Method 1 but got this:

    Error 87

    The online/cleanup-image/scanhealth option is unknown

    Then all I could find is:

    DISM enumerates, installs, uninstalls, configures, and updates, features and packages in Windows images. The commands that are available depend on the image being serviced and whether the image is offline or running.

    Anyway, I guess, the issue ain't as severe as it'd seemed. Sorry, for the inaccuracy first. However, it's still a nuisance, I hope with this clarification somebody tells me how to fix it.

    Thanks a lot.


    Sunday, September 08, 2013 4:53 PM
  • I've found how to enable the 'Run as Administrator' in Windows 2000 and XP in the support knowledge base 294676. I couldn't find, however, how to do it in Windows 8, please explain.

    I also noticed that Fixit has changed. As noted initially, I tried it, the version which I downloaded two months ago, in vain. Now, Fix it Center is offered but I couldn’t install it, always says

    ‘Fix it Center Setup encountered an error

    An unexpected error has occurred. Please close and try to run Setup again later.’

    How to eliminate this error?

    • Edited by George XY Monday, September 09, 2013 2:56 AM
    Monday, September 09, 2013 2:54 AM
  • Hi,

    Since Windows 8 has its inbuilt troubleshooter, there is no need to install Microsoft Fixit center.

    Please try the steps to fix it yourself.


    Lany Zhang

    Sunday, September 15, 2013 4:42 AM
  • This is not an answer! Please remove the answer mark.
    Thursday, February 13, 2014 5:58 AM
  • Did you solve this? I first had an issue with not accessing the "manage" under my computer and thougt it was only that issue. Today I was going to start the cmd as admin but is getting the same result as you.


    Testing a bit more. If I run CMD from the windows catalog I can run as administrator, but the shortcut under C: users\roaming does not

    • Edited by FNT Sunday, April 27, 2014 7:47 AM more info
    Sunday, April 27, 2014 7:27 AM