none
Error message using "Docpush" to verify FAST Search for SharePoint 2010 installation RRS feed

  • Question

  • Hi,

    I have installed FAST search for sharepoint following the Technet guide (http://technet.microsoft.com/en-us/library/ff381243.aspx) using windows server 2008 R2. I installed FAST in single server mode. This is a virtual machine, and I have in my setup separate domain controller, SharePoint 2010 and SQL 2008 R2. All servers run server 2008 R2, and are fully updated from Windows Update.

    When verifying the installation by feeding a single document as suggested by http://technet.microsoft.com/en-us/library/ff381272.aspx I get an error:

    PS C:\FASTSearch\bin> Docpush -c sp c:\temp\bob.txt
    [2010-07-12 14:02:49.621] ERROR      sp Reported error with http://cohowinery.com/c:\temp\bob.txt: processing:N/A:ProcessorDeploymentException: For pipeline 'Office14 (webcluster)', creating processor CompanyExtractorInclusionAny failed: ConfigurationError: CompanyExtractorInclusionAny: Failed to access or parse configuration file 'etc/resources/matching/configuration.companyextractor.inclusion.any.xml'. \\
    [2010-07-12 14:02:50.621] INFO       sp All add operations completed
    PS C:\FASTSearch\bin>

    In the event log I have several errors in the FAST Search log, such as:

    Resource not available on Resource store. Error: resource: dictionaries/matching/companies_inclusion_any.xml does not exist on resource store.

    CompanyExtractorInclusionAny: Failed to instantiate the matcher from 'etc/resources/matching/configuration.companyextractor.inclusion.any.xml'.

    Unable to acquire automaton since no filename was supplied.

    Unexpected exception occured during batch processing: ProcessorDeploymentException: For pipeline 'Office14 (webcluster)', creating processor CompanyExtractorInclusionAny failed: ConfigurationError: CompanyExtractorInclusionAny: Failed to access or parse configuration file 'etc/resources/matching/configuration.companyextractor.inclusion.any.xml'.

    When opening the file C:\FASTSearch\etc\resources\matching\configuration.companyextractor.inclusion.any.xml it cannot be parsed in IE, and in Notepad it looks corrupt:

    㘂ഇ䐋濩ᕺ໽��痡ᅷ❵煓蠉鄗曽咮↥煥䄃隱㑄揯沔㵅䵈⪛ෟ囷��뀼曖늜뢗ጥ喨킶ዽウꈆ缕ྂꩯ琀歧ኴ㎁녞殧ɉꯨ쀪℺풋ㅣ趨ႆᩦ姖ಮҚ洹橿띜뜁噩䷪揕溉릔丛烻穅ⶕອ咏⏽噶ፗ휐컴⢻㮊⮎쾠Ƈ䫎梮簅➑郘愚뒉曠ㆅᏫ謤搭쁛᯻ຽ㶌㏿ߒᣵ〳ﯹ玞㌨֠ⴼ㯀끃宴㈉퐅ṡ埳玓좤鳅ⳋꄺ��䗡퍂濧㿣ය��퓓맘ヲ蛉㭱쇼䈬㙭㫧䈄銷烕龹ᕈ刌臘ڹꑇ殺襡騕藟窔颻મ嗕姖囤ㄮ穃隀ꥰ侒鳳洼杜呦쪮ꩧᰀ轧ྡྷ땓બ࠘륒Ⴚ〄ꄕ羢䎒胉ఖ䞂鵽쪍ꄍ졪볋飬䢉⸔ᮀ儬ᒬ搐磈沶뉚ꚺ嵜

    When continuing with the next step in the verification process, Get-FASTSearchContentCollection -name "sp", I get the following error:

    PS C:\FASTSearch\bin> Get-FASTSearchContentCollection -name "sp" Get-FASTSearchContentCollection : Failed to communicate with the WCF service. At line:1 char:32
    + Get-FASTSearchContentCollection <<<<  -name "sp"
        + CategoryInfo          : OperationStopped: (:) [Get-FASTSearchContentCollection], AdminException
        + FullyQualifiedErrorId : e107: Failed to communicate with the WCF service.,Microsoft.SharePoint.Search.Extended.Administration.Commandlets.GetCollectionCommand
    PS C:\FASTSearch\bin>

    I have reinstalled FAST 3 times, each time with a failure..

     

    Best regards,

    Mikael André

     

    • Moved by hsalviMicrosoft employee, Moderator Wednesday, August 11, 2010 6:48 PM Moving to right Product (From:SharePoint 2010 - Setup, Upgrade, Administration and Operation)
    Monday, July 12, 2010 12:55 PM

All replies

  • Hi, thanks for your reply.

    Yes, I have read your thread, unfortunately a reinstall did not help for me.. I have static IP, and I have been following the technet guide when installing.

    Thursday, July 15, 2010 5:09 PM
  • Hello Mikael,

    I see that this is a new FAST installation. Failed to communicate with the WCF service can be because of multiple reasons . We certainly need to look at logs to further dig into what is going on here.

    Please log in to the FAST server with service account.  Open  fast server powershell management and  run the below command and  let me know the output

    nctrl status 

    Please post the output, however what I have seen this is primarily due to a incorrect configuration . I see you have tried a couple of times to install FAST but once again can you check the following post and ensure that all of the steps has been followed and the configuration for single server including certificate steps mentioned on the post matches the configuration actions that you have taken. 

    http://blogs.msdn.com/b/spses/archive/2010/04/09/installation-and-configuration-of-fast-search-server-for-sharepoint-2010.aspx

    Also Firewall exclusions and communication between boxes play a important role here . You can follow the steps below for a quick check on the WCF communication between SharePoint and FAST environment

    From Central Administration

    Central Administration>> Manage Service Applications>> FAST Query SSA>> FAST Search Administration>> Managed Properties.

    If the link does not display any error SharePoint has successfully connected to FAST server.  If you see an error here please post the same. 

    Browse to the FS14 search site created with FAST Search Centre Template

    Click on site actions >>site settings >>site collection administration >> FAST Search Keyword>> Add Keyword.

    If you are able to add a keyword SharePoint has successfully connected to FAST server.

    Often people forget to enable SharePoint enterprise site collection feature mentioned above. If you get an error while trying to add a keyword ensure you have the feature enabled. .

    Once you validate the setup with the post mentioned above and also do not see any issues with communication between Sharepoint and FAST you may also want to look at the KB article below.

    http://support.microsoft.com/?id=981297 Error message when you use PowerShell cmdlets to try to access managed properties in FAST Search Server 2010 for SharePoint: "Failed to communicate with the WCF service"

    ========================================================

    Regards

    Manas-MSFT

    Thursday, July 15, 2010 8:50 PM
  • Hello Mikael,

    I agree with Manas on his post. I would also like to suggest you to run Powershell command with -verbose switch and request you to post output here as well to see if we can find out what issue you are facing.

     

     


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Friday, July 16, 2010 3:07 AM
    Moderator
  • Mikael,

    I could solve the same problem. It was due to my dual homed server. You can check my solution here: http://social.msdn.microsoft.com/Forums/en/sharepoint2010setup/thread/b53b0799-6440-49fb-b726-0cb88d4c40e6 .

    hope this helps

    Alberto

    Friday, July 16, 2010 2:25 PM
  • I think I'm having similar problems.  I have Fast Search running - and the crawls work, searching works, etc.  However, when I go to Fast Search Administration and click on Managed Properties (or anything else on that page) I get an Error page with a correlation ID.  See below for what I pulled out of the logs.  Any clues what is wrong?  Mostly everything else seems to be working...

    <!-- /* Font Definitions */ @font-face {font-family:"Cambria Math"; panose-1:2 4 5 3 5 4 6 3 2 4; mso-font-alt:"Times New Roman"; mso-font-charset:0; mso-generic-font-family:roman; mso-font-pitch:variable; mso-font-signature:-1610611985 1107304683 0 0 415 0;} @font-face {font-family:Calibri; panose-1:2 15 5 2 2 2 4 3 2 4; mso-font-alt:"Arial Rounded MT Bold"; mso-font-charset:0; mso-generic-font-family:swiss; mso-font-pitch:variable; mso-font-signature:-520092929 1073786111 9 0 415 0;} /* Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal {mso-style-unhide:no; mso-style-qformat:yes; mso-style-parent:""; margin:0in; margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin;} .MsoChpDefault {mso-style-type:export-only; mso-default-props:yes; font-size:10.0pt; mso-ansi-font-size:10.0pt; mso-bidi-font-size:10.0pt;} @page WordSection1 {size:8.5in 11.0in; margin:1.0in 1.0in 1.0in 1.0in; mso-header-margin:.5in; mso-footer-margin:.5in; mso-paper-source:0;} div.WordSection1 {page:WordSection1;} -->

                    7888       Warning               A runtime exception was detected. Details follow.  Message: Thread was being aborted.  Technical Details: System.Threading.ThreadAbortException: Thread was being aborted.     at System.Threading.Thread.AbortInternal()     at System.Threading.Thread.Abort(Object stateInfo)     at System.Web.HttpResponse.End()     at System.Web.HttpServerUtility.Transfer(String path)     at Microsoft.SharePoint.Utilities.SPUtility.TransferToErrorPage(String message, String linkText, String linkUrl)     at Microsoft.Office.Server.Search.Extended.Administration.Internal.UI.ExtendedSearchCentralAdminPageBase.ReportError(String message)     at Microsoft.Office.Server.Search.Extended.Administration.Internal.UI.ExtendedSearchCentralAdminPageBase.HandleAdminOMExceptionIfAny(Exception ex)     at Microsoft.Office.Ser...  2d6778ec-df16-4bc0-9bf3-91cf8b7c3b05

    07/20/2010 15:11:07.58*               w3wp.exe (0x0860)                       0x15A8 SharePoint Server                           General                                       7888       Warning                 ...ver.Search.Extended.Administration.Internal.UI.ManagedPropertyManagement.FetchData(String searchKey, String searchValue, Int32 offset, Int32 pageSize, String sortExpression)     at Microsoft.Office.Server.Search.Extended.Administration.Internal.UI.ManagedPropertyManagement.InitializeGridView()     at Microsoft.Office.Server.Search.Extended.Administration.Internal.UI.ManagedPropertyManagement.OnLoad(EventArgs e)            2d6778ec-df16-4bc0-9bf3-91cf8b7c3b05

    07/20/2010 15:11:07.60 w3wp.exe (0x0860)                       0x15A8 SharePoint Server Search             Administration                                g4yw     Exception            (Watson Reporting Can

    Tuesday, July 20, 2010 7:18 PM
  • Hi, thanks for all your inputs. I was not aware of the msdn blog post, so I have now reinstalled (again...) following both the technet article and the blog post.

    The blog post has a validation section:

    Validating the SSA Configuration

    Follow the steps below for a quick check on the WCF communication between SharePoint and FAST environment

    From Central Administration

    Central Administration>> Manage Service Applications>> FAST Query SSA>> FAST Search Administration>> Managed Properties.

    If the link does not display any error SharePoint has successfully connected to FAST server.

    --> THIS WAS OK

    From Search Site

    Browse to the FS14 search site created above with FAST Search Centre Template

    Click on site actions >>site settings >>site collection administration >> FAST Search Keyword>> Add Keyword.

    If you are able to add a keyword SharePoint has successfully connected to FAST server.

    Often people forget to enable SharePoint enterprise site collection feature mentioned above. If you get an error while trying to add a keyword ensure you have the feature enabled.

    --> This failed with the message "Unexpected error occurred while communicating with Administration Service". I found the following in the log:

    Failed to connect to fast.<domain>:13391 sp. Error=Failed to initialize session with document engine: Unable to resolve Contentdistributor  [documentsubmitterworkerthread.cpp:132]  d:\office\source\search\native\gather\plugins\contentpi\documentsubmitterworkerthread.cpp 
    07/21/2010 15:20:11.10  mssearch.exe (0x0974)                    0x1550 SharePoint Server Search       Content Plugin                 dtz8 Medium   Failed to connect to fast.<domain>:13391. Attempt 23. Will wait for 60s before trying again.  [documentsubmitterworkerthread.cpp:185]  d:\office\source\search\native\gather\plugins\contentpi\documentsubmitterworkerthread.cpp 
    07/21/2010 15:20:11.25  mssearch.exe (0x0974)                    0x19C4 SharePoint Server Search       Content Plugin                 dtz5 High     Failed to connect to fast.<domain>:13391 sp. Error=Failed to initialize session with document engine: Unable to resolve Contentdistributor  [documentsubmitterworkerthread.cpp:132]  d:\office\source\search\native\gather\plugins\contentpi\documentsubmitterworkerthread.cpp 
    07/21/2010 15:20:11.25  mssearch.exe (0x0974)                    0x19C4 SharePoint Server Search       Content Plugin                 dtz8 Medium   Failed to connect to fast.<domain>:13391. Attempt 23. Will wait for 60s before trying again.  [documentsubmitterworkerthread.cpp:185]  d:\office\source\search\native\gather\plugins\contentpi\documentsubmitterworkerthread.cpp 

    After adding the application pool user to the local FAST Search Administrators group, this verification step was also successfull. This step was not mentioned in the blog, but is a part of the technet guide.

    I then ran the verification steps in the Technet article:

    nctrl status: All running
    PS C:\FASTSearch\bin> nctrl status
    Connecting to Node Controller at localhost:13260..
    Issuing 'status' request to Node Controller..

    Status for node : fast

    FAST Search      : C:\FASTSE~1
    Disk status     : 12% used - 112.89 GB free - 14.01 GB used - 126.90 GB total

    Module Name                     Process Name               PID  Status
    ------------------------------  --------------------  --------  --------------

    Browser Engine                  browserengine                   Running
    Config Server                   configserver              3292  Running
    Content Distributor             contentdistributor        3588  Running
    Enterprise Crawler              crawler                   2188  Running
    FDMWorker                       fdmworker                 5876  Running
    RTS Indexer                     indexer                   3712  Running
    Indexing Dispatcher             indexingdispatcher        5296  Running
    Name Service                    nameservice               2116  Running
    Document Processor              procserver_1              2632  Running
    Document Processor              procserver_2              2548  Running
    Document Processor              procserver_3              2436  Running
    Document Processor              procserver_4              2308  Running
    QRProxy Service                 qrproxy                         Running
    QRServer                        qrserver                  4984  Running
    SAM Admin                       samadmin                        Running
    SAM Worker                      samworker                       Running
    RTS Search                      search-1                  3724  Running
    Automatic spellcheck tuning     spelltuner                2552  Running
    SPRel                           sprel                     2920  Running
    RTS Top Dispatcher              topfdispatch              4436  Running
    WALinkStorerReceiver            walinkstorerreceiver      6128  Running
    WALookupDB                      walookupdb0               5936  Running
    WebAnalyzer                     webanalyzer               2020  Running

    PS C:\FASTSearch\bin>

    Docpush -> This is now working!
    PS C:\FASTSearch\bin> Docpush -c sp c:\temp\testing.txt
    [2010-07-21 14:46:39.553] INFO       sp All add operations completed
    PS C:\FASTSearch\bin>

    Verify that the document was indexed correctly -> this fails:

    PS C:\FASTSearch\bin> Get-FASTSearchContentCollection -name "sp"
    Get-FASTSearchContentCollection : Failed to communicate with the WCF service.
    At line:1 char:32
    + Get-FASTSearchContentCollection <<<<  -name "sp"
        + CategoryInfo          : OperationStopped: (:) [Get-FASTSearchContentColl
       ection], AdminException
        + FullyQualifiedErrorId : e107: Failed to communicate with the WCF service
       .,Microsoft.SharePoint.Search.Extended.Administration.Commandlets.GetColle
      ctionCommand

    PS C:\FASTSearch\bin>

    I installed inetmgr and verified that the application pool is running, and that the admin services site exists.

    Access http://localhost:13280/ and search for a term in the test document -> SUCCESS

    Search from SharePoint FAST Search site after my document -> SUCCESS

    Event log FAST Search Farm -> No errors, SUCCESS

    The event log on the SharePoint server however have several errors:
    Failed to connect to fast.<domain>:13391 Failed to initialize session with document engine: Unable to resolve Contentdistributor

    And warnings from content crawl:
    The start address http://sharepoint.<domain> cannot be crawled.

    Context: Application 'FAST_Connector', Catalog 'Portal_Content'

    Details:
     The object was not found.   (0x80041201)

     

    Sorry for the long post, but to sum up I now have three issues:

    1. Running "Get-FASTSearchContentCollection -name "sp"" gives the error "Failed to communicate with the WCF services"
    2. SharePoint event log reports "Failed to connect to fast.<domain>:13391 Failed to initialize session with document engine: Unable to resolve Contentdistributor"
    3. Content crawling from sharepoint results in "The object was not found". Is this perhaps a permission issue? what are the requirements?

     

    Wednesday, July 21, 2010 2:19 PM
  • Very interestingly, I am have similar sorts of problems, though my content crawling is working.  As I mentioned previously, when I go to Fast Search Administration and click on Managed Properties (or anything else on that page) I get an Error page with a correlation ID.  Everything else works.

    I do get exactly the same error when I run the Get-FASTSearchContentCollection test:

    PS C:\> Get-FASTSearchContentCollection -name "sp"
    Get-FASTSearchContentCollection : Failed to communicate with the WCF service.
    At line:1 char:32
    + Get-FASTSearchContentCollection <<<<  -name "sp"
        + CategoryInfo          : OperationStopped: (:) [Get-FASTSearchContentColl
       ection], AdminException
        + FullyQualifiedErrorId : e107: Failed to communicate with the WCF service
       .,Microsoft.SharePoint.Search.Extended.Administration.Commandlets.GetColle
      ctionCommand

     

    Wednesday, July 21, 2010 2:32 PM
  • Seems to be similar issues. I tested now all the other options on the FAST Search Administration page, together with the manage properties, and all of them was working.

    I have now added a file share as a content source as well, and I seem to have better luck with that one. Unfortunately I have very large files in the share, so I have not yet completed a full crawl. The SharePoint content source still has the issues mentioned above.

    Wednesday, July 21, 2010 3:39 PM
  • Have you also checked the steps in the article http://support.microsoft.com/?id=981297 Error message when you use PowerShell cmdlets to try to access managed properties in FAST Search Server 2010 for SharePoint: "Failed to communicate with the WCF service".

    Also are you using some sort of proxy server on these boxes or in your domain . You may want to ensure that there are no communication issues, try adding the server to bypass list in IE, or by making a hostfile entry .

    ========================================================

    Regards,

    Manas-MSFT

    Wednesday, July 21, 2010 4:41 PM
  • Hi, thanks for a quick reply.

    I have checked the support article from Microsoft, and the application pool is running and the web site exists.

    But I actually had a proxy issue, thanks for the tip! I am in a corporate network, and I am supposed to use "Use automatic configuration script" to get online. This has never caused any issues previously, but obviously it did now.. I modified this to instead hardcode a proxy server, bypass local addresses, and add the fast and sharepoint servers to the exceptions list. I am now able to run Get-FASTSearchContentCollection -name "sp" without any problems :)

    But I am still not able to crawl sharepoint sites. I have in the FAST Connector SSA added the address http://sharepoint.<domain> to the start address, and in the FAST Query SSA I have added sps3://mysite.sharepoint.<domain>. I have verified that the search service account have "Full read" on both web applications and on the user profile service application. When starting a Full crawl, the following messages appear in the event log:

    The start address http://sharepoint.<domain> cannot be crawled.

    Context: Application 'FAST_Connector', Catalog 'Portal_Content'

    Details:
     The object was not found.   (0x80041201)

    and:

    The start address sps3://mysite.<domain> cannot be crawled.

    Context: Application 'FAST_Query_SSA', Catalog 'Portal_Content'

    Details:
     The object was not found.   (0x80041201)

     

    I have also added a file share as a content source, and I am able to crawl that without any problems.

     

    Wednesday, July 21, 2010 5:36 PM
  • I have found some errors from the SharePoint log as well:

    HTTP Protocol Handler          High     CHttpAccessorHelper::InitRequestInternal - unexpected status (404) on request for 'http://sharepoint.<domain>' Authentication 0.  [httpacchelper.cxx:657]  d:\office\source\search\native\gather\protocols\http\httpacchelper.cxx
    GatherPI                       High     advising status change NSC_FLUSH (e12f870a-5c59-4132-9abe-eab46c8eca67-crawl-0 Portal_Content crawl -1)  [gatherobj.cxx:4512]  d:\office\source\search\native\gather\server\gatherobj.cxx
    GatherPI                       Medium   processing status change (1) NSC_FLUSH, (e12f870a-5c59-4132-9abe-eab46c8eca67-crawl-0, Portal_Content) thread id 0x1c24  [statthrd.cxx:97]  d:\office\source\search\native\gather\server\statthrd.cxx
    GatherPI                       High     CGthrPrj::AdviseStatusChange : advising status change NSC_FLUSH (Portal_Content e12f870a-5c59-4132-9abe-eab46c8eca67-crawl-0 )  [cgatherprj.cxx:1698]  d:\office\source\search\native\gather\gthrsvc\cgatherprj.cxx
    GatherPI                       High     CPluginCollection::AdviseStatusChange : advising status change NSC_FLUSH (Portal_Content e12f870a-5c59-4132-9abe-eab46c8eca67-crawl-0 )  [plugin.cxx:921]  d:\office\source\search\native\gather\gthrsvc\plugin.cxx
    GatherPI                       High     CPluginCollection::AdviseStatusChange : advising status change NSC_FLUSH (Portal_Content e12f870a-5c59-4132-9abe-eab46c8eca67-crawl-0 )  [plugin.cxx:921]  d:\office\source\search\native\gather\gthrsvc\plugin.cxx
    Content Plugin                 Medium   Received signal: NSC_FLUSH                                                      [contentpiobj.cxx:213]  d:\office\source\search\native\gather\plugins\contentpi\contentpiobj.cxx
    Gatherer                       Warning  The start address http://sharepoint.<domain> cannot be crawled.  Context: Application 'FAST_Connector', Catalog 'Portal_Content'  Details:  The object was not found.   (0x80041201)

    Wednesday, July 21, 2010 7:59 PM
  • Well, I'm not making progress.  Get-FASTSearchDocumentProcessingPipeline fails with "Access is denied".  I installed IIS Manager on the fast search host and verified that FASTSearchAdminServices is running.  The Application Pool is up and looks good.  So, why can't Get-FASTSearchDocumentProcessingPipeline communicate with the service?  This appears to be a simple permission issue.
    Thursday, July 22, 2010 2:53 PM
  • Isnt that a different issue from what you reported earlier? Are you running power shell as administrator?
    Thursday, July 22, 2010 4:38 PM
  • Hello Mikael,

    Good to know that now you are able to run Get-FASTSearchContentCollection -name "sp" without any problems

    The start address http://sharepoint.<domain> cannot be crawled can be because of AAM(alternate acess mappings) settings as well . Looks like you have Sharepoint server FQDN url on your default zone .
    Run a stsadm -o enumzoneurls or keep a printscreen of the AAM settings before you follow the next steps. Can you change the AAM and try with just having  http://servername , also check the content source has the same start address . Before starting a crawl please ensure that you are able to browse to the site with http://servername from SharePoint and FAST box in a browser.

    Considering you have to use FQDN you may want to modify the Public URL for the Default zone to be the FQDN hostheader used for accessing the site. Then add http://server as the internal URL for the Default zone.
    Once finished, the mappings look like the following:

    Private - Zone - Public
    http://FQDN - Default - http://FQDN
    http://server - Default - http://FQDN

    Hope this helps

    ============================================

    Regards

    Manas-MSFT

    Thursday, July 22, 2010 5:14 PM

  • Hello Siegeld

    Looks like you are facing a different issue then what Mikael has mentioned . You may want to check permissions on the FAST Serach folder <install location > sometimes noticed due to UAC enabled on the boxes,ensure that both the service account and the computer account is a member of FASTSearchAdministrators group.Also after logging in with the service account of FAST run a powershell as an administrator and check nctrl status and also see if you are able to start and stop the services and see if it helps.

    =====================================

    Regards

    Manas-MSFT

    Thursday, July 22, 2010 5:15 PM
  • It's the same issue - none of the cmdlets can communicate with WCF service.  I am running as administrator.  I've verified from IIS Manager that the FASTSearchAdminAppPool application pool is running properly, and that the FASTSearchAdminServices are running.  Not sure why Get-FASTSearchDocumentProcessingPipeline and other commands fail.
    Thursday, July 22, 2010 5:16 PM
  • Manas,

    Thanks for your tips. 

    I checked FASTSearchAdministrators and it had the service account and computer name - that's good.  I then logged in to the service account, and presto, Get-FASTSearchDocumentProcessingPipeline worked just fine.  When logged in as domain administrator, Get-FASTSearchDocumentProcessingPipeline fails.  It seems I am on to something...

    Let me remind you why I am running these tests.  I get this same error when I am on the SharePoint server host, trying to run various FAST administration commands from the SharePoint administration site.  Note that I have set the "Account for Administration Service" on the "Edit Search Service Application" properties page to be by fast search service account, the same account that I just tested, as I just described.

    So, what do you think?

    David

    Thursday, July 22, 2010 6:30 PM
  • Hi, thanks for your tips. I modified the alternate Access mapping, and the error message changed..

    AAM:

    Internal URL Zone Public URL for Zone
    http://sharepoint:2010  Default http://sharepoint:2010
    http://mysite.sharepoint.<domain>  Default http://mysite.sharepoint.<domain>
    http://mysite  Default http://mysite.sharepoint.<domain>
    http://sharepoint.<domain>  Default http://sharepoint.<domain>
    http://sharepoint  Default http://sharepoint.<domain>

    The content source (auto generated) in the FAST Query SSA:
    http://sharepoint
    sps3://mysite

    When running a crawl, the following error appears:

    The start address sps3://mysite cannot be crawled.

    Context: Application 'FAST_Query_SSA', Catalog 'Portal_Content'

    Details:
     The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly. If the repository was temporarily unavailable, an incremental crawl will fix this error.   (0x80041200)

    The start address http://sharepoint cannot be crawled.

    Context: Application 'FAST_Query_SSA', Catalog 'Portal_Content'

    Details:
     The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly. If the repository was temporarily unavailable, an incremental crawl will fix this error.   (0x80041200)

    Thursday, July 22, 2010 6:54 PM
  • Hi mikaelandre,

    you need to crawl http://sharepoint2010 URL using Content SSA and not Query SSA.

    Following URL should be only URL you would need to crawl from Query SSA sps3://mysite.sharepoint.<domain>

    Also Make sure that you can browse your SharePoint site and mysite web application from Server running Crawl Component.

     

     


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Thursday, July 22, 2010 10:51 PM
    Moderator
  • Hi Hiran,

    Yes, I have tried that as well. I modified now according to your instructions:

    FAST Content SSA source: http://sharepoint
    FAST
    Query SSA source: sps3://mysite

    Crawl log errors:
    The start address sps3://mysite cannot be crawled.

    Context: Application 'FAST_Query_SSA', Catalog 'Portal_Content'

    Details:
     The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly. If the repository was temporarily unavailable, an incremental crawl will fix this error.   (0x80041200)

    The start address http://sharepoint cannot be crawled.

    Context: Application 'FAST_Connector', Catalog 'Portal_Content'

    Details:
     The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly. If the repository was temporarily unavailable, an incremental crawl will fix this error.   (0x80041200)

     

    I have only one SharePoint server (but installed as farm in complete mode), and one FAST server. I am able to access both http://sharepoint and http://mysite using the account domain\_spsearch from both machines.

    From both machines I am asked for password twice before the site is opened, and when the page opens the URL in the browser is the FQDN. Could this be a problem?

     

    Friday, July 23, 2010 7:04 AM
  • Hello mikaelandre,

    Can you make sure that your SharePoint Server can communicate with Fast Server on FQDN.

    Also can you check your ULS logs for Search related Error when you run crawl.

    One more thing to verify whether you can browse the SharePoint site from server running Crawl Component.

     


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Friday, July 23, 2010 3:46 PM
    Moderator
  • Hi again, I have tested the points mentioned:

    -- Can you make sure that your SharePoint Server can communicate with Fast Server on FQDN.

    Ping fast.<domain> = OK
    Accessing http://fast.<domain> in internet explorer = OK (IIS7 default page displayed)
    Accessing http://fast.<domain>:13257/ContentCollectionService.svc = OK

    -- Also can you check your ULS logs for Search related Error when you run crawl.
    The relevant pars (I think) are:

    SharePoint Server Search       HTTP Protocol Handler          High     CHttpAccessorHelper::InitRequestInternal - unexpected status (503) on request for 'http://sharepoint/robots.txt' Authentication 0.  [httpacchelper.cxx:657]  d:\office\source\search\native\gather\protocols\http\httpacchelper.cxx
    SharePoint Server Search       HTTP Protocol Handler          High     CHttpAccessorHelper::InitRequestInternal - unexpected status (503) on request for 'http://sharepoint/robots.txt' Authentication 0.  [httpacchelper.cxx:657]  d:\office\source\search\native\gather\protocols\http\httpacchelper.cxx
    SharePoint Server Search       GatherPI                       High     advising status change NSC_FLUSH (e12f870a-5c59-4132-9abe-eab46c8eca67-crawl-0 Portal_Content crawl -1)  [gatherobj.cxx:4512]  d:\office\source\search\native\gather\server\gatherobj.cxx
    SharePoint Server Search       Gatherer                       Warning  The start address http://sharepoint cannot be crawled.  Context: Application 'FAST_Connector', Catalog 'Portal_Content'  Details:  The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly. If the repository was temporarily unavailable, an incremental crawl will fix this error.   (0x80041200)

     

    -- One more thing to verify whether you can browse the SharePoint site from server running Crawl Component.
    Not sure which server runs the Crawl component, but I can reach http://sharepoint both from the SharePoint server and from the FAST server.

     

     

    Friday, July 23, 2010 4:36 PM
  • I have also tried turning off the firewall, and adding http://sharepoint as public URL in AAM to prevent the two time authentication explained above, but without success.
    Friday, July 23, 2010 4:43 PM
  • Hello Mikael,

    Have you enabled SSL Communication for your Content SSA on each SharePoint Server running Crawl Component? If not make please follow steps as per following TechNet Article http://technet.microsoft.com/en-us/library/ff381261.aspx#BKMK_Configure_ssl_enabled_communication 

     

     


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Monday, July 26, 2010 4:35 PM
    Moderator
  • Hi Hiran, thanks for the reply. I have followed the SSL steps in the guide on my SharePoint server (I only have one), so this should be OK.

    Is there some way to remove the certificate and redo the process in case I did something wrong the first time? Or can I just do the same steps one more time without first removing the existing certificate?

    Monday, July 26, 2010 8:01 PM
  • Hi Mikael,

    I would say that just goahead and redo the steps. Account you need to specify is the account which is running osearch14 service in windows. you can find that user by going to services.msc and looking at SharePoint Server Search Service's Identity.

     


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Tuesday, July 27, 2010 2:56 PM
    Moderator
  • Hi again,

    I redid the steps, but without luck. The message when installing the certificate was:

    Updated acls on certificates private keys.
    Your FAST Search Connector has been setup to use certificate, restarting osearch
    14.
    Connection to contentdistributor fast.<dom<in>:13391 successfull
    y validated.

    But the error in the event log and crawl log is the same as before. When restarting Osearch14 (done when installing the certificate) generated another error in the event log:

    Volume Shadow Copy Service error: The process that hosts the writer with name OSearch14 VSS Writer and ID {0ff1ce14-0201-0000-0000-000000000000} does not run under a user with sufficient access rights. Consider running this process under a local account which is either Local System, Administrator, Network Service, or Local Service.

    Operation:
       Initializing Writer

    Context:
       Writer Class Id: {0ff1ce14-0201-0000-0000-000000000000}
       Writer Name: OSearch14 VSS Writer

     

    Could this be related? I am using a domain account, and I think I have configured the permissions according to the Technet documentation. The account is not a local administrator (mentioned in the error message), is that necessary?

     

    Thanks,

    Mikael

     

    Tuesday, July 27, 2010 3:46 PM
  • Hi Mikael,

    Did you run SharePoint Admin Shell as Administrator?

    If yes then

    Do you have Volume Shaow Copy Service Running and Configured. It looks like that is causing some issues here. 

    Check Status of SharePoint Server Search14 in services.msc My guess is that you will find it stopped or in stopping or starting state

    do following from Command Prompt

    net stop osearch14

    net start osearch14

    let us know if you get any error there. I guess you will get Same Error Message.

    Aslo check any events logged with Application  Event logs or System Event logs in Event Viewer

     

     


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Tuesday, July 27, 2010 4:35 PM
    Moderator
  • Hi,

    Yes, I did run it as an administrator.

    I am not sure what the Volume Shadow Copy Service is, but I see the service "SharePoint 2010 VSS Writer" in the list, and it is not started (manual). I have now added the search account to local administrators (as a step to find the error), and the VSS error disappeared.

    SharePoint Server Search 14 has status "Started", type "Manual" and user is my _spsearch account.

    Net stop osearch14 gives:
    From command liner: No errors (".... was stopped successfully").
    Application event log:

    Event ID 2
    The search service stopped normally.

    Event ID 1530
    Windows detected your registry file is still in use by other applications or services. The file will be unloaded now. The applications or services that hold your registry file may not function properly afterwards. 

     DETAIL -
     15 user registry handles leaked from \Registry\User\S-1-5-21-895965465-431640234-685831431-1186:
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Microsoft\SystemCertificates\Root
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Policies\Microsoft\SystemCertificates
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Policies\Microsoft\SystemCertificates
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Policies\Microsoft\SystemCertificates
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Policies\Microsoft\SystemCertificates
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Microsoft\SystemCertificates\SmartCardRoot
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Microsoft\SystemCertificates\Disallowed
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Microsoft\SystemCertificates\TrustedPeople
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Microsoft\SystemCertificates\trust
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Microsoft\SystemCertificates\My
    Process 572 (\Device\HarddiskVolume2\Windows\System32\lsass.exe) has opened key \REGISTRY\USER\S-1-5-21-895965465-431640234-685831431-1186\Software\Microsoft\SystemCertificates\CA

    Event ID 1
    The search service started.

    Looking in Services I see that SharePoint Server Search is started, so no need to run the command net start osearch14. This happened automatically.

     

    Mikael

    Tuesday, July 27, 2010 5:26 PM
  • I see the following error in the event log from the last time I rebootet (earlier today):

    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (965b3ad5-4276-4184-ac94-43291f24b3cc).

    Reason: Object 55e13a86-7f11-4401-975c-d232ac46073e-query-0 not found.

    Technical Support Details:
    System.Collections.Generic.KeyNotFoundException: Object 55e13a86-7f11-4401-975c-d232ac46073e-query-0 not found.
       at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
       at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)


    Perhaps this is also related?

     

    Mikael

    Tuesday, July 27, 2010 5:43 PM
  • Hi Mikael,

    If you have multiple Search SSA's then one of your SSA has query component not available.

    Thanks,

    Hiran


    Reagrds,

    Hiran
    Microsoft Online Community Support
    Wednesday, July 28, 2010 12:37 PM
    Moderator
  • Hi,

    I have two FAST SSAs, and I get the same error from both.

    "FAST Connector" = FAST Search Connector
    Used to crawl http://sharepoint

    "FAST Query SSA" = FAST Search Query
    Used to crawl sps3://mysite.sharepoint.innolab.no.accenture.com

    Is this not correct? When running Full crawl I get the same error from both.

     

    Thanks,

    Mikael André

    Wednesday, July 28, 2010 5:41 PM
  • Hello Mikael,

    Do you still get the error CHttpAccessorHelper::InitRequestInternal - unexpected status (503) on request for 'http://sharepoint/robots.txt' Authentication 0.  [httpacchelper.cxx:657]  d:\office\source\search\native\gather\protocols\http\httpacchelper.cxx , If yes please check if you are able to browse to SharePoint URL from SharePoint and FAST box after you have logged in with the crawling account .Also is the location d:\office\source\search\native\gather\protocols\http\httpacchelper.cxx  accessible once you are logged in with the same account. Please ensure that the webapplication and the FAST SSA  you are initiating a crawl is a part of the same proxy group .

    Also what type of authentication do you have on the SharePoint webapplication. Please check if you have Windows Integrated and anonymous both checked on the webapplication. Also can you check the web.config on your SharePoint webapplication and check the parameter impersonation within it. Do you have it set to true or false. 

    If you  are not getting the above error message please start a full crawl and post the error message you get .

    Thanks,
    ===============================================
    Regards,
    Manas

    Monday, August 2, 2010 3:27 PM
  • Hi, thanks for your reply.

    I still get the CHttpAccessorHelper error in the sharepoint logs, but I cannot find d:\office\source\search\native\gather\protocols\http\ anywhere... I do not have a d:\ station either on my sharepoint server or on my FAST server. d:\ is the hyper-V DVD station on both machines..

    I logged in to both machines using the _spsearch account, and I can browse to the sharepoint site. I do not have access to d:\office\... as it does not exist.

    The FAST Connector SSA is not part of the default proxy group, only the FAST Query SSA. This is as specified in the technet guide: http://technet.microsoft.com/en-us/library/ff381251.aspx

    The sharepoint web application have Authentication Type: Windows, anonymous is disabled, Integrated authentication is enabled with Negotiate (Kerberos) specified. Is it required to have anonymous authentication enabled in order to get search to work?

    Web.config has:     <authentication mode="Windows" />
        <identity impersonate="true" />

     

    Thanks,

    Mikael

    Tuesday, August 10, 2010 2:16 PM
  • Hello Mikael,

    If you log in to your FAST box and type in http://servername:13280 and search for a keword ...do you get the results . Please check and let us know .

    Thanks,

    Manas.

    Tuesday, August 10, 2010 11:01 PM
  • Hi Manas,

    Accessing http://fast:13280 gives an error message (Internet Explorer cannot display the webpage), same with http://fqdn:13280 (fast is the server name). Accessing http://localhost:13280 gives the query page, and I can search but get 0 results. When I force a document into the index using docpush (which previously was not working but is working fine now), that document is retrieved from the search.

     

    Best regards,

    Mikael André

    Wednesday, August 11, 2010 9:12 AM
  • Hello Mikael,

    Thank you for the update . While accessing http://localhost:13280 you mentioned that you can search but get 0 results for a word which you are sure is in index means the document might not have been indexed at all .... looks like your Content SSA is not working properly . Since this is a new setup you may want to create a new Content SSA and new content source and check . However if it still does not work I suggest to open a paid support case so that we can analyze your environment, enable additional logging and find out the cause.  Please visit the below link to see the various paid support options that are available to better meet your needs. http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Thanks ,

    Manas

     

    Thursday, August 12, 2010 11:26 PM
  • Hi Manas,

    Thas is correct, the Content SSA is not working, this is the issue we have been discussing. When trying to crawl my sharepoint site I get the error mentioned above.

    Today I have created a new SSA, and the error message changed! After creating the new SSA I went through the steps in "Verify correct setup" from technet, and everything was OK. I then added my sharepoint site (http://sharepoint) as a content source, and got this error:

    The start address http://sharepoint cannot be crawled.

    Context: Application 'FAST_Content_SSA', Catalog 'Portal_Content'

    Details:
     Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled.   (0x80041205)

    I have verified the permissions on the web application, and the account _spsearch has Full Read. I even tried changing to Full Control, but no change. The sharepoint logs have this:

    HTTP Protocol Handler          CHttpAccessorHelper::InitRequestInternal - Access Denied PRTH_E_ACCESS_DENIED on request for 'http://sharepoint' hr =0x80041205  [httpacchelper.cxx:268]  d:\office\source\search\native\gather\protocols\http\httpacchelper.cxx
    GatherPI                       advising status change NSC_FLUSH (45c74e45-b997-4fbe-a685-6ae7688ec339-crawl-0 Portal_Content crawl -1)  [gatherobj.cxx:4512]  d:\office\source\search\native\gather\server\gatherobj.cxx
    Gatherer                       The start address http://sharepoint cannot be crawled.  Context: Application 'FAST_Content_SSA', Catalog 'Portal_Content'  Details:  Access is denied. Verify that either the Default Content Access Account has access to this repository, or add a crawl rule to crawl this repository. If the repository being crawled is a SharePoint repository, verify that the account you are using has "Full Read" permissions on the SharePoint Web Application being crawled.   (0x80041205)
    GatherPI                       processing status change (1) NSC_FLUSH, (45c74e45-b997-4fbe-a685-6ae7688ec339-crawl-0, Portal_Content) thread id 0x1930  [statthrd.cxx:97]  d:\office\source\search\native\gather\server\statthrd.cxx
    GatherPI                       CGthrPrj::AdviseStatusChange : advising status change NSC_FLUSH (Portal_Content 45c74e45-b997-4fbe-a685-6ae7688ec339-crawl-0 )  [cgatherprj.cxx:1698]  d:\office\source\search\native\gather\gthrsvc\cgatherprj.cxx
    GatherPI                       CPluginCollection::AdviseStatusChange : advising status change NSC_FLUSH (Portal_Content 45c74e45-b997-4fbe-a685-6ae7688ec339-crawl-0 )  [plugin.cxx:921]  d:\office\source\search\native\gather\gthrsvc\plugin.cxx
    GatherPI                       CPluginCollection::AdviseStatusChange : advising status change NSC_FLUSH (Portal_Content 45c74e45-b997-4fbe-a685-6ae7688ec339-crawl-0 )  [plugin.cxx:921]  d:\office\source\search\native\gather\gthrsvc\plugin.cxx
    Content Plugin                 Received signal: NSC_FLUSH                                                      [contentpiobj.cxx:213]  d:\office\source\search\native\gather\plugins\contentpi\contentpiobj.cxx

     

    I have tried to figure out the necessary permissions for the search account, but not found anything useful. Could this be a permission issue? I use the same account _spsearch for everything related to search, it is used for the search service, ssa app pools and content access. It is not a local admin and not a farm admin.

    I have tried accessing http://sharepoint in a web browser using the _spsearch account, and I was able to access.

     

    Best regards,

    Mikael

     

     

     

    Friday, August 13, 2010 2:15 PM
  • Hello Mikael,

    Thank you for the update. This looks more likely to be some specific issue with this setup which needs some extensive troubleshooting and log analysis . Not sure if disabling loopback check http://support.microsoft.com/kb/926642/en-us would help in this scenario. <Article valid for 2008 as well>. I suggest to open a paid support case so that we can analyze your environment, enable additional logging and find out the cause.  Please visit the below link to see the various paid support options that are available to better meet your needs. http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Thanks ,

    Manas 

    Tuesday, August 17, 2010 12:54 AM