locked
Cannot unlock the taskbar RRS feed

  • Question

  • I am unable to rearrange the icons on the task bar of my laptop, despite having ‘Lock the toolbar’ deselected both in ‘Taskbar and Start Menu Properties’, and in the menu that appears when right-clicking the taskbar.

    If I try to move the icons they react in exactly the same way as when the lock is on, ie they jump back as soon as they are released.

    As far as I can see the settings on my laptop are identical to those on my workstation, except that I have Windows 7 32 bit on my laptop and 64 bit on my workstation.

    How can I fix this problem?

    Wednesday, December 9, 2009 8:24 PM

Answers

  • You can also try the following steps:

     

    Enable built-in admin account

    ==============

    1. Click Start, click "All Programs", please find and open "Accessories" folder.

    2. Please right-click on "Command Prompt" item and select "Run as administrator".

    3. Please type the following command line in to the coming window.

     

    net user administrator /active:yes

     

    Note: There is a space between "Administrator" and "/active:yes".

     

    4. Log off and log on the Administrator account.

     

    Please check if the taskbar works in the admin account. If not, try the following step:

     

    1. Click Start, type GPEDIT.MSC and press Enter.

    2.under User Configuration | Administrative Templates | Start Menu and Taskbar

    3. Set Lock the Taskbar policy to Not Configured 


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Thursday, December 17, 2009 3:07 AM
    Tuesday, December 15, 2009 7:28 AM
  • Thanks very much for the further posting!

    I wasn’t able to try the GPEDIT.MSC   option as I only have the Home Premium versions of Windows 7.

    Tried the command line suggestion, but although this worked initially, after a few reboots, it reverted back to being unable to unlock the taskbar icons.

    I thought this might indicate some other background problem, so I did a clean re-install of Windows.  However this has only partially fixed the problem -   I can now move the icons in the admin account, but not in the standard user account (even if I temporarily change it to an admin account).

    As I have downloaded all the latest software and driver updates, I presume this is a bug, and that there is not much I can do about it.

    Thanks anyway for your time.

    • Marked as answer by Vivian Xing Thursday, December 17, 2009 3:07 AM
    Wednesday, December 16, 2009 6:12 PM
  • Thanks for the further advice. 

     

    I spent quite a bit of additional time trying to track the problem down and eventually came to the conclusion that there was a problem with my network card, as I couldn’t connect to the internet using a cable.  This was despite having the latest drivers, and the Device Manager showing that it was working properly.  

    I disabled the card a few days ago, and I am pleased to report that my taskbar problem has not returned.

    Thanks again and Merry Xmas!


    • Marked as answer by Vivian Xing Monday, December 21, 2009 3:27 AM
    Saturday, December 19, 2009 4:46 PM

All replies

  • Hi,

     

    I would like to confirm if you see this  sign indicating that the taskbar is unlocked.

     

    What and how you move the icon and it does not work? In addition, are you in a domain?

     

    To troubleshoot this issue, I suggest testing it in Clean Boot mode first.

     

    If it does not work, try creating a new account.

     

    Create a new user account

    ====================

    1. Click the Start Button, type User Accounts in the start search pane and press Enter.

    2. Click Manage user accounts. 

    3. Click Create a new account, and type the name.

    4. Choose account type as Computer administrator.

    5. Click Create Account.

    6. Log off and log on with the new account.

     

    Does it work in the new account?


    Vivian Xing - MSFT
    Friday, December 11, 2009 8:41 AM
  • Thanks very much for the advice, but neither of these suggestions worked. I also don’t see the ‘unlocked’ icon in the left hand corner of the screen - however I don’t see it on my desktop PC, where the icons CAN be moved when the taskbar is unlocked. 

    If I try to move the icons on the laptop they move slightly then jump back to their original place.

    Grateful for any further suggestions.

    I should have mentioned that I am running Windows 7 64 bit on my desktop and the 32 bit version on my laptop.

    Saturday, December 12, 2009 6:41 PM
  • You can also try the following steps:

     

    Enable built-in admin account

    ==============

    1. Click Start, click "All Programs", please find and open "Accessories" folder.

    2. Please right-click on "Command Prompt" item and select "Run as administrator".

    3. Please type the following command line in to the coming window.

     

    net user administrator /active:yes

     

    Note: There is a space between "Administrator" and "/active:yes".

     

    4. Log off and log on the Administrator account.

     

    Please check if the taskbar works in the admin account. If not, try the following step:

     

    1. Click Start, type GPEDIT.MSC and press Enter.

    2.under User Configuration | Administrative Templates | Start Menu and Taskbar

    3. Set Lock the Taskbar policy to Not Configured 


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Thursday, December 17, 2009 3:07 AM
    Tuesday, December 15, 2009 7:28 AM
  • Thanks very much for the further posting!

    I wasn’t able to try the GPEDIT.MSC   option as I only have the Home Premium versions of Windows 7.

    Tried the command line suggestion, but although this worked initially, after a few reboots, it reverted back to being unable to unlock the taskbar icons.

    I thought this might indicate some other background problem, so I did a clean re-install of Windows.  However this has only partially fixed the problem -   I can now move the icons in the admin account, but not in the standard user account (even if I temporarily change it to an admin account).

    As I have downloaded all the latest software and driver updates, I presume this is a bug, and that there is not much I can do about it.

    Thanks anyway for your time.

    • Marked as answer by Vivian Xing Thursday, December 17, 2009 3:07 AM
    Wednesday, December 16, 2009 6:12 PM
  • Hi,

    Thank you for your reply.

    Lock and Unlock taskbar should work in Standard user account. As it occured in a newly installed system, it can be caused by third party programs and drivers. If you would like to troubleshoot it, you can install the drivers and software one by one and test this issue after each installation. 
    Vivian Xing - MSFT
    Thursday, December 17, 2009 3:25 AM
  • Thanks for the further advice. 

     

    I spent quite a bit of additional time trying to track the problem down and eventually came to the conclusion that there was a problem with my network card, as I couldn’t connect to the internet using a cable.  This was despite having the latest drivers, and the Device Manager showing that it was working properly.  

    I disabled the card a few days ago, and I am pleased to report that my taskbar problem has not returned.

    Thanks again and Merry Xmas!


    • Marked as answer by Vivian Xing Monday, December 21, 2009 3:27 AM
    Saturday, December 19, 2009 4:46 PM
  • Hi,

    Thank you for reply and letting us know the solution. It will be very helpful for troubleshooting similar issue in the future. Merry Xmas!
    Vivian Xing - MSFT
    Monday, December 21, 2009 3:27 AM