none
Could not start PsExec service RRS feed

  • Question

  • Hi there,

    I am facing difficulty in using pcexec , i am simply trying to use an ipconfig command and remote pc.

    both PCs are win Xps

    psexec \\10.10.xx.xx -u XXX -p XXX ipconfig

    but all am getting is

    PsExec v1.98 - Execute processes remotely
    Copyright (C) 2001-2010 Mark Russinovich

    Could not start PsExec service on 10.10.XX.XX:
    Access is denied.      HELP PLEASE


    • Edited by AL -23 Sunday, October 21, 2012 11:31 AM
    Sunday, October 21, 2012 8:37 AM

Answers

All replies

  • You need to turn your forward slashes into backslashes.
    Sunday, October 21, 2012 9:37 AM
  • oh sorry,

    this is typo i wrote it in the forum wrong . it is actually forward slashes . Thanks for pointing out :)


    now do you need to have anything to be enabled on the remote pc and/or do you need psexec on the remote pc as well ?
    • Edited by AL -23 Sunday, October 21, 2012 11:34 AM
    Sunday, October 21, 2012 11:24 AM
  • oh sorry,

    this is typo i wrote it in the forum wrong . it is actually forward slashes . Thanks for pointing out :)


    now do you need to have anything to be enabled on the remote pc and/or do you need psexec on the remote pc as well ?

    Sorry to say so again but you must use backslashes (\\).

    You do not need psexec on the remote PC and you do not need to enable anything. Turn off the firewall on both PCs while testing and make sure that the two PCs are on the same internal network and that they can ping each other.

    Sunday, October 21, 2012 11:45 AM
  • Thank you oberwald i thought you were saying i need to have it as forward slashes . you are right it needs to be back slashes.

    I can ping to the computer and i have a shared folder with it. however, i still can not connect using psexec.

    Monday, October 22, 2012 5:54 AM
  • Thank you oberwald i thought you were saying i need to have it as forward slashes . you are right it needs to be back slashes.

    I can ping to the computer and i have a shared folder with it. however, i still can not connect using psexec.

    Did you read my recommendation about the firewall?
    Monday, October 22, 2012 9:38 AM
  • yes no firewall inbetween
    Monday, October 22, 2012 9:45 AM
  • There is an inbuilt firewall in XP. Go Services and Stop Firewall Service and try again

    Thanks, Renjith V R

    Monday, October 22, 2012 11:19 AM
  • it should be something like this

    psexec \\marklap cmd

    ipconfig

    after you connect to the remote cmd then you issue "ipconfig"

    Monday, October 22, 2012 1:21 PM
  • Hi,


    For more information about how to use PsExec, we can refer to,


    PsExec v1.98 Download Page

    How PsExec works


    Hope this helps.


    Jeremy Wu

    TechNet Community Support

    Tuesday, October 23, 2012 6:03 AM
    Moderator
  • Hello, I cannot start a PowerShell script on a remote computer. The script is a modified version of DisableNetworkAdapterPnPCapabilities.ps1. (See the comments for my modification) PsExec copies the script to the computer but cannot start it. It can run ipconfig /all, and I've tried with COMPUTERNAME\administrator and password. I also tried with the -h, -i, -d, and/or -s flags. The script operates on the registry.

    PS - what I did was download a winrm module, used it (Set-WINRMListener and Restart-WinRM), and ran invoke-command with the computername and filepath parameters.

    • Edited by KWFJ Thursday, November 19, 2015 7:11 PM solved problem
    Tuesday, November 17, 2015 4:15 PM