none
Slow FIM Service Management Agent RRS feed

  • Question

  • Hey Guys,

          I just upgraded our production FIM 2010 setup from FIM 2010 R2 to FIM 2010 R2 SP1 build 4.1.3419.0. I updated both the portal and synchronization service both are running the same version however importing/syncing/exporting using the FIM MA is extremely slow. Any advice regarding speeding it up? 

    Saturday, May 24, 2014 2:56 AM

All replies

  • Have you seen these?

    http://technet.microsoft.com/en-us/library/hh322883(v=ws.10).aspx

    http://technet.microsoft.com/en-us/library/hh322920(v=ws.10).aspx

    They're both for R2 not R2 SP1. I think that most, if not all, of the performance tweaks are there by default in SP1 but it might be worth going through and checking. At least you might feel better knowing it used to be a lot worse.

    The FIM MA is talking to the FIM Web Service via SOAP hosted in IIS so anything you can do to speed that up will help. Also you can use Perfmon to track how quick the MA is going. I'd be interested in the object/sec that you're getting with SP1 exporting to the FIM Portal.

    Monday, May 26, 2014 2:53 AM
  • Sanoske312,

    Just to verify, you only changed the version of the FIM components, nothing on the back-end in SQL? I think Dan's suggestions above are good but upgrading from FIM R2 to the version you have by itself should not cause a sudden slowness...........Does restarting SQL server service help? If so it could be bad query plan in SQL and this has seemingly been reported in FIM R2 SP1 versions more than in others.......................

    Tuesday, May 27, 2014 4:59 AM