locked
Vista doesn't respond to any USB peripherial (Acer 9300 Laptop) RRS feed

  • Question

  • Hello,

    I have an Acer 9300 Laptop with Vista Family Premium Edition. All of its 3 USB ports used to function fine.
    Now each time I plug in any USB peripheral, Vista doesn't react and it's as if nothing is happening. The devices I plug don't get any voltage from the USB ports since their lights are off while connected.
    The USB drivers are installed properly in the Device Manager.

    Your help will be appreciated,
    Lior
    Thursday, November 1, 2007 6:18 PM

Answers

  • Hello Lior,

     

    Regularly, if USB devices cannot get power from USB ports, some hardware faults may exist. To narrow down the problem’s scope, please let me know:

     

    1.       Did all the USB devices stop working at one time, or only one or two devices stopped working? What are the devices?

    2.       Did all the USB ports stop power supply? Or only one port worked abnormally?

    3.       What happened before the problem occurred? Did you change any file or install any device?

     

    The answers to these questions are important for solving the problem. Please show me more detail.

     

    Regards,

    Lionel Chen

     

    Monday, November 5, 2007 11:03 AM

All replies

  • Hello Lior,

     

    Regularly, if USB devices cannot get power from USB ports, some hardware faults may exist. To narrow down the problem’s scope, please let me know:

     

    1.       Did all the USB devices stop working at one time, or only one or two devices stopped working? What are the devices?

    2.       Did all the USB ports stop power supply? Or only one port worked abnormally?

    3.       What happened before the problem occurred? Did you change any file or install any device?

     

    The answers to these questions are important for solving the problem. Please show me more detail.

     

    Regards,

    Lionel Chen

     

    Monday, November 5, 2007 11:03 AM
  • Hello,

     

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios.

     

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

     

    In addition, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

     

    Thanks!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

    Friday, November 16, 2007 11:08 AM
  • I have the same proplem on the same setup

    im on a Acer Aspire 9300 running Vista Home Premium

    i reinstalled Vista from my Acer Recorery CD and i flashed my bios

    -no USB

    is it a Vista thing or an Acer thing

    TQ
    Tuesday, March 4, 2008 7:11 PM
  • I am running Vista on a Compaq presario desktp. All of my USB ports stopped working at one time. My printer, my joystick and my speakers. Device Manager indicates everything is fine. I get a prompt that "the USB port has malfunctioned" then I get "unrecognized device".

    I was going to try a USB hub with external power but the computer is just over a year old.

    Wednesday, March 12, 2008 2:59 AM
  •  

    I have the same problem except i have 3 USB ports, 2 of which havent been working for a while, and the last one stopped working on the 4th of august, i cant use any devices and i get the same message "USB device Not recognised". I believe that this problem is Vista related and that it could be to do with an update that has been released. The laptop tells me that there are no drivers installed and that it doesnt need them and yet installing drivers for the usb belkin mouse i use doesnt help either. I have tried system restore and that doesnt solve the problem. Microsoft need to release an update to fix this problem. Either that or i have to buy a new laptop Sad

     

    Please hurry up and fix this please i need to play diablo 2 its important xD

    Tuesday, August 5, 2008 9:46 PM