none
Windows 10 GP WMI Filter

    Question

  • I have an issue in my SCCM 2012 R2 hardware\software inventory that appears to coincide with when I added the Windows 10 ADMX files into the central store. When I created the Windows 10 GPO I linked it to the WMI filter below. Being somewhat new to this process I had prepared in advance by reading\watching some videos and if I understand how this works the WMI link should have prevented the GPO from applying to any of the other operating systems we have, those being mainly Windows 7 SP1 with a small number of Windows 8\8.1. The GPO's for those OS's also have links to a WMI query that identifies the respective OS. Am I right in that this is how this should have worked?

    Namespace: root\CIMv2

    Query:     Select * from Win32_OperatingSystem where Version like ‘10%’ AND Product Type='1'

    Once I finally realized the issue in the SCCM sw\hw inventory had started at approximately the same time I disabled the GPO and deleted the WMI but I'm still seeing some issues in the hw inventory in SCCM which I have traced and determined that it's failing on the last step of the inventory process due to the error below. The inventory seems to be working somewhat now once the resynchronization occurs however I do not have any hardware history before the point I added the GP. What I've also discovered is certain processors (AMD, Intel Atom, Pentium Dual Core) do have older history but nothing that is an Intel Core processor does. How this would have been caused by the GP \WMI query is a bit confusing as the non-existent row it references, Work Station Status does show in the hw inventory, has nothing to do with the OS and looks the same for each different processor.

    ERROR - attempt to update non-existent row (sp = pWorkstationStatus_DATA). Invalid command:  exec dbo.pWorkstationStatus_DATA 1,16782407,'09/10/2015 12:43:39',1,'9/10/2015 12:42:39',N'12884901890',1033,-240

    • Rollback transaction: Machine=055RBANDAR
    • SQL MESSAGE: spAddInventoryLog - (no other data after the -)
    • Send resync command to local site for machine GUID:9380D2A9-A1C1-4C1F-892A-D4A0F248B52C

    My goal is to get the Windows 10 GPO with WMI link re-enabled without causing issues in SCCM but as I am not certain why it occurred in the first place I thought I'd start with the GP forum group before moving on to the SCCM forum.

    Thanks

    Thursday, September 10, 2015 8:32 PM

Answers

  • I just tested on a Win10 pc, using WMIexplorer;

    fails:
    Select * from Win32_OperatingSystem where Version like ‘10%’ AND Product Type='1'

    succeeds:
    SELECT * FROM Win32_OperatingSystem where version like '10%' and producttype='1'

    The difference is that the failing query (which I copied/pasted from your question, is using smart-quotes, i.e. angled/forward/backward.
    This *may* be an artefact of websites, in that some websites/blogs will silently "convert" the standard apostrophe/quote into "smart" quotes. WMI (and lots of other things) do not tolerate "smart" quotes, they do not recognise smart quotes as acceptable delimiters. This could be your issue. Although why it might devastate your HINV processing in ConfigMgr is not known to me.

    Note that this issue itself isn't caused by your adoption of updated ADMX templates, rather, a "bad" WMI filter containing illegal delimit characters is more likely.

    When I tried your original WQL, WMIexplorer barfed at it instantly, so I re-wrote the WQL by hand and it was fine, I then pasted both WQL statements into notepad and the smart-quotes issue was immediately obvious. (but I was half expecting that issue anyway, it's a nasty gotcha)


    Don


    • Edited by DonPick Thursday, September 10, 2015 9:28 PM
    • Proposed as answer by Alex LvModerator Tuesday, September 15, 2015 8:08 AM
    • Marked as answer by Alex LvModerator Tuesday, September 22, 2015 2:17 AM
    Thursday, September 10, 2015 9:26 PM