locked
AppHangB1 Resolution for Windows 7 and Office11 RRS feed

  • Question


  •  The Bottom line is to use a compatibility
     wizard in the control panel and let it
     figure out the correct settings for the
     older program.

     The below instructions are for Ms Access 2003
     aka Office11.

     Perhaps this method could be used on other
     troublesome programs.

     = = = = = = = = = = = = = = = = = = = = = = = = = = =

    When dealing with older Microsoft programs that have
    trouble function correctly within Windows-7 64 bit
    Professional there is a feature in the Control-Panel
    that might help.

    That feature used is the System and Security find and fix.

    In the case of using Microsoft Access 2003, 32 bit,
    under Windows-7, 64 bit, with complex code you can
    expect to have AppHangB1 errors, AppCrash errors, or
    in the case of early binding to Excel, from Access 2003
    VBA, to have the application simply freeze up.

    The Steps

    1). Open up the Control Panel in View by Category.

    2). Search for the ‘System and Security’ topic.

    3). Under the System and Security topic select the
        Find and Fix problems item.

    4). When the Troubleshooting window opens, select the
        Programs category.

    5). Then in the Compatibility window, click the Next.

        That feature will try to guess what program is
        having the problem.

    6). In the case of Access 2003, it didn’t show up in
        the list.  Therefore, you will have to click the
        Not-Listed category.  Then click the Next button.

    7). A Browse window will appear.

    8). Click the Browse button and go to the drive that has
        the application installed on it.  In this case select
        Computer and work your way to the C: drive.

    9). Since this is a 32 bit Microsoft application select
        the \Program Files(x86)\ folder.

    10). Next select the \Microsoft Office\ folder.

    11). Since we are using Office 2003, select the \Office11\ folder.

    12). Scroll down until you find the MsAccess.exe program.
         Click it and then click the Open button.

    13). You should see ->
            C:\Program Files(x86)\Microsoft Office\Office11\MsAccess.exe
        in the Browse line.
        Click the Next Button.
     
    14). Select ‘Try recommended settings’

    15). The Compatibility feature selected ‘XP mode (service pack 2)’.
         Click the Next button.

    16). Click ‘Yes, save these settings for this program’, and Click Next.

    17). You can also go to ->
           C:\Program Files(x86)\Microsoft Office\Office11\MsAccess.exe
         And do a Right-Mouse Click.

         Select Proprieties, then select compatibility tab.
         Check box ‘Run this program compatibility mode for:’
         And select Windows XP(Service Pack 2).

         Additionally turn on the ‘Run this program as an Administrator’.
         Select the ‘Change settings for all users’ button and Re-enter
         in all the information.

         Then you should be up and running.

     


    Ed505
    • Edited by Ed505 Tuesday, December 13, 2011 4:22 PM
    Tuesday, December 13, 2011 4:21 PM

Answers

  • Hi,

     

    Thanks for sharing. We really appreciate your time and efforts. Hope your experience will help other community members facing similar problems.

     

     

    Regards,

    Leo   Huang

     

     


    Leo Huang

    TechNet Community Support

    • Marked as answer by Leo Huang Wednesday, December 21, 2011 8:37 AM
    Thursday, December 15, 2011 8:04 AM
  •  

     

     Thank you for the kind words.

     The finial answer turned out to be simple.

     Just use the the compatibility wizard under the
     control panel's System and Security / Find and
     Fix menu items.

     Also I set the executable file to start up in
     administrative mode.


     


    Ed505
    • Marked as answer by Leo Huang Thursday, December 22, 2011 2:52 AM
    Wednesday, December 21, 2011 6:14 PM

All replies

  • Hi,

     

    Thanks for sharing. We really appreciate your time and efforts. Hope your experience will help other community members facing similar problems.

     

     

    Regards,

    Leo   Huang

     

     


    Leo Huang

    TechNet Community Support

    • Marked as answer by Leo Huang Wednesday, December 21, 2011 8:37 AM
    Thursday, December 15, 2011 8:04 AM
  •  

     

     Thank you for the kind words.

     The finial answer turned out to be simple.

     Just use the the compatibility wizard under the
     control panel's System and Security / Find and
     Fix menu items.

     Also I set the executable file to start up in
     administrative mode.


     


    Ed505
    • Marked as answer by Leo Huang Thursday, December 22, 2011 2:52 AM
    Wednesday, December 21, 2011 6:14 PM