locked
Problem with trusted location in Word2013 RRS feed

  • Question

  • I tried searching for this answer to no avail.

    I have 4 machines with office2013. I need to add a location on a server to these machines trusted locations. I can do this for user A, but when user B logs in, the trusted location is not there. I can add this in the registry, but it is also for the current user only.

    I downloaded the admin files and put them in the appropriate folder and they show up in the local group policy. gpedit.msc and drill into user config/admin temp/blah blah/trusted locations and did trusted locations on network and I used #4 since on all machines there are 3 local ones already set (not in GP, but in the programs trust center, don't know how or why, those are there).  Anyways I set it on #4 in GP and log in as a different user and none of the GP settings are there.  I am pretty sure we are blocking everything at the server level (no policy coming down) and we don't have any office addins there to begin with.

    What am I missing?

    TIA

    Thursday, January 30, 2014 11:33 PM

Answers

  • Hi,

    According to your description, my understanding is that you want to set a server location to trusted locations in 4 machines. Please try to use environment variables to specify Trusted Locations:

    1. Use Registry Editor to locate the trusted location that is represented by an environment variable.

      To open Registry Editor, click Start, click Run, type regedit, and then click OK.

      Or, if you are using Windows 8 or Windows 8.1, swipe from the right to reveal the charms, choose the Search charm, and type regedit.

      Trusted Locations that are configured by using the OCT are stored in the following location:

      HKEY_CURRENT_USER/Software/Microsoft/Office/15.0/application_name/Security/Trusted Locations                    

      Where application_name can be Access, Excel, PowerPoint, Visio, or Word.

      Trusted Locations are stored in registry entries named Path, and they are stored as String Value (REG_SZ) value types. Be sure to locate each Path entry that uses environment variables to specify a trusted location.

    2. Change the Path value type.

      Applications in the Office 2013 can’t recognize environment variables that are stored as String Value (REG_SZ) value types. For applications to recognize environment variables, you must change the value type of the Path entry so that it is an Expandable String Value (REG_EXPAND_SZ) value type. To do this, follow these steps:

      1. Write down or copy the value of the Path entry. This should be a relative path that contains one or more environment variables.

      2. Delete the Path entry.

      3. Create a Pathentry of type Expandable String Value (REG_EXPAND_SZ).

      4. Change the new Path entry so that it has the same value that you wrote down or copied in the first step.

      Be sure to make this change for each Path entry that uses environment variables to specify a trusted location.

    http://technet.microsoft.com/en-us/library/cc179039.aspx

    If it works fine and you want to use GP to set the trusted location. Please pay attention to make sure the user config/admin applies to all users. We could check the gpresult to check the GP log.

    http://technet.microsoft.com/en-us/library/cc733160.aspx

    Here is a similar issue:

    http://social.technet.microsoft.com/Forums/office/en-US/00cb610d-3c98-480b-9c43-e6ce77183e81/office-2013-trusted-locations-increase?forum=winserverGP

    More referencen:

    http://social.technet.microsoft.com/Forums/en-US/382c97e8-93c8-4022-b8fe-22401037d14c/forum-faq-common-steps-to-start-troubleshooting-group-policy-application-issues?forum=winserverGP

    If you had more further about the GP, please post your question to GP forum:

    http://social.technet.microsoft.com/Forums/en-US/home?forum=winserverGP

    Regards,

    George Zhao
    TechNet Community Support



    • Marked as answer by Tony Chen CHN Tuesday, February 11, 2014 6:20 PM
    Monday, February 3, 2014 2:32 AM