locked
DCDIAG returns different output in PowerShell RRS feed

  • Question

  • Hi,

    When I run the command dcdiag /test:RIDManager in PowerShell in my Domain Controller, I get the test as passed.
    But when I run it from another server in a different domain using Remote Session in PowerShell I get the test as failed.

    $testSession= New-PSSession -ComputerName <hostname> -Credential Get-Credential

    Invoke-Command -Session $testSession -ScriptBlock {dcdiag /test:RIDManager}

    This command gives passed when I use the hostname of the Primary Domain Controller but failed for the Secondary Domain Controller. This comes as failed only when I run the command from as Computer in another doamin.

    Error Received : DsBindWithSpnEx() failed with error 5, Access is denied..

    Please help to understand the issue.


    Thursday, May 9, 2019 1:03 PM

All replies

  • Many tools and programs cannot be run in a remote session.


    \_(ツ)_/

    Thursday, May 9, 2019 2:16 PM
  • Hi,

    Was your issue resolved?

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,

    Lee


    Just do it.

    Friday, May 31, 2019 7:50 AM